Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

BGP not distributing in EIGRP

I need some help determining why my BGP routes are not distributing in my EIGRP. I almost the same configs in a working enviroment, but in my test lab its only distributing the directly connected ports.

Here is my test lab:

Router 1

interface FastEthernet1/0

ip address 192.168.1.1 255.255.255.0

duplex auto

speed auto

!

interface Serial3/0

ip address 192.168.254.2 255.255.255.0

no fair-queue

!

router eigrp 100

redistribute connected

redistribute bgp 1

network 192.168.1.0

default-metric 10000 6000 255 1 1500

no auto-summary

!

router bgp 1

no synchronization

bgp log-neighbor-changes

redistribute connected

redistribute static

redistribute eigrp 100

neighbor 192.168.254.1 remote-as 1

default-information originate

no auto-summary

show ip route:

D 192.168.0.0/24 [90/30720] via 192.168.1.2, 01:14:43, FastEthernet1/0

C 192.168.254.0/24 is directly connected, Serial3/0

C 192.168.1.0/24 is directly connected, FastEthernet1/0

B 192.168.2.0/24 [200/0] via 192.168.254.1, 01:15:56

Router 2:

interface FastEthernet0/0

description tst

ip address 192.168.0.1 255.255.255.0

ip access-group 102 in

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.1.2 255.255.255.0

duplex auto

speed auto

!

router eigrp 100

redistribute static

network 192.168.0.0

network 192.168.1.0

no auto-summary

!

show ip route:

C 192.168.0.0/24 is directly connected, FastEthernet0/0

D EX 192.168.254.0/24 [170/2172416] via 192.168.1.1, 00:07:49, FastEthernet0/1

C 192.168.1.0/24 is directly connected, FastEthernet0/1

As you can see my BGP route from Router 1 is not being propagated to router 2. Is there something I'm overlooking. Any help is greatly appreciated.

Thanks.

7 REPLIES
Hall of Fame Super Blue

Re: BGP not distributing in EIGRP

Hi

When you redistribute into EIGRP you need to include metrics for the EIGRP routes or else they do not get redistributed.

So change to

router eigrp 100

redistribute bgp 1

to

router eigrp 100

redistribute bgp 1 1000 1 255 1 1500

HTH

Jon

Blue

Re: BGP not distributing in EIGRP

Jon:

He already has the default-metric command in place...

router eigrp 100

redistribute connected

redistribute bgp 1

network 192.168.1.0

default-metric 10000 6000 255 1 1500

no auto-summary

...configuring the metric on the same line as the redistribute command, like you suggest, allows you more granularity in the event that you want to assign different metrics to different protocols you're redistributing into EIGRP. But in its absence, the default-metric command will assign the same metrics to all redistributed protocols.

Victor

Hall of Fame Super Blue

Re: BGP not distributing in EIGRP

Yep, good point. I read the post a bit too quickly and missed that before going out to to the pub :-)

Apologies to the OP.

Jon

Cisco Employee

Re: BGP not distributing in EIGRP

Armando,

192.168.2.0/24 is learnt via iBGP (AD = 200). By default, IOS will not redistribute iBGP routes into an IGP. You need to configure the following command to change this default behavior:

router bgp 1

bgp redistribute-internal

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: BGP not distributing in EIGRP

Thanks. That did it. I kept seeing that command around but I didn't realize it was under the "router bgp."

I put in the command and restarted my routers and it worked.

Out of curiosity why would it work between my 6509 and 3845 without that command?

These are the commands under the 3845:

router eigrp 100

redistribute bgp 1 metric 19800 6000 255 1 1500

network A.A.A.A

no auto-summary

!

router bgp 1

no synchronization

bgp log-neighbor-changes

redistribute connected

redistribute static

redistribute eigrp 100

neighbor B.B.B.B remote-as 65000

default-information originate

no auto-summary

Cisco Employee

Re: BGP not distributing in EIGRP

Armando,

This is interesting that you are seeing a different behavior with the 3845. It should be the same.

Are you certain that the BGP route(s) that was redistributed in EIGRP on the 3845 was actually received from iBGP?

Regards,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: BGP not distributing in EIGRP

Sorry, they are actually all exterbal BGP routes. That's why it works.

Thanks hritter.

156
Views
10
Helpful
7
Replies