Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

New Member

BGP Not Running in MPLS Network

Hello All,

I'm trying to configure a Backbone running MPLS and BGP .. I've been able to establish MPLS between the routers. The PELeft and PERight will be connected to end routers where the end routers will be in separate VRFs (2 to be exact).

mpls-bgp.png

I have reachability between all the routers. I'm running OSPF in the Backbone between the 3 Routers, and BGP between PELeft and PERight.

Here are the configuration of the 3 Routers:

PELeft:

interface Loopback0

ip address 1.1.1.1 255.255.255.255

!

interface Serial0/0

ip address 10.10.10.2 255.255.255.0

mpls ip

clock rate 2000000

!

router ospf 1

log-adjacency-changes

network 1.1.1.1 0.0.0.0 area 0

network 10.10.10.0 0.0.0.255 area 0

!

router bgp 13879

bgp log-neighbor-changes

neighbor 2.2.2.2 remote-as 13879

!

address-family ipv4

  neighbor 2.2.2.2 activate

  no auto-summary

  no synchronization

exit-address-family

CorePRouter:

interface Serial0/0

ip address 10.10.10.1 255.255.255.0

mpls ip

clock rate 2000000

!

router ospf 1

log-adjacency-changes

network 10.10.10.0 0.0.0.255 area 0

network 10.10.20.0 0.0.0.255 area 0

PERight:

interface Loopback0

ip address 2.2.2.2 255.255.255.255

!

interface Serial0/0

ip address 10.10.20.2 255.255.255.0

mpls ip

clock rate 2000000

!

router ospf 1

log-adjacency-changes

network 2.2.2.2 0.0.0.0 area 0

network 10.10.20.0 0.0.0.255 area 0

!

router bgp 13879

bgp log-neighbor-changes

neighbor 1.1.1.1 remote-as 13879

!

address-family ipv4

  neighbor 1.1.1.1 activate

  no auto-summary

  no synchronization

exit-address-family

And for the reachability:

PERight#ping 1.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/25/76 ms

CorePRouter#sh mpls ldp n

    Peer LDP Ident: 10.10.10.2:0; Local LDP Ident 10.10.20.1:0

        TCP connection: 10.10.10.2.646 - 10.10.20.1.50623

        State: Oper; Msgs sent/rcvd: 48/50; Downstream

        Up time: 00:31:06

        LDP discovery sources:

          Serial0/0, Src IP addr: 10.10.10.2

        Addresses bound to peer LDP Ident:

          10.10.10.2      1.1.1.1

    Peer LDP Ident: 10.10.20.2:0; Local LDP Ident 10.10.20.1:0

        TCP connection: 10.10.20.2.12741 - 10.10.20.1.646

        State: Oper; Msgs sent/rcvd: 47/47; Downstream

        Up time: 00:31:03

        LDP discovery sources:

          Serial0/1, Src IP addr: 10.10.20.2

        Addresses bound to peer LDP Ident:

          10.10.20.2      2.2.2.2

Routes on All Routers:

CorePRouter:

CorePRouter#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets

O       1.1.1.1 [110/65] via 10.10.10.2, 00:30:12, Serial0/0

     2.0.0.0/32 is subnetted, 1 subnets

O       2.2.2.2 [110/65] via 10.10.20.2, 00:30:02, Serial0/1

     10.0.0.0/24 is subnetted, 2 subnets

C       10.10.10.0 is directly connected, Serial0/0

C       10.10.20.0 is directly connected, Serial0/1

PERight:

PERight#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets

O       1.1.1.1 [110/129] via 10.10.20.1, 00:27:28, Serial0/0

     2.0.0.0/32 is subnetted, 1 subnets

C       2.2.2.2 is directly connected, Loopback0

     10.0.0.0/24 is subnetted, 2 subnets

O       10.10.10.0 [110/128] via 10.10.20.1, 00:27:28, Serial0/0

C       10.10.20.0 is directly connected, Serial0/0

PELeft:

PELeft#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets

C       1.1.1.1 is directly connected, Loopback0

     2.0.0.0/32 is subnetted, 1 subnets

O       2.2.2.2 [110/129] via 10.10.10.1, 00:27:53, Serial0/0

     10.0.0.0/24 is subnetted, 2 subnets

C       10.10.10.0 is directly connected, Serial0/0

O       10.10.20.0 [110/128] via 10.10.10.1, 00:27:53, Serial0/0

But the BGP between the PERight and PELeft is not coming up

PERight#sh ip bgp summ | b N

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

1.1.1.1         4 13879       0       0        0    0    0 never    Active

PELeft#sh ip bgp summ | b N

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

2.2.2.2         4 13879       0       0        0    0    0 never    Active

What am I missing here?

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

BGP Not Running in MPLS Network

Hi Islam,

I believe you are missing the neighbor update-source commands in your BGP configuration.

PELeft should have:

router bgp 13879

neighbor 2.2.2.2 update-source Loopback0

and PERight should have:

router bgp 13879

neighbor 1.1.1.1 update-source Loopback0

I suspect that right now, your PELeft and PERight are trying to contact each other but they use ther IP addresses from serial interfaces as source IP addresses, and do not recognize each other under these addresses.

Try adding these commands to the configuration and give it a minute or so for the BGP peering to come up. If it does not help please post the output of show ip bgp neighbor from both PELeft and PERight. Thank you!

Best regards,

Peter

3 REPLIES
Cisco Employee

BGP Not Running in MPLS Network

Hi Islam,

I believe you are missing the neighbor update-source commands in your BGP configuration.

PELeft should have:

router bgp 13879

neighbor 2.2.2.2 update-source Loopback0

and PERight should have:

router bgp 13879

neighbor 1.1.1.1 update-source Loopback0

I suspect that right now, your PELeft and PERight are trying to contact each other but they use ther IP addresses from serial interfaces as source IP addresses, and do not recognize each other under these addresses.

Try adding these commands to the configuration and give it a minute or so for the BGP peering to come up. If it does not help please post the output of show ip bgp neighbor from both PELeft and PERight. Thank you!

Best regards,

Peter

New Member

BGP Not Running in MPLS Network

Thank You! This is what I was missing!     

Cisco Employee

BGP Not Running in MPLS Network

Hi Islam,

It has been a pleasure. Take care!

Best regards,

Peter

178
Views
0
Helpful
3
Replies
CreatePlease to create content