Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Bronze

BGP Peering

I have two router connected with EBGP peering , i can able to ping both router's IP address,but i cann't establish neighbour reliation ship.

following error messange in log message , can anybody tell me urgently

*Mar 1 03:54:39.022: BGP: Import timer expired. Walking from 1 to 1

*Mar 1 03:54:54.023: BGP: Import timer expired. Walking from 1 to 1

*Mar 1 03:55:09.024: BGP: Import timer expired. Walking from 1 to 1

*Mar 1 03:55:24.024: BGP: Performing BGP general scanning

*Mar 1 03:55:24.024: BGP(0): scanning IPv4 Unicast routing tables

*Mar 1 03:55:24.036: BGP(IPv4 Unicast): Performing BGP Nexthop scanning for gen

eral scan

*Mar 1 03:55:24.036: BGP(0): Future scanner version: 231, current scanner versi

on: 230

*Mar 1 03:55:24.036: BGP(1): scanning IPv6 Unicast routing tables

*Mar 1 03:55:24.036: BGP(IPv6 Unicast): Performing BGP Nexthop scanning for gen

eral scan

*Mar 1 03:55:24.036: BGP(1): Future scanner version: 231, current scanner versi

on: 230

*Mar 1 03:55:24.036: BGP(2): scanning VPNv4 Unicast routing tables

*Mar 1 03:55:24.052: BGP(VPNv4 Unicast): Performing BGP Nexthop scanning for ge

neral scan

*Mar 1 03:55:24.052: BGP(2): Future scanner version: 231, current scanner versi

on: 230

*Mar 1 03:55:24.052: BGP(3): scanning IPv4 Multicast routing tables

*Mar 1 03:55:24.064: BGP(IPv4 Multicast): Performing BGP Nexthop scanning for g

eneral scan

*Mar 1 03:55:24.064: BGP(3): Future scanner version: 231, current scanner versi

on: 230

*Mar 1 03:55:39.093: BGP: Import timer expired. Walking from 1 to 1

*Mar 1 03:55:54.093: BGP: Import timer expired. Walking from 1 to 1

*Mar 1 03:56:09.094: BGP: Import timer expired. Walking from 1 to 1

*Mar 1 03:56:24.095: BGP: Performing BGP general scanning

*Mar 1 03:56:24.095: BGP(0): scanning IPv4 Unicast routing tables

*Mar 1 03:56:24.107: BGP(IPv4 Unicast): Performing BGP Nexthop scanning for gen

  • WAN Routing and Switching
8 REPLIES
Hall of Fame Super Silver

Re: BGP Peering

Minu

It does not appear to me that these messages have anything to do with problems in establishing the neighbor relationship. These messages are about scanning the routing table to see if there are any routes to advertise in BGP (it is scanning for IPv4 unicast, then for IPv6 unicast, then for VPNv4 unicast, and then for IPv4 multicast). This scanning activity is a normal part of BGP and I do not see anything in these messages that indicates a problem.

Perhaps you can tell us more about the problem? Can you post the router config? Are the routers connected on a common subnet (and are you using addresses in that subnet as the peering addresses)? If not have you specified the multihop parameter?

If we had more information to work with we might be able to find better answers.

HTH

Rick

New Member

hello ,

hello ,

I am facing kind of similar problem.

I am trying the to form the ebgp neighbourship between two directly connected routers , but i am using different subnets

-----------------------------------------------------------------------------------------------------------------------

below is the required config for router R1

router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 192.168.1.5 remote-as 2
no auto-summary

interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.252
duplex auto
speed auto

ip route 192.168.1.4 255.255.255.252 FastEthernet0/0

R1#sh cdp ne
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S - Switch, H - Host, I - IGMP, r - Repeater

Device ID Local Intrfce Holdtme Capability Platform Port ID
R2 Fas 0/0 171 R S I 3725 Fas 0/0

--------------------------------------------------------------------------------------------------------------------------

required config for router R2

router bgp 2
no synchronization
bgp log-neighbor-changes
neighbor 192.168.1.1 remote-as 1
no auto-summary

interface FastEthernet0/0
ip address 192.168.1.5 255.255.255.252
duplex auto
speed auto
end

ip route 192.168.1.0 255.255.255.252 FastEthernet0/0

R2# sh cdp ne
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S - Switch, H - Host, I - IGMP, r - Repeater

Device ID Local Intrfce Holdtme Capability Platform Port ID
R1 Fas 0/0 130 R S I 3725 Fas 0/0

-------------------------------------------------------------------------------------------------------

I am getting below bgp logs and bgp is stuck in idle state.

R1#
*Mar 1 00:24:21.071: BGP: Import timer expired. Walking from 1 to 1
R1#
*Mar 1 00:24:36.071: BGP: Import timer expired. Walking from 1 to 1
R1#
*Mar 1 00:24:51.071: BGP: Import timer expired. Walking from 1 to 1
R1#
*Mar 1 00:25:06.071: BGP: Performing BGP general scanning
*Mar 1 00:25:06.071: BGP(0): scanning IPv4 Unicast routing tables
*Mar 1 00:25:06.071: BGP(IPv4 Unicast): Performing BGP Nexthop scanning for general scan
*Mar 1 00:25:06.071: BGP(0): Future scanner version: 16, current scanner version: 15
*Mar 1 00:25:06.071: BGP(1): scanning IPv6 Unicast routing tables
*Mar 1 00:25:06.075: BGP(IPv6 Unicast): Performing BGP Nexthop scanning for general scan
*Mar 1 00:25:06.075: BGP(1): Future scanner version: 20, current scanner version: 19
*Mar 1 00:25:06.075: BGP(2): scanning VPNv4 Unicast routing tables
*Mar 1 00:25:06.075: BGP(VPNv4 Unicast): Performing BGP Nexthop scanning for general scan
*Mar 1 00:25:06.075: BGP(2): Future scanner version: 20, current scanner version: 19
*Mar 1 00:25:06.079: BGP(4): scanning IPv4 Multicast routing tables
*Mar 1 00:25:06.079: BGP(IPv4 Multicast): Performing BGP Nexthop scanning for general scan
*Mar 1 00:25:06.079: BGP(4): Future scanner version: 20, current scanner version: 19
*Mar 1 00:25:06.079: BGP(5): scanning IPv6 Multicast routing tables
*Mar 1 00:25:06.079: BGP(IPv6 Multicast): Performing BGP Nexthop scanning for general scan
*Mar 1 00:25:06.079: BGP(5): Future scanner version: 20, current scanner version: 19
*Mar 1 00:25:06.079: BGP(6): scanning NSAP Unicast routing tables
*Mar 1 00:25:06.079: BGP(NSAP Unicast): Performing BGP Nexthop scanning for general scan
*Mar 1 00:25:06.079: BGP(6): Future scanner version: 20, current scanner version: 19

kindly help.

Hall of Fame Super Silver

We do not have enough

We do not have enough information yet to be able to identify the cause of your issue.

- can you post the output of show ip interface Fast0/0 from both routers.

- can you post the output of each router attempting to ping the BGP neighbor address

- can you post the output of show ip bgp and of show ip bgp sum from both routers

HTH

Rick

Cisco Employee

Hi,

Hi,

Could you please check "show ip int brief". I believe your protocol should be "down" since you configured two different subnet ip address for directly connected interface.

 

Silver

as you are configuring ebgp

as you are configuring ebgp between two differn subnet you should add below command on both router it will work

neighbor x.x.x.x disable-connected-check

New Member

Re: BGP Peering

Greetings,

As the other guy says, the routers aren't even trying to establish. Are the neighbors 'activated'?

Send through the 'show run | begin router bgp'

Dave

New Member

Re: BGP Peering

hi ,

If you can ping that means there is a route present .

paste logs for << and

1) Show ip bgp neighbors

2) sh ip bgp summary

3) sh ip route

4) [ sh running ]

and traceroute .. its really diffucult without data ..

New Member

Re: BGP Peering

Hi,

Are you able to ping P2P link ips i.e. POS interface or DS3 interface ?

Have you given ' update source loopback ' in neighbour command ? If yes, make sure loopback ips are properly routed. Just check !

Cheers !!!

3082
Views
0
Helpful
8
Replies
This widget could not be displayed.