Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

BGP route-inject

hello friends.

Does anyone know how to correctly configure this feature?

mine didnt work..

router bgp 100

no synchronization

bgp router-id 2.2.2.2

bgp log-neighbor-changes

bgp inject-map rm_injected exist-map rm_exist

network 2.0.0.0

network 2.2.2.2 mask 255.255.255.255

aggregate-address 2.0.0.0 255.0.0.0

ip prefix-list pl_existing seq 5 permit 2.0.0.0/8

!

ip prefix-list pl_injected seq 5 permit 2.2.2.0/24

route-map rm_exist permit 10

match ip address prefix-list pl_existing

!

route-map rm_injected permit 10

match ip address prefix-list pl_injected

Any clues...what kind of route should I have on the routing table? or BGP table to make this work?

Vlad

2 REPLIES
Bronze

Re: BGP route-inject

Hi,

Wich interface has an ip in the 2.2.2.0/24 nettwork ?

You need to post the complete config if we are supposed to help you :)

If your 2.2.2.0/24 is not an connected interface on your router you either need to get it redistributet or create a route to the null interface like this :

ip route 2.2.2.0 255.255.255.0 null 0 222

And actually why is it necesarry to inject a /24 route when you are supposed to advertice 2.0.0.0/8 ? Your IGP probably carry a more specific route to 2.2.2.0/24 ?

BR,

Bjornarsb

New Member

Re: BGP route-inject

interface Loopback0

ip address 2.2.2.2 255.255.255.255

or

ip route 2.0.0.0 255.0.0.0 Null0

Then "show ip route" and "show ip bgp" to see if you have achived what you were trying too.

191
Views
0
Helpful
2
Replies