Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Bgp route missing

BGP 11.jpeg.jpeg

Hi,

There are totally three Autonomous configured, OSPF running on AS 2. Router 3(as2) has directly connection with R1(As1) and Router 5(As2) has directly connected with R2(AS3). now the problem is R3 and R5 know AS1 and AS2 routes but they don't exchange their external routes with ebgp. if R3 know about 2.2.2.2(AS3) it should send this to AS 1.

here is my results:-

R5#sh ip bgp

   Network          Next Hop            Metric LocPrf Weight Path

* i1.1.1.1/32       192.168.13.1             0    100      0 1 i

*> 2.2.2.2/32       192.168.52.2             0             0 3 i

R3#sh ip bgp

   Network          Next Hop            Metric LocPrf Weight Path

*> 1.1.1.1/32       192.168.13.1             0             0 1 i

* i2.2.2.2/32       192.168.52.2             0    100      0 3 i

AS 3

R2#sh ip bgp

   Network          Next Hop            Metric LocPrf Weight Path

*> 2.2.2.2/32       0.0.0.0                  0         32768 i

AS 1

R1#sh ip bgp

Network          Next Hop            Metric LocPrf Weight Path

*> 1.1.1.1/32       0.0.0.0                  0         32768 i

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Blue

Re: Bgp route missing

Can't see anything wrong with your config but i did a quick search and it seems like it is dynamips/GNS3 issue.

Are you using that for your setup ?

If so the solutions are either to save the lab, stop and it and reload it or use a different router/IOS.

As for the route issue. When an EBGP router receives a route from an EBGP peer it advertises the route to an IBGP peer with the next hop set to the EBGP peer it received the route from ie.

1) R2 in AS 3 advertises 2.2.2.2 to R5 in AS 2 so this is EBGP. The next hop for the route is R2 ie. 192.168.52.2.

2) R5 then advertises this via IBGP to R3 with the same next hop ie. 192.168.52.2. If you look at your original post 2.2.2.2 is in R3's BGP table with a next hop of 192.168.52.2

3) if you look at R3's route table in your follow up post you can see it has no route to 192.168.52.2 because that subnet is not part of your OSPF domain. So R3 cannot install 2.2.2.2 into the IP routing table because it is not reachable.

And it also cannot advertise to R1 for the same reason.

4) by adding the next-hop self command on R5 (and R3) you are telling R5 that when it advertises the route to R3 it needs to change the next hop of the route from 192.168.52.2 to it's own IP address.

5) once it has done this R3 knows how to get to R5 ie. from its IP routing table so it considers 2.2.2.2 reachable, installs it in the routing table and advertises it to R1.

The same works in reverse ie. R3 advertising to R5 as well.

Hope that makes sense.

Jon

11 REPLIES
Hall of Fame Super Blue

Bgp route missing

From R3 can you post -

1) sh ip route

2) sh ip bgp neighbor advertised-routes

and then also post the full config for R3

Jon

New Member

Re: Bgp route missing

i forget to mention that on Router 4 and 6 dont have bgp configured.

R3#sh ip route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets

B       1.1.1.1 [20/0] via 192.168.13.1, 00:04:20

C    192.168.13.0/24 is directly connected, Serial1/0

     3.0.0.0/32 is subnetted, 1 subnets

C       3.3.3.3 is directly connected, Loopback0

O    192.168.45.0/24 [110/2] via 192.168.34.4, 00:05:09, FastEthernet0/0

     5.0.0.0/32 is subnetted, 1 subnets

O       5.5.5.5 [110/3] via 192.168.36.6, 00:05:09, FastEthernet0/1

                [110/3] via 192.168.34.4, 00:05:09, FastEthernet0/0

O    192.168.65.0/24 [110/2] via 192.168.36.6, 00:05:09, FastEthernet0/1

C    192.168.36.0/24 is directly connected, FastEthernet0/1

C    192.168.34.0/24 is directly connected, FastEthernet0/0

R3#sh ip bgp summary

BGP router identifier 3.3.3.3, local AS number 2

BGP table version is 2, main routing table version 2

2 network entries using 264 bytes of memory

2 path entries using 104 bytes of memory

3/1 BGP path/bestpath attribute entries using 504 bytes of memory

2 BGP AS-PATH entries using 48 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory

BGP using 952 total bytes of memory

BGP activity 2/0 prefixes, 2/0 paths, scan interval 60 secs

Neighbor        V          AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

5.5.5.5         4          2      14      13        2    0    0 00:06:08        1

192.168.13.1    4          1      10       9        2    0    0 00:06:50        1

R3#sh ip bgp neighbors

BGP neighbor is 5.5.5.5,  remote AS 2, internal link

  BGP version 4, remote router ID 5.5.5.5

  BGP state = Established, up for 00:05:05

  Last read 00:00:03, last write 00:00:03, hold time is 180, keepalive interval is 60 seconds

  Neighbor capabilities:

    Route refresh: advertised and received(new)

    New ASN Capability: advertised and received

    Address family IPv4 Unicast: advertised and received

  Message statistics:

    InQ depth is 0

    OutQ depth is 0

                         Sent       Rcvd

    Opens:                  2          2

    Notifications:          1          1

    Updates:                1          1

    Keepalives:             8          8

    Route Refresh:          0          0

    Unrecognized:         n/a          1

    Total:                 12         13

  Default minimum time between advertisement runs is 0 seconds

For address family: IPv4 Unicast

  BGP table version 2, neighbor version 2/0

  Output queue size : 0

  Index 2, Offset 0, Mask 0x4

  2 update-group member

                                 Sent       Rcvd

  Prefix activity:               ----       ----

    Prefixes Current:               1          1 (Consumes 52 bytes)

    Prefixes Total:                 1          1

    Implicit Withdraw:              0          0

    Explicit Withdraw:              0          0

    Used as bestpath:             n/a          0

    Used as multipath:            n/a          0

                                   Outbound    Inbound

  Local Policy Denied Prefixes:    --------    -------

    Total:                                0          0

  Number of NLRIs in the update sent: max 1, min 1

  Address tracking is enabled, the RIB does have a route to 5.5.5.5

  Connections established 2; dropped 1

  Last reset 00:05:54, due to BGP Notification sent, header synchronization problems

  Transport(tcp) path-mtu-discovery is enabled

Connection state is ESTAB, I/O status: 1, unread input bytes: 0           

Connection is ECN Disabled, Mininum incoming TTL 0, Outgoing TTL 255

Local host: 3.3.3.3, Local port: 179

Foreign host: 5.5.5.5, Foreign port: 21868

Connection tableid (VRF): 0

Enqueued packets for retransmit: 0, input: 0  mis-ordered: 0 (0 bytes)

Event Timers (current time is 0x6CC7C):

Timer          Starts    Wakeups            Next

Retrans             8          0             0x0

TimeWait            0          0             0x0

AckHold             7          5             0x0

SendWnd             0          0             0x0

KeepAlive           0          0             0x0

GiveUp              0          0             0x0

PmtuAger            0          0             0x0

DeadWait            0          0             0x0

Linger              0          0             0x0

ProcessQ            0          0             0x0

iss: 2059140500  snduna: 2059140749  sndnxt: 2059140749     sndwnd:  16136

irs: 1335151246  rcvnxt: 1335151495  rcvwnd:      16136  delrcvwnd:    248

SRTT: 200 ms, RTTO: 993 ms, RTV: 793 ms, KRTT: 0 ms

minRTT: 144 ms, maxRTT: 320 ms, ACK hold: 200 ms

Status Flags: passive open, gen tcbs

Option Flags: nagle, path mtu capable

IP Precedence value : 6

Datagrams (max data segment is 536 bytes):

Rcvd: 18 (out of order: 0), with data: 9, total data bytes: 248

Sent: 16 (retransmit: 0, fastretransmit: 0, partialack: 0, Second Congestion: 0), with data: 9, total data bytes: 248

Packets received in fast path: 0, fast processed: 0, slow path: 0

fast lock acquisition failures: 0, slow path: 0

BGP neighbor is 192.168.13.1,  remote AS 1, external link

  BGP version 4, remote router ID 1.1.1.1

  BGP state = Established, up for 00:05:54

  Last read 00:00:10, last write 00:00:10, hold time is 180, keepalive interval is 60 seconds

  Neighbor capabilities:

    Route refresh: advertised and received(new)

    New ASN Capability: advertised and received

    Address family IPv4 Unicast: advertised and received

  Message statistics:

    InQ depth is 0

    OutQ depth is 0

                         Sent       Rcvd

    Opens:                  1          1

    Notifications:          0          0

    Updates:                0          1

    Keepalives:             7          7

    Route Refresh:          0          0

    Total:                  8          9

  Default minimum time between advertisement runs is 30 seconds

For address family: IPv4 Unicast

  BGP table version 2, neighbor version 2/0

  Output queue size : 0

  Index 1, Offset 0, Mask 0x2

  1 update-group member

                                 Sent       Rcvd

  Prefix activity:               ----       ----

    Prefixes Current:               0          1 (Consumes 52 bytes)

    Prefixes Total:                 0          1

    Implicit Withdraw:              0          0

    Explicit Withdraw:              0          0

    Used as bestpath:             n/a          1

    Used as multipath:            n/a          0

                                   Outbound    Inbound

  Local Policy Denied Prefixes:    --------    -------

    Bestpath from this peer:              1        n/a

    Total:                                1          0

  Number of NLRIs in the update sent: max 0, min 0

  Address tracking is enabled, the RIB does have a route to 192.168.13.1

  Connections established 1; dropped 0

  Last reset never

  Transport(tcp) path-mtu-discovery is enabled

Connection state is ESTAB, I/O status: 1, unread input bytes: 0           

Connection is ECN Disabled, Mininum incoming TTL 0, Outgoing TTL 1

Local host: 192.168.13.3, Local port: 20573

Foreign host: 192.168.13.1, Foreign port: 179

Connection tableid (VRF): 0

Enqueued packets for retransmit: 0, input: 0  mis-ordered: 0 (0 bytes)

Event Timers (current time is 0x6D6A8):

Timer          Starts    Wakeups            Next

Retrans             9          0             0x0

TimeWait            0          0             0x0

AckHold             9          7             0x0

SendWnd             0          0             0x0

KeepAlive           0          0             0x0

GiveUp              0          0             0x0

PmtuAger            1          0         0xA9120

DeadWait            0          0             0x0

Linger              0          0             0x0

ProcessQ            0          0             0x0

iss: 3414808598  snduna: 3414808785  sndnxt: 3414808785     sndwnd:  16198

irs:  938062699  rcvnxt:  938062941  rcvwnd:      16143  delrcvwnd:    241

SRTT: 210 ms, RTTO: 904 ms, RTV: 694 ms, KRTT: 0 ms

minRTT: 40 ms, maxRTT: 300 ms, ACK hold: 200 ms

Status Flags: active open

Option Flags: nagle, path mtu capable

IP Precedence value : 6

Datagrams (max data segment is 1460 bytes):

Rcvd: 17 (out of order: 0), with data: 9, total data bytes: 241

Sent: 17 (retransmit: 0, fastretransmit: 0, partialack: 0, Second Congestion: 0), with data: 8, total data bytes: 186

Packets received in fast path: 0, fast processed: 0, slow path: 0

fast lock acquisition failures: 0, slow path: 0

New Member

Bgp route missing

On R5 and R3 this message keep gemerating

%BGP-5-ADJCHANGE: neighbor 3.3.3.3 Down BGP Notification sent

R5#

%BGP-3-NOTIFICATION: sent to neighbor 3.3.3.3 1/1 (header synchronization problems) 0 bytes

%BGP-5-ADJCHANGE: neighbor 3.3.3.3 Up

R5#

%BGP-3-NOTIFICATION: received from neighbor 5.5.5.5 1/1 (header synchronization problems) 0 bytes

%BGP-5-ADJCHANGE: neighbor 5.5.5.5 Down BGP Notification received

%BGP-5-ADJCHANGE: neighbor 5.5.5.5 Up

R3#

Hall of Fame Super Blue

Bgp route missing

Can you post the full configuration of R3 ?

Jon

New Member

Bgp route missing

R3#sh running-config

Building configuration...

Current configuration : 1711 bytes

!

upgrade fpd auto

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R3

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

!

no aaa new-model

ip source-route

no ip icmp rate-limit unreachable

ip cef

!

!

!

!        

no ip domain lookup

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!

!

!

archive

log config

  hidekeys

!

!        

!

!

!

ip tcp synwait-time 5

!

!

!

!

interface Loopback0

ip address 3.3.3.3 255.255.255.255

!

interface FastEthernet0/0

ip address 192.168.34.3 255.255.255.0

duplex full

speed auto

!

interface FastEthernet0/1

ip address 192.168.36.3 255.255.255.0

duplex full

speed auto

!

interface Serial1/0

ip address 192.168.13.3 255.255.255.0

serial restart-delay 0

!

interface Serial1/1

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/2

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/3

no ip address

shutdown

serial restart-delay 0

!

router ospf 1

log-adjacency-changes

passive-interface Serial1/0

network 3.3.3.3 0.0.0.0 area 0

network 192.168.34.0 0.0.0.255 area 0

network 192.168.36.0 0.0.0.255 area 0

!

router bgp 2

no synchronization

bgp log-neighbor-changes

neighbor 5.5.5.5 remote-as 2

neighbor 5.5.5.5 update-source Loopback0

neighbor 192.168.13.1 remote-as 1

no auto-summary

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

control-plane

Hall of Fame Super Blue

Re: Bgp route missing

Add this to your configuration -

router bgp 2

neighbor 5.5.5.5 next-hop self

and then on R5 do the same thing for R3 ie. assuming R3 is 3.3.3.3

router bgp 2

neighbor 3.3.3.3 next-hop self

and then check routing tables on R1/R3.

Jon

New Member

Bgp route missing

R1#sh ip bgp

BGP table version is 5, local router ID is 1.1.1.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

*> 1.1.1.1/32       0.0.0.0                  0         32768 i

*> 2.2.2.2/32       192.168.13.3                           0 2 3 i

Now its working, but 2.2.2.2 keep coming up and down, check the logs below

*Jan 18 02:24:08.643: %BGP-5-ADJCHANGE: neighbor 5.5.5.5 Up

*Jan 18 02:24:08.871: %BGP-3-NOTIFICATION: received from neighbor 5.5.5.5 1/1 (header synchronization problems) 0 bytes

R3(config-router)#

*Jan 18 02:24:08.875: %BGP-5-ADJCHANGE: neighbor 5.5.5.5 Down BGP Notification received

R3(config-router)#

R3(config-router)#

R3(config-router)#

R3#

*Jan 18 02:24:19.575: %SYS-5-CONFIG_I: Configured from console by console

R3#

*Jan 18 02:24:24.207: %BGP-5-ADJCHANGE: neighbor 5.5.5.5 Up

R3#sh run | sec bgp

router bgp 2

no synchronization

bgp log-neighbor-changes

neighbor 5.5.5.5 remote-as 2

neighbor 5.5.5.5 update-source Loopback0

neighbor 5.5.5.5 next-hop-self

neighbor 192.168.13.1 remote-as 1

no auto-summary

R5#sh run | sec bgp

router bgp 2

no synchronization

bgp log-neighbor-changes

neighbor 3.3.3.3 remote-as 2

neighbor 3.3.3.3 update-source Loopback0

neighbor 3.3.3.3 next-hop-self

neighbor 192.168.52.2 remote-as 3

no auto-summary

Hall of Fame Super Blue

Bgp route missing

So the routes are now showing properly ?

So the messages are from R2 showing the neighborship going up and down with R5, is that correct ?

If so you can run "debug ip bgp" on both routers to see what is happening.

Can you also post the BGP config only of R2 ?

Jon

New Member

Bgp route missing

Routes no problem now, but not stable keep going up d down

R5#debug ip bgp even

BGP events debugging is on

R5#

R5#

R5#

*Jan 18 02:40:19.471: BGP(4): Import timer expired. Walking from 1 to 1

*Jan 18 02:40:19.471: BGP(5): Import timer expired. Walking from 1 to 1

R5#deb

*Jan 18 02:40:34.475: BGP(4): Import timer expired. Walking from 1 to 1

*Jan 18 02:40:34.479: BGP(5): Import timer expired. Walking from 1 to 1

R5#deb

R5#debug ip bgp

*Jan 18 02:40:49.479: BGP(4): Import timer expired. Walking from 1 to 1

*Jan 18 02:40:49.483: BGP(5): Import timer expired. Walking from 1 to 1

R5#            

R5#

R5#

R5#

*Jan 18 02:40:53.947: BGP: 3.3.3.3 reset due to BGP Notification sent

*Jan 18 02:40:53.947: %BGP-5-ADJCHANGE: neighbor 3.3.3.3 Down BGP Notification sent

R5#

*Jan 18 02:40:53.951: %BGP-3-NOTIFICATION: sent to neighbor 3.3.3.3 1/1 (header synchronization problems) 0 bytes

R5#

*Jan 18 02:40:54.023: BGP: service reset requests

*Jan 18 02:40:54.027: BGP: service reset requests

*Jan 18 02:40:54.027: BGP: service reset requests

*Jan 18 02:40:54.031: BGP: service reset requests

*Jan 18 02:40:54.031: BGP: service reset requests

*Jan 18 02:40:54.035: BGP: service reset requests

*Jan 18 02:40:54.035: BGP: service reset requests

*Jan 18 02:40:54.035: BGP: service reset requests

*Jan 18 02:40:54.043: BGP: starting the default originate timer with initial delay of 1 sec

*Jan 18 02:40:54.159: BGP: default originate timer expired

*Jan 18 02:40:54.163: BGP: processing neighbors configured for conditional default route origination

Jan 18 02:41:16.923: %BGP-5-ADJCHANGE: neighbor 3.3.3.3 Up

R5#u all

hostname R2

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

!

no aaa new-model

ip source-route

no ip icmp rate-limit unreachable

ip cef

!

!

!

!        

no ip domain lookup

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

archive

log config

  hidekeys

!

!

!

!

!

ip tcp synwait-time 5

!

!

!

!

interface Loopback0

ip address 2.2.2.2 255.255.255.255

!

interface FastEthernet0/0

no ip address

shutdown

duplex half

!

interface Serial1/0

ip address 192.168.52.2 255.255.255.0

serial restart-delay 0

!

interface Serial1/1

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/2

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/3

no ip address

shutdown

serial restart-delay 0

!

router bgp 3

no synchronization

bgp log-neighbor-changes

network 2.2.2.2

network 2.2.2.2 mask 255.255.255.255

neighbor 192.168.52.5 remote-as 2

no auto-summary

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

Hall of Fame Super Blue

Re: Bgp route missing

Can't see anything wrong with your config but i did a quick search and it seems like it is dynamips/GNS3 issue.

Are you using that for your setup ?

If so the solutions are either to save the lab, stop and it and reload it or use a different router/IOS.

As for the route issue. When an EBGP router receives a route from an EBGP peer it advertises the route to an IBGP peer with the next hop set to the EBGP peer it received the route from ie.

1) R2 in AS 3 advertises 2.2.2.2 to R5 in AS 2 so this is EBGP. The next hop for the route is R2 ie. 192.168.52.2.

2) R5 then advertises this via IBGP to R3 with the same next hop ie. 192.168.52.2. If you look at your original post 2.2.2.2 is in R3's BGP table with a next hop of 192.168.52.2

3) if you look at R3's route table in your follow up post you can see it has no route to 192.168.52.2 because that subnet is not part of your OSPF domain. So R3 cannot install 2.2.2.2 into the IP routing table because it is not reachable.

And it also cannot advertise to R1 for the same reason.

4) by adding the next-hop self command on R5 (and R3) you are telling R5 that when it advertises the route to R3 it needs to change the next hop of the route from 192.168.52.2 to it's own IP address.

5) once it has done this R3 knows how to get to R5 ie. from its IP routing table so it considers 2.2.2.2 reachable, installs it in the routing table and advertises it to R1.

The same works in reverse ie. R3 advertising to R5 as well.

Hope that makes sense.

Jon

New Member

Bgp route missing

My friend aslo suggest me to check with different ios and router about flapping netwrk , because am using currently router c7200  and Version 12.4(24)T5.

Thanks for your continuous fast replys and explanation really appreciated .


,

1161
Views
0
Helpful
11
Replies