Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

BGP router or switch suggestion

I need a recommendation for a router or switch that can run BGP to act as an Internet edge router. I only need partial routing (let's say < 500 routes) with Gigabit interfaces. Any suggestions? I'm considering a cat 3750 with IP Services. Anybody use that model for BGP?

Thanks,

Jermaine

1 ACCEPTED SOLUTION

Accepted Solutions

Re: BGP router or switch suggestion

Hi,

for only 500 routes you can use practically every router and switch supporting your other requirements.

You should apply the proper inbound and outbound filters to be sure an ISP failure will not get you in trouble. An example configuration would look like this:

router bgp 65000

network 1.1.0.0 mask 255.255.0.0

neighbor 3.4.5.6 remote-as 1

neighbor 3.4.5.6 maximum-prefix 2000

neighbor 3.4.5.6 prefix-list NoTrash in

neighbor 3.4.5.6 filter-list 1 out

no auto-summary

ip as-path access-list 1 permit ^$

ip prefix-list NoTrash deny 192.168.0.0/16 le 32

ip prefix-list NoTrash deny 172.16.0.0/12 le 32

ip prefix-list NoTrash deny 10.0.0.0/8 le 32

ip prefix-list NoTrash deny 1.1.0.0/16 le 32

ip prefix-list NoTrash permit 0.0.0.0/0 le 32

ip route 1.1.0.0 255.255.0.0 Null 0 250

assuming your network to announce would be 1.1.0.0/16

Hope this helps

Martin

4 REPLIES

Re: BGP router or switch suggestion

To use a switch such as 3750 with BGP enabled costs more $$$. I would spend that much money on a router that can do the same thing with additional memory added, in case you subscribe to more prefixes.

New Member

Re: BGP router or switch suggestion

Yes, I understand the additional cost for the IP Services feature set. My equipment is located in a collocation facility where I have access to any number of ISPs via ethernet. I also don't plan on using WAN interfaces, so my main requirement is gigabit ports; I need at least four.

I do see the point about memory...

Re: BGP router or switch suggestion

Hi,

for only 500 routes you can use practically every router and switch supporting your other requirements.

You should apply the proper inbound and outbound filters to be sure an ISP failure will not get you in trouble. An example configuration would look like this:

router bgp 65000

network 1.1.0.0 mask 255.255.0.0

neighbor 3.4.5.6 remote-as 1

neighbor 3.4.5.6 maximum-prefix 2000

neighbor 3.4.5.6 prefix-list NoTrash in

neighbor 3.4.5.6 filter-list 1 out

no auto-summary

ip as-path access-list 1 permit ^$

ip prefix-list NoTrash deny 192.168.0.0/16 le 32

ip prefix-list NoTrash deny 172.16.0.0/12 le 32

ip prefix-list NoTrash deny 10.0.0.0/8 le 32

ip prefix-list NoTrash deny 1.1.0.0/16 le 32

ip prefix-list NoTrash permit 0.0.0.0/0 le 32

ip route 1.1.0.0 255.255.0.0 Null 0 250

assuming your network to announce would be 1.1.0.0/16

Hope this helps

Martin

New Member

Re: BGP router or switch suggestion

Yes, that's what I figured. I was hoping to hear from people that may have used the 3750 for BGP. Thanks for the sample config; it is close to what I had in mind.

135
Views
11
Helpful
4
Replies
CreatePlease to create content