Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

BGP routes into EIGRP

Hi guys,

I am trying to get routes that are being advertised by BGP inot EIGRP howver it does not seem to be working. I thought it would be fairly simple.

I have attached a scanned copy of my diagram. i am just trying this to see if I can use it in production. What I am trying to acheieve is that if a link between R4 and R3 or between R1 and R2 fails, then it will go the other way. R2 and R4 run EIGRP as their IGP. BGP is everywhere else.

Any help great. I have put in the routing parts of the running config.

R1
router bgp 65200
bgp log-neighbor-changes
network 10.2.1.2 mask 255.255.255.252
network 172.16.1.0 mask 255.255.255.0
network 192.168.2.0
neighbor 10.2.1.1 remote-as 65001
neighbor 192.168.2.2 remote-as 65100

R2
router eigrp 1
redistribute bgp 65001
passive-interface Serial0/0
network 10.0.0.0
network 172.16.0.0
network 192.168.1.0
network 192.168.2.0
no auto-summary
!
router bgp 65001
bgp log-neighbor-changes
network 10.2.1.1 mask 255.255.255.252
network 192.168.1.0
network 192.168.2.0
redistribute eigrp 1
neighbor 10.2.1.2 remote-as 65200


R3
router bgp 65100
network 10.1.1.1 mask 255.255.255.252
network 172.16.2.0 mask 255.255.255.0
network 172.168.2.1
network 192.168.2.0
neighbor 10.1.1.1 remote-as 65001
neighbor 192.168.2.1 remote-as 65200


R4
router eigrp 1
redistribute bgp 65001
passive-interface Serial0/0
network 10.0.0.0
network 172.16.0.0
network 192.168.1.0
network 192.168.2.0
no auto-summary
!
router bgp 65001
no synchronization
bgp log-neighbor-changes
network 192.168.1.0
redistribute eigrp 1
neighbor 10.1.1.2 remote-as 65100
no auto-summary

Everyone's tags (2)
3 REPLIES
Hall of Fame Super Gold

BGP routes into EIGRP

Cory

The big issue with the configuration that you have posted is that EIGRP is attempting to redistribute routes from BGP but there is no default metric. For EIGRP to successfully redistribute routes there must be a default metric for the redistributed routes.

You can supply the default metric in two ways:

- you can configure default-metric under router eigrp.

- you can include default metric parameters on the redistribute bgp command.

Give one of these a try and let us know if it works better.

HTH

Rick

New Member

Re: BGP routes into EIGRP

I just figured it out myself, I need IBGP running as well. I also added no auto summary to every bgp process.

Is running IBGP another way Richard or are your ways more simple etc?

Hall of Fame Super Gold

BGP routes into EIGRP

Cory

I had not given any thought to possible issues of IBGP vs EBGP but that is something that you do need to work out.

While reviewing the original post I did notice an issue (though it is not related to the main question of this thread). You have this in the config

network 10.2.1.1 mask 255.255.255.252

but you would never get an entry in the routing table for 10.2.1.1 with a mask of 255.255.255.252. So that network would never be advertised by BGP. And there is a similar issue with

network 10.2.1.2 mask 255.255.255.252

And there are similar issues with other entries, but I hope that I do not need to point each of them out.

Whether you are running IBGP or EBGP has very little to do with whether routes will get redistributed into EIGRP. But failure to provide a default metric will certainly prevent any successful redistribution into EIGRP.

HTH

Rick

1722
Views
0
Helpful
3
Replies
CreatePlease to create content