cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3182
Views
0
Helpful
1
Replies

BGP Routes not advertised over VRFs

Islam Nadim
Level 1
Level 1

Hello All,

I have this topology, where I created a backbone that should work with VRFs.

topology.png

The configuration below related to the backbone routers. I'm using OSPF for the backbone and BGP on the Edge Routers.

CorePRouter:

interface Serial0/0

ip address 10.10.10.1 255.255.255.252

mpls ip

clock rate 2000000

!

interface Serial0/1

ip address 10.10.20.1 255.255.255.252

mpls ip

clock rate 2000000

!

router ospf 1

log-adjacency-changes

network 10.10.10.0 0.0.0.255 area 0

network 10.10.20.0 0.0.0.255 area 0

!

PERight:

ip vrf CustA

rd 1:1

route-target export 1:1

route-target import 1:1

!

ip vrf CustB

rd 2:2

route-target export 2:2

route-target import 2:2

!

interface Loopback0

description -- BGP SOURCE INTERFACE WITH PERight --

ip address 2.2.2.2 255.255.255.255

!

interface Serial0/0

description -- TO CorePRouter --

ip address 10.10.20.2 255.255.255.252

mpls ip

clock rate 2000000

!

interface Serial0/1

description -- TO CustA2 Router$$VRF CustA --

ip vrf forwarding CustA

ip address 192.168.2.1 255.255.255.252

clock rate 2000000

!

interface Serial0/2

description -- TO CustB2 Router$$VRF CustB --

ip vrf forwarding CustB

ip address 192.168.4.1 255.255.255.252

clock rate 2000000

!

router ospf 1

log-adjacency-changes

network 2.2.2.2 0.0.0.0 area 0

network 10.10.20.0 0.0.0.255 area 0

!

router bgp 13879

no bgp default route-target filter

bgp log-neighbor-changes

neighbor 1.1.1.1 remote-as 13879

neighbor 1.1.1.1 update-source Loopback0

!

address-family ipv4

  neighbor 1.1.1.1 activate

  no auto-summary

  no synchronization

exit-address-family

!

address-family ipv4 vrf CustB

  neighbor 192.168.4.2 remote-as 65003

  neighbor 192.168.4.2 activate

  no synchronization

exit-address-family

!

address-family ipv4 vrf CustA

  neighbor 192.168.2.2 remote-as 65001

  neighbor 192.168.2.2 activate

  no synchronization

exit-address-family

!

PELeft:

ip vrf CustA

rd 1:1

route-target export 1:1

route-target import 1:1

!

ip vrf CustB

rd 2:2

route-target export 2:2

route-target import 2:2

!

interface Loopback0

description -- BGP SOURCE INTERFACE WITH PERight --

ip address 1.1.1.1 255.255.255.255

!

interface Serial0/0

description -- TO CorePRouter --

ip address 10.10.10.2 255.255.255.252

mpls ip

clock rate 2000000

!

interface Serial0/1

description -- TO CustA1 Router$$VRF CustA --

ip vrf forwarding CustA

ip address 192.168.1.1 255.255.255.252

clock rate 2000000

!

interface Serial0/2

description -- TO CustB1 Router$$VRF CustB --

ip vrf forwarding CustB

ip address 192.168.3.1 255.255.255.252

clock rate 2000000

!

router ospf 1

log-adjacency-changes

network 1.1.1.1 0.0.0.0 area 0

network 10.10.10.0 0.0.0.255 area 0

!

router bgp 13879

no bgp default route-target filter

bgp log-neighbor-changes

neighbor 2.2.2.2 remote-as 13879

neighbor 2.2.2.2 update-source Loopback0

!

address-family ipv4

  neighbor 2.2.2.2 activate

  no auto-summary

  no synchronization

exit-address-family

!

address-family ipv4 vrf CustB

  redistribute connected

  neighbor 192.168.3.2 remote-as 65002

  neighbor 192.168.3.2 activate

  no synchronization

exit-address-family

!

address-family ipv4 vrf CustA

  redistribute connected

  neighbor 192.168.1.2 remote-as 65000

  neighbor 192.168.1.2 activate

  no synchronization

exit-address-family

!

The problem here, the VRF Routes are not advertised between the PEs, thus the CEs can't see each other. What am I missing here?

1 Accepted Solution

Accepted Solutions

Jon Marshall
Hall of Fame
Hall of Fame

You need to add a VPNv4 address family configuration to both PE routers as this is used to exchange the VPN information between PE routers.

So you need to add this under your BGP configuration -

address-family vpnv4

neighbor activate

neighbor send-community both

Jon

View solution in original post

1 Reply 1

Jon Marshall
Hall of Fame
Hall of Fame

You need to add a VPNv4 address family configuration to both PE routers as this is used to exchange the VPN information between PE routers.

So you need to add this under your BGP configuration -

address-family vpnv4

neighbor activate

neighbor send-community both

Jon

Review Cisco Networking products for a $25 gift card