Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

BGP routing issue

hi,

I'm having a problem with a new network i've added to my router. I've added a network 172.17.19.0/27 and 172.17.19.32/27... and have added the following SubInterface config for one of them:

interface FastEthernet0/0.5

description Voice Vlan

encapsulation dot1Q 5

ip address 172.17.19.2 255.255.255.224

no ip redirects

ip pim sparse-dense-mode

ip cgmp

no snmp trap link-status

standby 1 ip 172.17.19.1

standby 1 priority 105

standby 1 preempt

standby 1 track Serial0/1/0:0

I've added it to my BGP AS as below:

router bgp 65202

no synchronization

bgp log-neighbor-changes

network 10.200.200.0 mask 255.255.255.224

network 172.17.9.0 mask 255.255.255.0

network 172.17.10.0 mask 255.255.255.0

network 172.17.11.248 mask 255.255.255.248

network 172.17.19.0 mask 255.255.255.224

network 172.17.19.32 mask 255.255.255.224

aggregate-address 172.17.10.0 255.255.254.0 summary-only

also I've added the following ACL:

access-list 108 deny udp host 172.17.19.4 any eq 5000

access-list 108 permit ip 172.17.19.0 0.0.0.31 any

access-list 109 permit udp host 172.17.19.0 any eq 5000

But I can't acecss this network from another other router. Any idea what i'm missing. i'm not an expert on Routing.

3 REPLIES

Re: BGP routing issue

If you do a show ip bgp in the neighboring router, can you see the new prefixes? Also, just to check, when you do show ip bgp summary, can you see the neighbors you are expecting?

In the neighboring routers, what do you get for show ip route 172.17.19.0?

Kevin Dorrell

Luxembourg

New Member

Re: BGP routing issue

Hi Kevin,

I see this when i do a show ip bgp:

*> 172.17.9.0/24 0.0.0.0 0 32768 i

s> 172.17.10.0/24 0.0.0.0 0 32768 i

* i172.17.10.0/23 172.17.10.21 0 100 0 i

*> 0.0.0.0 32768 i

s> 172.17.11.248/29 0.0.0.0 0 32768 i

* i172.17.19.0/27 172.17.10.21 0 100 0 i

*> 0.0.0.0 0 32768 i

* i172.17.19.32/27 172.17.10.21 0 100 0 i

the neighbors seem normal. I've checked the same setup on another router in a different location,...these are 172.16.6.0 and it shows up as follows:

s> 172.16.5.0/24 0.0.0.0 0 32768 i

s> 172.16.6.0/28 0.0.0.0 0 32768 i

s> 172.16.6.16/28 0.0.0.0 0 32768 i

s> 172.16.6.32/28 0.0.0.0 0 32768 i

s> 172.16.8.0/24 0.0.0.0 0 32768 i

Could it be to do with the way I have HSRP set up?

Re: BGP routing issue

HI, [Do Rate if HELPS]

You should have missed the I-BGP routing:

What is the IGRP protocol you are using ?

Pls check was there any "ip route" command need to be added for internal route synchronization. Like,

ip route 172.17.19.0 255.255.255.224

Do Rate if HELPS

Best Regards,

Guru Prasad R

209
Views
0
Helpful
3
Replies
CreatePlease to create content