Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

BGP Routing Issues

Hi All,

 

I am having this issue with one of our customer. The router one is not showing the correct next-hop address as compare to router two.

 

CE1---->PE1

CE2---->PE2

 

The existing config is as follows

PE1

=====

interface Loopback1
 description NAT address for web traffic
 ip address 192.168.1.20 255.255.255.255
!
interface GigabitEthernet0/1
 description xxxx
 ip address x.5.111.69 255.255.255.252
 duplex full
 speed 100
!

interface Serial1/0.3 point-to-point
 description PVC to CustomerA
 bandwidth 500
 ip address y.6.66.118 255.255.255.252
 ip nat inside  
!
router bgp 65120
 no synchronization
 bgp log-neighbor-changes
 neighbor x.5.111.70 remote-as 65120
 neighbor x.5.111.70 description IBGP to backup router
 neighbor x.5.111.70 next-hop-self
 neighbor x.5.111.70 soft-reconfiguration inbound
 neighbor y.6.66.117 remote-as 13009
 neighbor y.6.66.117 description customerA
 neighbor y.6.66.117 soft-reconfiguration inbound
 neighbor y.6.66.117 route-map HOST out
 neighbor y.6.66.117 filter-list 1 in
!
ip as-path access-list 1 deny _64500_
ip as-path access-list 1 permit .*
!
ip nat inside source list 11 interface Loopback1 overload
!
ip access-list standard HOST
 permit 210.11.66.244
 
!
access-list 11 permit ip 10.0.0.0 0.255.255.255 host z.11.66.244
!
route-map HOST-HOST permit 10
 match ip address HOST
 set as-path prepend 64500 64500
!
route-map HOST-HOST deny 20
!

PE2

======

interface Loopback1
 description NAT address for web traffic
 ip address 192.168.1.21 255.255.255.255
!
interface GigabitEthernet0/1
 description xxx
 ip address x.5.111.70 255.255.255.252
 duplex full
 speed 100
!

interface Serial1/0.3 point-to-point
 description PVC to CustomerA
 bandwidth 500
 ip address y.6.66.122 255.255.255.252
 ip nat inside  
!
router bgp 65120
 no synchronization
 bgp log-neighbor-changes
 neighbor x.5.111.69 remote-as 65120
 neighbor x.5.111.69 description IBGP to backup router
 neighbor x.5.111.69 next-hop-self
 neighbor x.5.111.69 soft-reconfiguration inbound
 neighbor y.6.66.121 remote-as 13009
 neighbor y.6.66.121 description customerA
 neighbor y.6.66.121 soft-reconfiguration inbound
 neighbor y.6.66.121 route-map HOST out
 neighbor y.6.66.121 filter-list 1 in
!
ip as-path access-list 1 deny _64500_
ip as-path access-list 1 permit .*
!
ip nat inside source list 11 interface Loopback1 overload
!
ip access-list standard HOST
 permit z.11.66.244
!
access-list 11 permit ip 10.0.0.0 0.255.255.255 host z.11.66.244
!
route-map HOST-HOST permit 10
 match ip address HOST
 set as-path prepend 64500 64500
!
route-map HOST-HOST deny 20
!

The intended result is as follows as showing from router two

PE1# show ip bgp | in 10.16

*i10.16.0.0/16    x.5.111.70          0   100  0 13009 65000 i 

PE2# show ip bgp | in 10.16

*>10.16.0.0/16    y.6.66.121          0   100  0 13009 65000 i 

 

I think the customer connection issue will resolve if we can correct the routing in PE1 like as below

PE1# show ip bgp | in 10.16

*>10.16.0.0/16    y.6.66.117          0   100  0 13009 65000 i 

 

What is required to correct it? Please advice.

Everyone's tags (1)
107
Views
0
Helpful
0
Replies
CreatePlease to create content