Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

bgp small network

Hello all,

I have a c890 witch is a default gateway for the lan behind it.

The router is configured with bgp for 2 providers and local network is /24 routable network (92.224.1.0/24).

I think bgp is configured corectly because I can ping any ip from the router (92.224.1.1), for example I can ping 8.8.8.8.

The problem is that I can not ping anything from the local network, from example I can not ping 8.8.8.8 (google dns) from 92.224.1.2.

92.224.1.2 has as default gw 92.224.1.1.

92.224.1.2 -> 92.224.1.1 -> BGP 2 ISP's

Thanks.

Everyone's tags (1)
13 REPLIES
Purple

bgp small network

Hi,

can you post output from following on the router:

-sh ip route

-sh ip bgp

Regards.

Alain

Don't forget to rate helpful posts.
New Member

bgp small network

sure,

sh ip route

Gateway of last resort is 89.xxx.xxx.121 to network 0.0.0.0

B*    0.0.0.0/0 [20/0] via 89.xxx.xxx.121, 00:39:14

      89.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C        89.xxx.xxx.120/30 is directly connected, FastEthernet8

L        89.xxx.xxx.122/32 is directly connected, FastEthernet8

      92.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C        92.224.1.0/24 is directly connected, GigabitEthernet0

L        92.224.1.1/32 is directly connected, GigabitEthernet0

sh ip bgp

   Network          Next Hop            Metric LocPrf Weight Path

*> 0.0.0.0          89.xxx.xxx.121           0             0 6xx3 i

I've pulled out one isp.

Purple

bgp small network

Hi,

you didn't advertise your 92.224.1/24 network into BGP so this network is not reachable from outside on any other AS.

just advertise it either with a network command or redistribute it.

router bgp xxx

network 92.224.1.0 mask 255.255.255.0

or

router bgp xxx

redistribute connected route-map 92_Prefix

ip prefix-list myprefix permit 92.224.1.0/24

route-map 92_Prefix

match ip address prefix-list myprefix

Regards.

Alain.

Don't forget to rate helpful posts.
New Member

bgp small network

I have the network command in my config. I just spoked with my isp and they told me that they can not see any advertise from my ip (89.xxx.xxx.122).

My bgp config. I've deleted the second isp for testing.

I don't have any acl configured on the router.

router bgp 5xxx1

no synchronization

bgp log-neighbor-changes

network 92.224.1.0 mask 255.255.255.0

neighbor 89.xxx.xxx.121 remote-as 6xx3

neighbor 89.xxx.xxx.121 ebgp-multihop 3

neighbor 89.xxx.xxx.121 next-hop-self

no auto-summary

Thanks.

New Member

bgp small network

HI mate...

please issue the comand "Show ip bgp neigh 89.xxx.xxx advertised-routes."   and paste the output here please...

have you cleared the bgp table after you added the network statement ? if not.. issue  clear ip bgp * soft

cheers

New Member

Re: bgp small network

Hello, the result is 0.

show ip bgp neighbors 89.xxx.xxx.121 advertised-routes

Total number of prefixes 0

Yes, I've cleared the bgp table.

New Member

bgp small network

YOu probably have a conflict in your routing table...  IF its not properly installed in the routing table, BGP wont propagate anything...

i know the prefix is directly connected as seen in your routing table... 

but if you issue the command  show ip route 92.224.1.0 , what u see ?

New Member

Re: bgp small network

What can I do ?

sh ip rou 92.224.1.0

Routing entry for 92.224.1.0/24

  Known via "connected", distance 0, metric 0 (connected, via interface)

  Routing Descriptor Blocks:

  * directly connected, via GigabitEthernet0

      Route metric is 0, traffic share count is 1

New Member

bgp small network

remove the network for that subnet and add the one for loopback to see if you can propagate your loopback... if not.. i would reboot your router

btw...  you can remove this command

neighbor 89.xxx.xxx.121 next-hop-self

as you are dealing with an EBGP connection the next hop will always change to your router`s address when it advertises learned prefixes and locally originated ones, thus you dont really need it.

Silver

bgp small network

Provide output of show ip bgp neighbor

show " show ip bgp neigshow ip

---

Posted by WebUser Chetan Mahendroo

New Member

bgp small network

Sorry for the late response.

I will try next year with loopback, what Gustavo says.

Until then bgp is down.

Is strange, because on linux with quaga bgp was working well but here (Cisco C892) does not work. I'm sure I have missed something.

Until next year I whish you all a Happy New Year!

... and thanks for the support.

New Member

bgp small network

alright... let us know how it goes...

New Member

Re: bgp small network

Hello, I just tried with the network configured on loopback and all it's working fine

I still don't understand why the network configured on a fa port can't be advertised but on loopback is working.

Anyway, thank you all for the support.

691
Views
3
Helpful
13
Replies
CreatePlease to create content