Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

bgp to 2 providers for isp redundancy, active standby

Hi there

If I have 2 internet providers and my own AS and I want to route to only of them so basically a active standby setup, how would I achieve this ?

say I own the network 195.1.1.0/24 and only want this to advertise this out on one router and the other will be standby, and also for outgoing traffic I want to use the same router!

what config would be best for this ?

3 REPLIES
New Member

Re: bgp to 2 providers for isp redundancy, active standby

Hi there.

This can be achieved by using route maps with AS paths and pre pending.

I use this setup in our call centre.
If you want I can post the relevant config minus ip addressing later if you require it for guidance purposes?



Sent from Cisco Technical Support iPhone App

New Member

bgp to 2 providers for isp redundancy, active standby

yes the config would be great

however thats for incoming traffic to your AS

how about the outgoing traffic from your internal net ?

New Member

bgp to 2 providers for isp redundancy, active standby

Hi there.

Here is the config for router 1, I also have eigrp running between two L3 switches connected to the two routers for users

interface Loopback0

ip address 10.255.2.21 255.255.255.255

!

interface GigabitEthernet0/0

ip address 10.253.2.89 255.255.255.248

!

interface GigabitEthernet0/1

ip address 10.254.2.198 255.255.255.252

(External to ISP)

!

router eigrp 1

redistribute connected

redistribute bgp 65135 route-map SET-TAG-FOR-EXTERNAL-PREFIX

network 10.253.2.89 0.0.0.0

default-metric 100000 1 255 1 1500

no auto-summary

eigrp router-id 10.255.2.21

!

router bgp 65135

bgp router-id 10.255.2.21

bgp log-neighbor-changes

neighbor 10.254.2.197 remote-as 65530

!

address-family ipv4

redistribute eigrp 1 route-map DENY-EXTERNAL-PREFIXES

neighbor 10.254.2.197 activate

neighbor 10.254.2.197 soft-reconfiguration inbound

neighbor 10.254.2.197 route-map BGP-INBOUND-FILTER in

no auto-summary

no synchronization

network 10.255.2.21 mask 255.255.255.255

exit-address-family

!

!

ip as-path access-list 1 deny _65035$

ip as-path access-list 1 permit .*

!

route-map BGP-INBOUND-FILTER permit 10

match as-path 1

!

route-map DENY-EXTERNAL-PREFIXES deny 10

match tag 99

!

route-map DENY-EXTERNAL-PREFIXES permit 20

!

route-map SET-TAG-FOR-EXTERNAL-PREFIX permit 10

set tag 99

*****************************************************************

Router 2

interface Loopback0

ip address 10.255.2.23 255.255.255.255

!

interface GigabitEthernet0/0

(External to ISP)

ip address 10.254.2.98 255.255.255.252

!

!

interface GigabitEthernet0/1

ip address 10.253.2.97 255.255.255.248

no ip redirects

no ip proxy-arp

duplex auto

speed auto

!

!

router eigrp 1

redistribute connected

redistribute bgp 65035 route-map SET-TAG-FOR-EXTERNAL-PREFIX

network 10.253.2.97 0.0.0.0

default-metric 1000 1 255 1 1500

no auto-summary

eigrp router-id 10.255.2.23

!

router bgp 65035

bgp router-id 10.255.2.23

bgp log-neighbor-changes

neighbor 10.254.2.97 remote-as 65530

!

address-family ipv4

redistribute eigrp 1 route-map DENY-EXTERNAL-PREFIXES

neighbor 10.254.2.97 activate

neighbor 10.254.2.97 soft-reconfiguration inbound

neighbor 10.254.2.97 route-map BGP-INBOUND-FILTER in

neighbor 10.254.2.97 route-map AS-PATH-PREPEND out

no auto-summary

no synchronization

network 10.255.2.23 mask 255.255.255.255

exit-address-family

!

!

ip as-path access-list 1 deny _65135$

ip as-path access-list 1 permit .*

!

route-map BGP-INBOUND-FILTER permit 10

match as-path 1

!

route-map DENY-EXTERNAL-PREFIXES deny 10

match tag 99

!

route-map DENY-EXTERNAL-PREFIXES permit 20

!

route-map SET-TAG-FOR-EXTERNAL-PREFIX permit 10

set tag 99

!

route-map AS-PATH-PREPEND permit 10

set as-path prepend 65035

!

!

This config stops internal routes from being broadcast to the network but if router 1 dies then router 2 takes over straight away.

Hope this helps.

688
Views
0
Helpful
3
Replies
CreatePlease login to create content