Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

BGP: Unable to announce route using the Network Statement

The host IP 84.204.x.x unable to announce through BGP

BGP configuration on Cisco 1841:

!

interface FastEthernet0.1201

encapsulation dot1Q 1201

ip address 172.18.11.1 255.255.255.252

no ip redirects

no ip unreachables

no ip proxy-arp

crypto map vpn-map

service-policy output POLICY-IPVPN-8M-OUT

!

router bgp 65001

no synchronization

bgp router-id 192.168.255.11

bgp log-neighbor-changes

network 84.204.x.x mask 255.255.255.255

network 172.18.11.0 mask 255.255.255.252

redistribute eigrp 1 route-map RMAP-EIGRP-TO-BGP

redistribute rip route-map RMAP-RIP-TO-BGP

neighbor 172.18.11.2 remote-as 3216

neighbor 172.18.11.2 description *** ISP-PE Neighbor ***

neighbor 172.18.11.2 update-source FastEthernet0.1201

neighbor 172.18.11.2 route-map RMAP-AS-PREPEND2 out

no auto-summary

!

ip route 0.0.0.0 0.0.0.0 10.102.0.21

ip route 84.204.x.x 255.255.255.255 10.102.0.21 200

!

route-map RMAP-AS-PREPEND permit 10

set as-path prepend 65001 65001 65001

!

route-map RMAP-AS-PREPEND2 permit 5

match ip address prefix-list PFXL-LAN-IPVPN PFXL-LOOPBACK-IPVPN

!

route-map RMAP-AS-PREPEND2 permit 10

match ip address prefix-list PFXL-LAN PFXL-LOOPBACK

set as-path prepend 65000

!

route-map RMAP-AS-PREPEND2 permit 20

match ip address prefix-list PFXL-ANY

!

CE1#sh ip bgp

BGP table version is 1220, local router ID is 192.168.255.11

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

r> 0.0.0.0          172.18.11.2                            0 3216 65000 i

*> 10.0.0.0/23      172.18.11.2                            0 3216 65000 ?

*  10.0.0.0         172.18.11.2                            0 3216 65000 i

*>                  172.17.253.254          78         32768 ?

...

*> 10.102.0.0/23    0.0.0.0                 70         32768 ?

*> 10.202.20.0/23   172.18.11.2                            0 3216 65002 ?

*> 84.204.x.x/32 10.102.0.21              0         32768 i

*  172.18.11.0/30   172.18.11.2              0             0 3216 ?

*>                  0.0.0.0                  0         32768 i

*> 172.18.12.0/30   172.18.11.2                            0 3216 ?

...

CE1#sh ip bgp neighbors 172.18.11.2 advertised-routes

BGP table version is 1220, local router ID is 192.168.255.11

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

*> 10.0.0.0         172.17.253.254          78         32768 ?

*> 10.11.32.0/23    0.0.0.0         4294967295         32768 ?

*> 10.102.0.0/23    0.0.0.0                 70         32768 ?

*> 192.168.255.0    172.17.253.254          78         32768 ?

*> 192.168.255.11/32

                    0.0.0.0                  3         32768 ?

Total number of prefixes 5

Everyone's tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: BGP: Unable to announce route using the Network Statement

Hello Anton,

modify the prefix-list

ip prefix-list PFXL-ANY seq 5 permit 0.0.0.0/0

as

ip prefix-list PFXL-ANY seq 5 permit 0.0.0.0/0 le 32

if the objective is to match any available IP prefix in BGP table

the route is present in the IP routing table and should be also in the BGP table so the issue is the prefix-list

Note:

you should prepend your own AS 65001 and not 65000

Hope to help

Giuseppe

4 REPLIES

Re: BGP: Unable to announce route using the Network Statement

Hi,

Please check if the route for 84.204.x.x is available in the routing table. This is mandatory for the network command to work.Also please post the outputs of the prefix-lists. 'show run | in prefix-list' will help

Thanks,

Karthic

New Member

Re: BGP: Unable to announce route using the Network Statement

Hi, see ip route and prefix-lists below:

CE1#sh ip route 84.204.56.212

Routing entry for 84.204.56.212/32

  Known via "static", distance 200, metric 0

  Advertised by bgp 65001

  Routing Descriptor Blocks:

  * 10.102.0.21

      Route metric is 0, traffic share count is 1

CE1#show run | in prefix-list

ip prefix-list PFXL-ANY seq 5 permit 0.0.0.0/0

ip prefix-list PFXL-DMVPN seq 5 permit 172.16.0.0/16 ge 24 le 24

ip prefix-list PFXL-DMVPN seq 10 permit 172.16.0.0/16 ge 32

ip prefix-list PFXL-GRE seq 5 permit 172.17.0.0/16 ge 30 le 30

ip prefix-list PFXL-IPVPN seq 5 permit 172.18.254.0/24 ge 30 le 30

ip prefix-list PFXL-IPVPN seq 10 permit 172.18.11.0/24 ge 30 le 30

ip prefix-list PFXL-IPVPN seq 15 permit 172.18.12.0/24 ge 30 le 30

ip prefix-list PFXL-IPVPN seq 20 permit 172.18.13.0/24 ge 30 le 30

ip prefix-list PFXL-LAN seq 4 permit 10.0.0.0/8

ip prefix-list PFXL-LAN seq 5 permit 10.0.0.0/8 ge 23 le 28

ip prefix-list PFXL-LAN-CO seq 5 permit 10.0.0.0/22 ge 23 le 28

ip prefix-list PFXL-LAN-CO seq 10 permit 10.100.0.0/22 ge 23 le 28

ip prefix-list PFXL-LAN-CO seq 15 permit 10.101.0.0/22 ge 23 le 28

ip prefix-list PFXL-LAN-CO seq 20 permit 192.168.252.0/24

ip prefix-list PFXL-LAN-IPVPN seq 5 permit 10.102.0.0/22 ge 23 le 28

ip prefix-list PFXL-LAN-IPVPN seq 10 permit 10.202.8.0/22 ge 23 le 28

ip prefix-list PFXL-LAN-IPVPN seq 15 permit 10.202.20.0/22 ge 23 le 28

ip prefix-list PFXL-LOOPBACK seq 4 permit 192.168.255.0/24

ip prefix-list PFXL-LOOPBACK seq 10 permit 192.168.255.0/24 ge 32

ip prefix-list PFXL-LOOPBACK-CO seq 5 permit 192.168.255.255/32

ip prefix-list PFXL-LOOPBACK-CO seq 10 permit 192.168.255.254/32

ip prefix-list PFXL-LOOPBACK-CO seq 15 permit 192.168.255.253/32

ip prefix-list PFXL-LOOPBACK-IPVPN seq 5 permit 192.168.255.11/32

ip prefix-list PFXL-LOOPBACK-IPVPN seq 10 permit 192.168.255.12/32

ip prefix-list PFXL-LOOPBACK-IPVPN seq 15 permit 192.168.255.13/32

Hall of Fame Super Silver

Re: BGP: Unable to announce route using the Network Statement

Hello Anton,

modify the prefix-list

ip prefix-list PFXL-ANY seq 5 permit 0.0.0.0/0

as

ip prefix-list PFXL-ANY seq 5 permit 0.0.0.0/0 le 32

if the objective is to match any available IP prefix in BGP table

the route is present in the IP routing table and should be also in the BGP table so the issue is the prefix-list

Note:

you should prepend your own AS 65001 and not 65000

Hope to help

Giuseppe

Re: BGP: Unable to announce route using the Network Statement

You are not matching the prefix in any of the prefix lists. Please add the command

ip prefix-list PFXL-ANY seq 20 permit 84.204.56.212/32

so that we can advertise this prefix

1095
Views
0
Helpful
4
Replies
CreatePlease login to create content