Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

BGP vs OSPF redistribution problem (Solution required)

Dear All,

I have configured CErouter and L3 switch and running OSPF and eBGP between CE-Router and PE router. I am unable to see the network at australia (remote-end) if i am advertising network from L3 switch-in OSPF. The remote-end is running eBGP simply and receving rest all network.

Seems as if there is issue with redistribution in BGP.

Please suggest the correct way of redistribution.

========CE-Router config=======

router ospf 1

router-id 10.118.65.1

log-adjacency-changes

redistribute bgp 24084 metric 100 subnets

network 10.118.65.0 0.0.0.7 area 0

default-information originate metric 100

!

router bgp 24084

no synchronization

no bgp log-neighbor-changes

network 10.118.65.0 mask 255.255.255.248

redistribute ospf 1 metric 10

neighbor 172.34.15.129 remote-as 9730

neighbor 172.34.15.129 ebgp-multihop 2

neighbor 172.34.15.129 update-source FastEthernet0/0

neighbor 172.34.15.129 version 4

neighbor 172.34.15.129 allowas-in

neighbor 172.34.15.129 soft-reconfiguration inbound

no auto-summary

sh ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface

10.118.65.2 0 FULL/DROTHER 00:00:36 10.118.65.2 FastEthernet0/

1

=========L3- Switch Config==========

router ospf 1

router-id 10.118.65.2

log-adjacency-changes

network 10.118.64.0 0.0.0.255 area 0

network 10.118.65.0 0.0.0.7 area 0

!

sh ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface

10.118.65.1 255 FULL/DR 00:00:34 10.118.65.1 GigabitEtherne

t0/24

9 REPLIES

Re: BGP vs OSPF redistribution problem (Solution required)

ou are redistributing OSPF into BGP, but do you need to redistirbute the BGP routes into the OSPF as well?

BTW, what does the "metric 10" do when redistributing into BGP? Does is set the MED?

Kevin Dorrell

Luxembourg

Community Member

Re: BGP vs OSPF redistribution problem (Solution required)

Hi kevin,

please suggest the correction required and how should i instill the defualt route which i am receiving from eBGP into OSPF.

Yes, of course i am re-distributing the network 10.118.64.0 into BGP and redistributing learned prefixes into OSPF.

Re: BGP vs OSPF redistribution problem (Solution required)

At the moment you are re-distributing the OSPF routes into BGP with your redistribute ospf 1 line.

I think what you need to re-distribute the BGP routes into OSPF is:

router ospf 1

 redistribute bgp

You can add a metric after the line if you want, otherwise it takes a default cost of 20.

As for your network command under BGP, it will advertise that prefix to BGP, but only if it is already in the routing table with that exact prefix and mask.

Kevin Dorrell

Luxembourg

Community Member

Re: BGP vs OSPF redistribution problem (Solution required)

Hi Kevin,

Please find the attached network diagram. I want to have 2 ASBR as DR & BDR. Is it possible to achieve when both are not directly connected to each-other.

Kindly suggest the the other workaround incase Area0 is not feasible to achieve.

Re: BGP vs OSPF redistribution problem (Solution required)

I think you may have confused the concept of DR and BDR. There is not just one DR and one BDR per area. The DR and BDR are only really relevant when you have two or more routers attached to a single VLAN (multi-access network). Your area 0 might have several VLANs or networks in it, and each network will have a DR and BDR.

Think of it this way: the DR on a multi-access network is the router that speaks on behalf of all the others.

In your case, the segment between CE1 and L3S1 will have a DR and a BDR. The segment between CE2 and L3S2 will also have a DR and BDR. Each CE router will advertise the external routes to the rest of the OSPF area.

If you want to use CE1 in preference to CE2, and CE2 as a backup, then you simply set the default metric of the imported routes on CE2 to metric 30. The imported routes on CE1 will already have a metric of 20 by default. Since the imported routes are type E2, this metric will not change as you go through the network.

Hope this helps. If you need any more help with the concepts, just ask.

Area 0 shoud work correctly as per your diagram, but take out the bit about DR, BDR, and Drother.

Kevin Dorrell

Luxembourg

Community Member

Re: BGP vs OSPF redistribution problem (Solution required)

Dear Kevin,

Thanx for your response. I would like to share the concept what we have tried to implement. CE-1 router would act as DR and CE-2 router as BDR. These two L3 switches are not in same LAN. They are almost 20miles (30kmtrs) and connected via E1 link (EoSDH).Incase , we do not use ip ospf priority command to elct the DR and BDR then how would the LSA (Ext Type-2) identify that CE1router or link has failed and traffic has to be shifted onto CERouter2.

Please share your comments.

Re: BGP vs OSPF redistribution problem (Solution required)

Sorry, I missed the bit about EoSDH. Does this mean that the CE1 and CE2 are on the same subnet and the same LAN? (I know not physically, but virtually so.) I don't have experience with EoSDH, but are you using it as a layer-2 bridge between parts of the same VLAN(s) on the two sites? Are CE1 and CE2 on the same IP subnet and can ping each other?

If so, then the concept of DR and BDR should be OK as you wrote it.

It that how it is?

Kevin Dorrell

Luxembourg

Re: BGP vs OSPF redistribution problem (Solution required)

Hello,

Under OSPF configuration:

default-information originate always

Does this solve your problem?

Br,

Calin

Community Member

Re: BGP vs OSPF redistribution problem (Solution required)

Hi All,

I did give defualt-information originate. I have not included always b'coz ospf is receiving the defualt route from eBGP. Please see the below scenario..

L3swtch---CE1---PE-1--MPLS cloud--PE-2---CE2.

Now if i am advertising default-information originate from eBGP of CE2. its getting propogated uptill L3switch and OSPF is learning it via eBGP. Incase, i do it always.. then there would be an issue. Internal LAN 'll never detect that far-end is down and 'll always receive the 0.0.0.0 via OSPF neighbour.

720
Views
0
Helpful
9
Replies
CreatePlease to create content