Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

BGP with Loadbalancing

Hi,

I would like to check in-depth how does this BGP with maximum path 2 works. Does it load balance 50 50 between the 2 links that are of the same bandwidth?

The configuration is just by adding maximum path 2 at both the CE and PE end?

5 REPLIES

Re: BGP with Loadbalancing

BGP maximum path 2 allows installation of a second path to a particular destination in the routing table if certain characteristics of the second path match that of the best path. As far the ratio of load balancing is concerned it's based on the switching type, cef/fast/process, configured on the ingress interface. BGP doesn't factor in the link size for choosing the path or load balancing. If process switching is enabled on the ingress interface then the ratio might be probably close to 50:50.

Have a look at this document.

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080094431.shtml#bgpmpath

HTH

Sundar

Silver

Re: BGP with Loadbalancing

Best way i can suggest you to configure this by Lookpback interface configuration.

If you have Point to Point 2 Links terminated on both end single router.

interface loopback 0

ip address 1.1.1.1 255.255.255.0

router bgp 11

neighbor 2.2.2.2 remote-as 10

neighbor 2.2.2.2 update-source loopback 0

neighbor 2.2.2.2 ebgp-multihop

{Same configuraation at other end.}

Buth if you have two different ISP or two different router you should select another way for load balancing.

Maximum possible way for Load balancing available on below URL:

http://www.cisco.com/warp/public/459/40.html#conf1

Choose appropriate as your scenario.

Regards,

Dharmesh Purohit

New Member

Re: BGP with Loadbalancing

Hi,

Thanks for the assistance. The BGP is running fine, just that the load balancing wasn't what I had expected. Seem like traffic is going out via 1 link and coming back via the other link.

Below is the config

PE

router bgp 234

redistribute connected

redistribute static

neighbor 192.19.50.1 remote-as 123

neighbor 192.19.50.1 activate

neighbor 192.19.50.1 soft-reconfiguration inbound

neighbor 192.19.50.6 remote-as 123

neighbor 198.19.50.6 activate

neighbor 198.19.50.6 soft-reconfiguration inbound

maximum-paths 2

no auto-summary

no synchronization

network 0.0.0.0

CE

router bgp 123

bgp log-neighbor-changes

neighbor 192.19.50.1 remote-as 234

neighbor 198.19.50.5 remote-as 234

maximum-paths 2

redistribute connected

redistribute static

neighbor 192.19.50.1 activate

neighbor 192.19.50.5 activate

no auto-summary

no synchronization

network 192.168.0.0

Re: BGP with Loadbalancing

HI,

Refer link below for Load Sharing with BGP in Single Homed & Multi-Homed Environments:

http://www.cisco.com/en/US/tech/tk365/technologies_configuration_example09186a00800945bf.shtml

DO RATE ALL HELPFUL POSTS

Best Regards,

Guru Prasad R

Silver

Re: BGP with Loadbalancing

It is also possible to load-balance across unequal cost paths for outside traffic using "bgp dmzlink-bw" command and communities (automatic).

Please refer to this document:

http://cisco.com/en/US/customer/products/sw/iosswrel/ps1839/products_feature_guide09186a00800b5d5e.html

131
Views
9
Helpful
5
Replies
CreatePlease to create content