Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

BGP without direct link

Hi,

is it possible for R1-AS100 and R2-AS300 to exchange BGP routing while there is a Router3 in the middle of them with Static routing ?

BGP without direct link

http://home.netpower.no/paal/bgp-possible.jpg

regards,

Paal

10 REPLIES

Re: BGP without direct link

Hello!

Yes it is possible with ebgp-multihop "x"

where x in your case should be 2 (number of the hops to the other peer side)

You have a small template above how I would do it:

--------------

R1-AS100

int lo0

ip address 1.1.1.1 255.255.255.255

router bgp 100

bgp log-neighbor-changes

neighbor 2.2.2.2 remote-as 300

neighbor 2.2.2.2 description R2

neighbor 2.2.2.2 ebgp-multihop 2

neighbor 2.2.2.2 update-source Loopback0

ip route 2.2.2.2 255.255.255.255 "next-hop-IP"

----------

R2-AS300

int lo0

ip address 2.2.2.2 255.255.255.255

router bgp 300

bgp log-neighbor-changes

neighbor 1.1.1.1 remote-as 100

neighbor 1.1.1.1 description R1

neighbor 1.1.1.1 ebgp-multihop 2

neighbor 1.1.1.1 update-source Loopback0

ip route 1.1.1.1 255.255.255.255 "next-hop-IP"

Hope it's ok for you. If you have any concern reply here.

Good luck!

Cheers,

Calin

Hall of Fame Super Silver

Re: BGP without direct link

Hello Calin,

in this case there is another router in the middle so it needs:

neigh x.x.x.x ebgp-multihop 3 if using loopbacks

Hope to help

Giuseppe

Re: BGP without direct link

Hi Giuseppe,

I'm sure that is ebgp-multihop 2, I just tried :)

The idea, as I understand ebgp-multihop, is that this is counting the hops until destination. 1st hop is the router in the middle, the 2nd hope is bgp router's interface connected to the middle router and the 3 hop is actual the destination, and this is not count as hop.

If you want to talk more about this write to me: calin@ezeea.com . I don't want to transform this question into a flame here :)

Cheers,

Calin

Cisco Employee

Re: BGP without direct link

Calin,

You are completely right that a TTL of 2 is sufficient to establish the session in this scenario. In principle, you should also be able to establish a session with a directly connected router using a TTL of 1, even if the session is establish using the loopback interface address. But in reality, establishing a session to the loopback interface address of a directly connected router requires to set the TTL to 2 on the ebgp-multihop command, unless you use the "neighbor disable-connected-check" command.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: BGP without direct link

you have to remember that if the router in the middle is not running BGP, unless you're doing some kind of mpls switching, most likely your packets will drop. Unless you have all the static routes possible that you need for that router in the middle. And running BGP i doubt it but i could be wrong. You can always create a GRE tunnel and do it that way.

Hall of Fame Super Silver

Re: BGP without direct link

Hello Calin,

what works is correct.

I couldn't try but I had always used multihop 2 to establish an eBGP connection on loopbacks so I thought a value of 3 was needed.

I should have written it as a possible suggestion !

Thank you for your feedback and I've remarked your useful answer.

Best Regards

Giuseppe

New Member

Re: BGP without direct link

thanks for your engagement!

This is the whole case, I have tried with the ebgp-multihop command, but still no luck.

new drawing :

http://home.netpower.no/paal/bgp-possible2.jpg

BGP sessions seems to be established:

Description: R1

BGP version 4, remote router ID 192.168.116.90

BGP state = Established, up for 00:17:39

I can not ping 193.214.20.211 from 192.168.234.163

There is no routing on R3 since the interfaces are DirectConnected

When I :

R2-AS300#ping 193.214.20.211 source fa0

there is no response

the following is my config:

R1-AS100

---------

!

interface FastEthernet0

ip address 192.168.116.90 255.255.255.0

!

interface FastEthernet1

ip address 172.28.10.9 255.255.255.252

!

router bgp 100

no synchronization

bgp log-neighbor-changes

redistribute static

neighbor 172.28.10.2 remote-as 300

neighbor 172.28.10.2 description R2

neighbor 172.28.10.2 ebgp-multihop 2

neighbor 172.28.10.2 update-source Fa1

no auto-summary

!

ip route 172.28.10.2 255.255.255.255 172.28.10.10

ip route 193.214.20.211 255.255.255.255 192.168.116.1

R2-AS300

---------

!

interface FastEthernet0

ip address 192.168.234.1 255.255.255.0

!

interface Vlan2

ip address 172.28.10.2 255.255.255.252

!

router bgp 300

no synchronization

!bgp router-id 172.28.10.2

bgp log-neighbor-changes

network 192.168.234.0

neighbor 172.28.10.9 remote-as 100

neighbor 172.28.10.9 description R1

neighbor 172.28.10.9 ebgp-multihop 2

neighbor 172.28.10.9 update-source vlan2

no auto-summary

!

ip route 172.28.10.9 255.255.255.255 172.28.10.1

Re: BGP without direct link

Hi there!

OK, so step by step:

1.

give us the output on both routers of

show ip bgp sum

2.

from R1-AS100 can you ping 172.28.10.2 ?

the same

from R2-AS300 can you ping 172.28.10.9

3. try this on both router bgp config

neighbor 172.28.10.2 ebgp-multihop 1

neighbor 172.28.10.9 ebgp-multihop 1

Actual you have only one hop to the destination of peer bgp.

Good luck!

Cheers,

Calin

New Member

Re: BGP without direct link

I am able to ping

172.28.10.2 from R1

and

172.28.10.9 from R2

When I set

neighbor 172.28.10.9 ebgp-multihop 1

the BGP State = Idle

reset connection with :

R1-AS100#clear ip bgp 300

when I set

neighbor 172.28.10.9 ebgp-multihop 2

BGP state = Established, up for 00:00:07

I thinks that's because it is 2 hops ?

Output of 'show ip bgp sum' is in the new drawing with 'show ip route'

http://home.netpower.no/paal/bgp-possible2.jpg

additional info:

R2-AS300#traceroute 193.214.20.211 source vlan2

Type escape sequence to abort.

Tracing the route to 193.214.20.211

1 172.28.10.1 0 msec 0 msec 0 msec

2 172.28.10.1 !H * !H

R2-AS300#

R2-AS300#traceroute 193.214.20.211 source fa0

Type escape sequence to abort.

Tracing the route to 193.214.20.211

1 * * *

2 * * *

3 * * *

Many thanks,

Paal

Cisco Employee

Re: BGP without direct link

Paal,

It will definitely not work with "ebgp-multihop 1". You need "ebgp-multihop 2".

As someone already mentioned, you need to make sure that the router in between will be able to route the traffic via static routes (might be cumbersome), MPLS, etc.

Regards,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
379
Views
5
Helpful
10
Replies
CreatePlease to create content