Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

BGP

iam new to networking.

when i was seeing the configurations of BGP. i was just not able to understand.

there was only physical interface connected to the remote peer. it is /25 address given by the remote peer.

but i see many peers formation from the /25 subnet with different ASnumbers.

is this possible

can any one help on this

4 REPLIES
New Member

Re: BGP

As far as i understand what you are asking is if BGP works with different AS, the answer is YES BGP is meant to provide communication between different AS. The internet nowadays is based on BGP. the current version is 4. It aslo doesnt matter that what IGP is the AS running. BGP performs interdomain routing in Transmission-Control Protocol/Internet Protocol (TCP/IP) networks. BGP is an exterior gateway protocol (EGP), which means that it performs routing between multiple autonomous systems or domains and exchanges routing and reachability information with other BGP systems.

* Please rate this if it helps. *

Regards.

Re: BGP

Dear Rangap,

Yes you can peer with a lot of BGP neighbors via one interface as soon as there is IP reachability between each of them, you can runn EBGP or IBGP with a lot of peers regarless the peers address the only condition you must take care about is there is IP reachability between peers because BGP establish TCP session with each peer (IBGP-EBGP) and based on networking basics the TCP flow (Source & destination) must be reachable, the below URL shown good case study that can help you to under stand a lot of BGP commands.

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a00800c95bb.shtml#bgpconfed

Best Regards,

Mounir Mohamed

New Member

Re: BGP

Hi mounir,

I understood the same.

but the thing when i saw the configuration it is the EBGP configured

router bgp 100

neighbor 190.225.11.1 remote-as 100

neighbor 190.225.11.1 update-source loopback 1

it should be configured in the same way as above using the loopback if it is not directly connected

but it is configured as below

190.225.11.0/25----- is given by the remote bgp

neighbor 190.225.11.3 remote-as 3605

neighbor 190.225.11.3 peer-group lax-32177

neighbor 190.225.11.6 remote-as 4648

neighbor 190.225.11.6 peer-group lax

neighbor 190.225.11.7 remote-as 2152

neighbor 190.225.11.7 peer-group lax

This is the one i cant understand

Re: BGP

Dear Ranqap,

The above example shown that there is one IBGP session and 3 EBGP sessions, the IBGP session using the loopback interface as source when establishing the BGP session (Source of the TCP session), IBGP peers not need to be directly connected as you may run partial mesh IBGP session between edge routers which is not directly connected or between edge routers and Route-Reflector, but with EBGP session there is a rule say that both EBGP peers must be directly connected because its External BGP so sure you will not peering with one provider through another provider the logic is that you peering with EBGP neighbor via one interface or multi interfaces but MUST be direclt connected, BTW the above EBGP configurations you using one ip of /25 in the same interface that EBGP session running and all neighbors is directly connected so you doesn't using update-source loopback # but in the same time you still can using loopbacks in peering with each other, generally loopback interface is useful in many other scenarios such as load-balance, load-sharing, RID etc., finally EBGP peers ip address must be directly connected and if you do not need to use the interface address you can use Loopback it?s optional but with one condition that is you using Loopback in EBGP scenario you MUST use ebgp-multihop command.

For example i will use the below configurations with this senario:

RouterA (RR-A)have 2 interfaces F0/0 S0/0 and both interfaces connected to my network to runn IBGP with my edge routers so i will use the loopback interface of RR-1 because i need to peer with all edge routers and if i'm using one interface IP as my BGP router id once the interface went down the bgp session will went down which is not perfect because i'm still have another interface F0/0 is up so using the loopback interface as BGP session ID in this case is perfect.

RR-A

routerbgp 100

neighbor 192.168.99.1 remote-as 100

neighbor 192.168.99.1 update-source loopback 1

NOTE: the loopback ip must be reachable from other peers side

EBGP example:

RR-A

Router bgp 100

neighbor 172.16.100.1 remote-as 6400

neighbor 172.16.100.1 update-source loopback 1

neighbor 172.16.100.1 ebgp-multihop 2 -> 255 default

neighbor 172.16.100.1 version 4

ip route 172.16.100.1 255.255.255.255 serial0

ip route 172.16.100.1 255.255.255.255 f0/0

Best Regards,

Mounir Mohamed

118
Views
0
Helpful
4
Replies
CreatePlease to create content