Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

BGPv6

Greetings,

I have weird problem for me, which could be very simple for somebody else. I'm not new with IPv6, however I am quite new with BGP.

Here is the scenario:

I establish IPv6 bgp neighbor, see all the routes, can ping IPv6 internet all from the routers outside interface. However, I can not ping it from inside interface. I can ping static defined IPv6 routes from inside interface.

On this router I am running IPv4 and IPv6, however BGP is only for IPv6.

My site prefix is:

2001:67C:1328::/48 , BGP neighbour is 2A01:260:1::210.

Here is the IPv6 configuration: I deleted rest of the config regarding IPv4.

---------------------------------------------------------------------------------------------------------

ipv6 unicast-routing

ipv6 cef

interface BRI0

no ip address

encapsulation hdlc

shutdown

!

interface Dot11Radio0

no ip address

shutdown

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

!

interface Dot11Radio1

no ip address

shutdown

speed basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0

station-role root

!

interface FastEthernet0

no ip address

duplex auto

speed auto

!

interface FastEthernet0.26

encapsulation dot1Q 26

!

interface FastEthernet0.27

encapsulation dot1Q 27

ipv6 address 2001:67C:1328:67::2/64

ipv6 enable

!

interface FastEthernet1

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet2

switchport access vlan 2

!

interface FastEthernet3

switchport access vlan 3

!

interface FastEthernet4

!

interface FastEthernet5

!

interface FastEthernet6

switchport access vlan 2

!

interface FastEthernet7

switchport access vlan 3

!

interface FastEthernet8

!

interface FastEthernet9

!

interface Vlan1

no ip address

!

interface Vlan2

!

interface Vlan3

ipv6 address 2A01:260:8039::2/126

ipv6 enable

!

router bgp 199268

bgp router-id 1.1.1.1

no bgp default ipv4-unicast

bgp log-neighbor-changes

neighbor 2A01:260:1::210 remote-as 34779

neighbor 2A01:260:1::210 description Connection to ISP

neighbor 2A01:260:1::210 ebgp-multihop 5

!

address-family ipv4

  no auto-summary

exit-address-family

!

address-family ipv6

  redistribute static

  network 2001:67C:1328::/48

  neighbor 2A01:260:1::210 activate

  neighbor 2A01:260:1::210 default-originate

  neighbor 2A01:260:1::210 prefix-list ISP out

exit-address-family

!

!

!

!

logging esm config

ipv6 route 2001:67C:1328:66::/64 2001:67C:1328:67::1

ipv6 route 2001:67C:1328::/48 Null0

ipv6 route 2A01:260:1::210/128 2A01:260:8039::1

!

!

ipv6 prefix-list ISP seq 5 permit 2001:67C:1328::/48

!

!

!

end


------------------------------------------------------------------------------------------

Any input would be greatly appreciated.

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: BGPv6

It looks good. You are definitely advertising your prefix to your ISP. You need to talk to your ISP to find out why your prefix does not seem to make it to the Internet.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
6 REPLIES

BGPv6

Hi,

just to clarify, the 'outside' interface that gives you access to exernal IPv6 address is the VLAN3 SVI? Which 'inside' interface are you attempting to ping from?

cheers,

Seb.

New Member

Re: BGPv6

Thank you for interest.

Yes, VLAN 3 SVI gives external access. I am attempting to ping from IPv6 address from the router (2001:67C:1328:67::2/64) .

Ping 2001:4860:4860::8888 (google dns) works, Ping 2001:4860:4860::8888 source 2001:67C:1328:67::2 does not work.

Ping to neighbor 2A01:260:1::210 works even from the inside ( I believe because of the static IPv6 route).

Cisco Employee

Re: BGPv6

Hi,

I looked up your prefix (2001:67C:1328::/48) from several looking glass servers on the Internet and could not find it. It does not appear that your prefix is properly propagated. Your configuration looks good, except for the fact that you advertise the default route to your ISP ("neighbor 2A01:260:1::210 default-originate"). The issue might be with your ISP.

Can you post the output for the following command:

show bgp ipv6 unicast neighbor 2A01:260:1::210 advertised-routes

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: BGPv6

HI,

My first configuration was without default originate (did not work as well), this is someting I added just for trying purposes. Have deleted this command now.

This is output:

Zunanji1#show bgp ipv6 unicast neighbor 2A01:260:1::210 advertised-routes

BGP table version is 10587, local router ID is 1.1.1.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale, m multipath, b backup-path, x best-external

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

*> 2001:67C:1328::/48

                    ::                       0         32768 i

Total number of prefixes 1


Cisco Employee

Re: BGPv6

It looks good. You are definitely advertising your prefix to your ISP. You need to talk to your ISP to find out why your prefix does not seem to make it to the Internet.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

BGPv6

Problem solved, ISP fault.

609
Views
0
Helpful
6
Replies