Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

brain dead on ospf

Just trying to bring up a new 3750 stack and route OSPF from our core, but it's been a while and I've mainly been doing BGP and EIGRP.. was hoping someone could help:

I'm seeing the neighbor relationship as full, but am not receiving any routes from the core router.  The core router gets it's OSPF routes from our other core router(s).. I think I should at least get networks defined in area 0??

3750 (CAR1) router IP: 10.14.1.2

CAR1.CF#sho ip ospf neigh

Neighbor ID     Pri   State           Dead Time   Address         Interface
64.38.14.148      1   FULL/DR         00:00:39    10.14.1.1       Port-channel1

core router (BDR1) IP 10.14.1.1

Neighbor ID     Pri   State           Dead Time   Address         Interface

10.14.1.2         0   FULL/  -        00:00:39    10.14.1.2       Port-channel2

64.38.14.146      0   FULL/  -        00:00:38    10.13.1.1       GigabitEthernet2/1

74.200.240.5      0   FULL/  -        00:00:31    74.200.242.53   GigabitEthernet2/2

3750 OSPF CONFIG:

!

router ospf 600

log-adjacency-changes

redistribute connected subnets

passive-interface default

no passive-interface Port-channel1

network 10.13.1.2 0.0.0.0 area 0

network 10.13.1.0 0.0.0.255 area 0

network 10.14.1.0 0.0.0.0 area 0

network 10.14.1.0 0.0.0.3 area 0

network 64.38.14.148 0.0.0.0 area 0

network 74.200.193.4 0.0.0.3 area 0

network 74.200.242.54 0.0.0.0 area 0

Core OSPF CONFIG:

router ospf 600
log-adjacency-changes
nsf enforce global
redistribute connected
redistribute static subnets route-map static-to-ospf
passive-interface default
no passive-interface GigabitEthernet2/1
no passive-interface GigabitEthernet2/2
no passive-interface Port-channel2
network 10.13.1.2 0.0.0.0 area 0
network 10.13.1.0 0.0.0.255 area 0
network 10.14.1.0 0.0.0.0 area 0
network 10.14.1.0 0.0.0.3 area 0
network 64.38.14.148 0.0.0.0 area 0
network 74.200.193.4 0.0.0.3 area 0
network 74.200.242.54 0.0.0.0 area 0

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Bronze

Re: brain dead on ospf

Based on the output, it seems you have mismatched network types.

While you can form adjacency with mismatched network types and identical OSPF timers, you won't be able to exchange LSA information.

It seems your 3750 stack is running the default broadcast mode while the Core is either running point-to-point or point-to-multipoint based on the output .. no DR is listed.

Regards

______

Each time you rate a CSC   discussion   we'll donate $1 to the American Red Cross Haiti fund up to a   maximum   donation of $10,000 USD.

https://supportforums.cisco.com/docs/DOC-8895

4 REPLIES
Hall of Fame Super Bronze

Re: brain dead on ospf

Based on the output, it seems you have mismatched network types.

While you can form adjacency with mismatched network types and identical OSPF timers, you won't be able to exchange LSA information.

It seems your 3750 stack is running the default broadcast mode while the Core is either running point-to-point or point-to-multipoint based on the output .. no DR is listed.

Regards

______

Each time you rate a CSC   discussion   we'll donate $1 to the American Red Cross Haiti fund up to a   maximum   donation of $10,000 USD.

https://supportforums.cisco.com/docs/DOC-8895

Community Member

Re: brain dead on ospf

Awesome!

That was it

Hall of Fame Super Bronze

Re: brain dead on ospf

Glad to be of help.

Please remember to rate helpful posts.

Regards

Edison

Community Member

Re: brain dead on ospf

Thanks.. I rated the post!

221
Views
0
Helpful
4
Replies
CreatePlease to create content