Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Bridging a serial interface and an ethernet interface

http://www.ciscotr.com/forum/attachments/router/1187d1389701406-bridge-yapma-bridgejpg

Hi guys, I have a problem. I am trying to make E0 and S1 interfaces on RouterA bridge. There is a PC in LAN1 and it's Ip:10.0.0.2.

S0 on RouterB's Ip: 10.0.0.1. When i try to ping from the PC to 10.0.0.1, it sends an ARP packet. After the packet left S1 interface it looks like that from top to bottom: ARP/Ethernet/HDLC/Frame.

When the packet reachs S0 interface It does nothing. As if it does not understand ARP and does not response. What is the problem. Thanks.

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: Bridging a serial interface and an ethernet interface

What is the problem that you're trying to solve? Maybe we can come up with a workaround or another solution. You can bridge the ethernet and serial, but you have to go through the serial interface and not terminate on it. That means that you should be bridging on RouterB as well, but I know that may not be an option.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
10 REPLIES

Re: Bridging a serial interface and an ethernet interface

You'll need to configure irb on RouterA:

bridge irb

int e0

no ip address

bridge-group 1

int s1

no ip address

bridge-group 1

int bvi1

ip addres

bridge 1 route ip

bridge 1 protocol ieee

I haven't tested this yet, so there could be some syntax errors.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***

Re: Bridging a serial interface and an ethernet interface

Okay, I tested. How do you have RouterB configured? What is S0's interface? The only way that you should be able to get this to work with both hosts being on the same subnet would be to bridge both routers like I stated above. I could get that to work. Otherwise, let's assume that Lan1's host is 10.0.0.1. In order for it to get to the other side through RouterA, RouterA can bridge, but RouterB's S0 address would need to be in the 10.0.0.0/24 subnet and still route. Then Lan1 host would use RouterB's S0 interface ip as a default gateway, but you still wouldn't be able to have Lan2's host on the same subnet as Lan1's host.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Bridging a serial interface and an ethernet interface

Hi John, there is 10.0.0.1/24 on RouterB's S0. That is the all configuration on it. S0 is a serial interface whis is configured with 9600 clock rate. the PC's Ip:10.0.0.2/24 both PC and S0 on the same subnet. But it doe not work.  Below is wireshark capture when packet arrives RouterB's S0. It just does not response to the ARP packet. Thank you.

Re: Bridging a serial interface and an ethernet interface

Can you post the config of RouterA?

Note: Serial interfaces won't have arp entries associated to them. I'm not sure what you're trying to do will work, but if you can post the config of RouterA and RouterB we can take a look.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Re: Bridging a serial interface and an ethernet interface

RotuterA:

hostname RouterA

!

interface Serial1

no ip address

serial restart-delay 0

bridge-group 1

!

interface FastEthernet0

no ip address

duplex auto

speed auto

bridge-group 1

!

!

interface BVI1

no ip address

!

!

bridge irb

bridge 1 protocol ieee

bridge 1 route ip

RouterB:

!

hostname RouterB

!

interface Serial0

ip address 10.0.0.1 255.255.255.0

clock rate 9600

!

That is all.

Re: Bridging a serial interface and an ethernet interface

I don't believe you're going to be able to get this to work. I've labbed it up and it simply doesn't work to the wan interface because serial interfaces don't work like lan interfaces do. They don't use arp. I took the same config that you have and it doesn't work, but if I link an FE interface between R2 and R3, it works fine with the ip address being on R3's lan interface. Change the link between RouterA and RouterB to an ethernet link and you'll see what I mean...

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Re: Bridging a serial interface and an ethernet interface

Thank you John, I know you are right, but I need to bridge an ethernet and a serial interface.

Re: Bridging a serial interface and an ethernet interface

What is the problem that you're trying to solve? Maybe we can come up with a workaround or another solution. You can bridge the ethernet and serial, but you have to go through the serial interface and not terminate on it. That means that you should be bridging on RouterB as well, but I know that may not be an option.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Re: Bridging a serial interface and an ethernet interface

Actually I want to make a scenario like below, bridging two diffrent interface. Anyway thank you for your kind help.

no ip routing

no ip cef

controller DSL 0/0

mode atm

line-term cpe

line-mode 2-wire line-zero

dsl-mode shdsl symmetric annex B

line-rate auto

interface ATM0/0

no ip address

no ip route-cache

no atm ilmi-keepalive

bridge-group 1

pvc 8/35 

encapsulation aal5snap

interface FastEthernet0/0

ip address 10.10.10.11 255.255.255.0

no ip route-cache

speed 100

bridge-group 1

access-list 1 permit 10.10.10.0 0.0.0.255

bridge 1 protocol ieee

Re: Bridging a serial interface and an ethernet interface

No problem. From your config above, I'm still not sure what you're trying to accomplish though. Here's a document on the irb feature. There could be restrictions on what interfaces can be bridged, but I have no way of testing atm interfaces unfortunately:

http://www.cisco.com/en/US/tech/tk389/tk815/technologies_tech_note09186a0080094663.shtml

http://www.cisco.com/en/US/docs/optical/15000r4_0/ethernet/454/guide/irb.html

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
706
Views
0
Helpful
10
Replies
CreatePlease to create content