Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Bridging between Ethernet and Multilink interface problem

Hi,

I'm trying to do transparent bridging with the following setup but im unable to pass traffic from R1 to the PE router. My goal is to use R2 as a L2 bridge to get connectivity between R1 and PE1. R1 doesn't have the necessary module hence this setup and i dont manage the PE side..

Just testing this to avoid paying on having extra hardware:)

    R1 F0/0     <>   F0/0 R2 Multilink1 (s1/0,s1/1)   <>    Multilink1 (s1/0, s1/1) PE1 

   1.1.1.1/30                                                                     1.1.1.2/30

First issue that I see is the IP address on the Multilink on the PE side. I have the multilink interface UP between R2 and PE, 1.1.1.0/30 is not being installed as a connected interface on the routing table. Not sure how can go around this. Below is the config for reference.  

Is this setup even possible? Or i'm missing something? Any help will be much appreciated. Thanks in advanced!

R1:

interface FastEthernet0/0

ip add 1.1.1.1 255.255.255.252

R2:

bridge irb

bridge 1 protocol ieee

interface FastEthernet0/0

bridge-group 1

interface Multilink1

no ip address

ppp multilink

ppp multilink group 1

bridge-group 1

interface Serial1/0

no ip address

encapsulation ppp

serial restart-delay 0

ppp multilink

ppp multilink group 1

interface Serial1/1

no ip address

encapsulation ppp

serial restart-delay 0

ppp multilink

ppp multilink group 1

PE1:

interface Multilink1

ip address 1.1.1.2 255.255.255.252

ppp multilink

ppp multilink group 1

interface Serial1/0

no ip address

encapsulation ppp

serial restart-delay 0

ppp multilink

ppp multilink group 1

interface Serial1/1

no ip address

encapsulation ppp

serial restart-delay 0

ppp multilink

ppp multilink group 1

6 REPLIES
Hall of Fame Super Gold

Bridging between Ethernet and Multilink interface problem

There are parts of your post that are not clear to me. In particular in which routing table are you expecting to see the /30 network? Are you looking on R1 (where I would expect it to be) or on R2 (where the expected behavior is that the subnet will not be in the routing table since R2 is bridging that subnet and not routing it).

If I were doing this I probably would not use irb on R2. irb gives you the ability to interface the bridged domain to the routed domain. But based on what you have shown us there is not a routed domain on R2. I would suggest that you configure no ip routing on R2, remove the bridge irb command, and use the rest of the config as you have it.

HTH

Rick

Community Member

Bridging between Ethernet and Multilink interface problem

Thanks for the inputs Rick! Sorry if I was not clear enough on my post. I'm doing this on the lab in preparation so I can expect what the behavior of the PE router will be during the cutover. The /30 network which im not seeing being installed is on the routing table of my PE1 router. I was expecting that since the Multilink is UP on the PE1 router, the /30 will be installed as a connected Interface on PE1 routing table but that wasn't the case. The Multilink interface on PE1 is still waiting reply from the Multilink interface on R2 to agree on the IP address. Since the IP address is configured on R1's Ethernet interface and  R2 is only in bridge mode, R2 is not sending any acknowledgement back to PE1. Is there any workaround on this behaviour? Thanks again!

- Liam

PE1


PE1(config)#int mul1

PE1(config-if)#ip address 1.1.1.2 255.255.255.252

PE1(config-if)#

*Mar  1 05:20:47.566: Mu1 IPCP: O CONFREQ [Listen] id 7 len 10

*Mar  1 05:20:47.566: Mu1 IPCP:    Address 1.1.1.2 (0x030601010102)

*Mar  1 05:20:47.570: Se1/1 MLP: O frag C0000040 size 20 encsize 4

*Mar  1 05:20:47.570: Se1/1 MLP: O data FF03 003D C000 0040 8021 0107 000A 0306

*Mar  1 05:20:47.574: Se1/1 MLP: I ppp LCP (C021) size 20 encsize 4

*Mar  1 05:20:47.578: Se1/1 MLP: I data FF03 C021 0807 0010 8021 0107 000A 0306

*Mar  1 05:20:47.578: RT: is_up: Multilink1 0 state: 4 sub state: 1 line: 0 has_route: True

*Mar  1 05:20:47.582: RT: is_up: Multilink1 0 state: 4 sub state: 1 line: 0 has_route: True

*Mar  1 05:20:47.586: Mu1 LCP: I PROTREJ [Open] id 7 len 16 protocol IPCP (0x80210107000A030601010102)

*Mar  1 05:20:47.586: Mu1 IPCP: State is Closed

*Mar  1 05:20:47.590: Mu1 IPCP: State is Listen

PE1# ping 1.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:

*Mar  1 05:41:09.746: IP: s=1.1.1.2 (local), d=1.1.1.1, len 100, unroutable.

R2 (bridge)

*Mar  1 05:27:20.614: Mu1 PPP: Outbound ieee-st packet dropped

*Mar  1 05:27:21.046: Mu1 IPCP: I CONFREQ [Not negotiated] id 8 len 10

*Mar  1 05:27:21.046: Mu1 IPCP:    Address 1.1.1.2 (0x030601010102)

*Mar  1 05:27:21.046: Mu1 LCP: O PROTREJ [Open] id 8 len 16 protocol IPCP (0x80210108000A030601010102)

R1

R1# ping 1.1.1.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 1.1.1.2, timeout is 2 seconds:

*Mar  1 05:13:11.986: IP: tableid=0, s=1.1.1.1 (local), d=1.1.1.2 (FastEthernet0/0), routed via RIB

*Mar  1 05:13:11.986: IP: s=1.1.1.1 (local), d=1.1.1.2 (FastEthernet0/0), len 100, sending

*Mar  1 05:13:11.990: IP: s=1.1.1.1 (local), d=1.1.1.2 (FastEthernet0/0), len 100, encapsulation failed.


Hall of Fame Super Gold

Bridging between Ethernet and Multilink interface problem

Liam

Your response provides information that is quite helpful. I have done configurations that did bridging between Ethernet and serial interfaces which worked. But I do not believe that I have ever done one that involved a multilink interface. And based on your information the multilink in the bridge group may create a problem. I believe that the issue is that your PE1 router is depending on IPCP to negotiate/confirm the IP address on the interface. But since the multilink on R2 has no IP address it can not complete the IPCP negotiation.

HTH

Rick

Community Member

Bridging between Ethernet and Multilink interface problem

Yeah the IPCP negotiation between R2 and PE1 is problem. Works fine if R2 multilink has an IP but defeats the purpose of it being a L2 device only. Thanks Rick.

Cisco Employee

Re: Bridging between Ethernet and Multilink interface problem

On PE1 configure the multilink for bridging same as R2, then configure IRB with a BVI interface and put the address on the BVI.

Here is a sample relevant configuration. I tried it out on three random routers and the three addresses can ping each other.

The BVI on r200 is superfluous for you but it's handy for checking reachability.

r202#

!

interface Ethernet0/0

ip address 10.0.0.202 255.255.255.0

end

r200#

!

bridge irb

!

interface Ethernet0/0

no ip address

bridge-group 1

!

interface BVI1

ip address 10.0.0.200 255.255.255.0

!

interface Multilink1

no ip address

ppp multilink

ppp multilink group 1

bridge-group 1

!

interface Serial2/0

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1

!

interface Serial3/0

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1

!

bridge 1 protocol ieee

bridge 1 route ip

r200#

r201#

!

bridge irb

!

interface BVI1

ip address 10.0.0.201 255.255.255.0

!

interface Multilink1

no ip address

ppp multilink

ppp multilink group 1

bridge-group 1

!

interface Serial2/0

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1

!

interface Serial3/0

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1

!

bridge 1 protocol ieee

bridge 1 route ip

!

r201#

Community Member

Bridging between Ethernet and Multilink interface problem

Hi Margalla,

Thanks for the inputs apparently I don't manage the PE router which I stated before and i don't think my SP will configure bridging on their PEs.

501
Views
0
Helpful
6
Replies
CreatePlease to create content