Cisco Support Community
Community Member

BT Broadband PPoA Issue


We have a cisco 1841 with a wic-1adsl card installed.

We are connecting this to BT Broadband in belfast and was told it was PPoA we got the username,passwords and also told that the static ip address has a mask of

When connecting the dsl port to the adsl wic we get a physical port in the atm module as initialising then down and under the debugs we get the following.

*Sep 11 13:21:03.831: DSL: Received response: 0x22

*Sep 11 13:21:03.831: DSL: Open failed: Handshake or init message invalid or had bad CRC -- retrying

We have the following config.

interface FastEthernet0/0

ip address zzzzzzz

ip nat inside

ip virtual-reassembly

duplex auto

speed auto


interface ATM0/1/0

no ip address

no ip mroute-cache

no atm ilmi-keepalive

dsl operating-mode auto

dsl enable-training-log

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1


interface Dialer1

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname

ppp chap password 0 yyyyyy

ppp pap sent-username password 0 yyyyy

ppp ipcp dns request

ppp ipcp wins request


ip classless

ip route Dialer1

ip route 200.x.x.0



no ip http server

no ip http secure-server

ip nat inside source list 1 interface Dialer1 overload


access-list 1 permit any

dialer-list 1 protocol ip permit



Community Member

Re: BT Broadband PPoA Issue


Can u plz send me the result of <>



Community Member

Re: BT Broadband PPoA Issue


Thanks for the mail.

See below.

Portadown#show ip int brief

Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 YES NVRAM up up

FastEthernet0/1 unassigned YES NVRAM administratively down down

ATM0/1/0 unassigned YES NVRAM initializing down

NVI0 unassigned YES unset up up

Virtual-Access1 unassigned YES unset up up

Dialer1 unassigned YES NVRAM up up

ATM0/1/0 is down, line protocol is down

Hardware is DSLSAR (with Alcatel ADSL Module)

MTU 4470 bytes, sub MTU 4470, BW 800 Kbit, DLY 640 usec,

reliability 0/255, txload 1/255, rxload 1/255

Encapsulation ATM, loopback not set

Encapsulation(s): AAL5 AAL2, PVC mode

23 maximum active VCs, 256 VCs per VP, 0 current VCCs

VC Auto Creation Disabled.

VC idle disconnect time: 300 seconds

Last input never, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: Per VC Queueing

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

0 packets output, 0 bytes, 0 underruns

0 output errors, 0 collisions, 4 interface resets

0 output buffer failures, 0 output buffers swapped out

Also, If you plug a netopia router into this it works.

Community Member

Re: BT Broadband PPoA Issue

What IOS version are you using?

I am fairly sure I have seen this before and it needed the very latest IOS to work.

Don't ask what the very latest version at that time was :-)

CreatePlease to create content