Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

c1721 with a WIC 1ADSL - PPPoE Trouble Configuration

I am having trouble to configure a c1721 with a WIC 1ADSL card.

Actually, I have a Cisco c827 working fine, but when I put the same configuration on the c1721, I am getting the message "01:40:23: Di1 DDR: Cannot place call, no dialer string set"

If I place the dialer string on the dialer interface, I get the message - "01:45:36: Di1: No free dialer - starting fast idle timer" either way I am getting

"01:46:06: Di1 DDR: cdp, 360 bytes, outgoing uninteresting (no list matched)" What sould I do? Thanks in advance.

This line only on the c1721.

dialer-list 1 protocol ip permit

Here is the configuration file:

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Maxirede-via-GVT

!

username jonas privilege 15 password 7 ******

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

no ip domain-lookup

ip dhcp excluded-address 192.168.200.1 192.168.200.2

!

ip dhcp pool Maxirede

network 192.168.200.0 255.255.255.252

domain-name Maxirede

default-router 192.168.200.1

dns-server 200.175.5.139 200.175.89.139

lease 0 0 1

!

ip cef

ip ssh time-out 120

ip ssh authentication-retries 3

vpdn enable

!

vpdn-group pppoe

request-dialin

protocol pppoe

!

crypto mib ipsec flowmib history tunnel size 200

crypto mib ipsec flowmib history failure size 200

!

interface Ethernet0

ip address 192.168.200.1 255.255.255.252

ip nat inside

ip tcp adjust-mss 1400

hold-queue 100 out

!

interface ATM0

no ip address

no atm ilmi-keepalive

pvc 0/35

pppoe-client dial-pool-number 1

!

bundle enable

!

dsl operating-mode auto

hold-queue 224 in

!

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication pap callin

ppp chap hostname *****@turbonetpro

ppp chap password 7 ********

ppp pap sent-username ******@turbonetpro password 7 *****

ppp ipcp dns request

ppp ipcp username unique

!

ip nat inside source list 1 interface Dialer1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

no ip http server

!

access-list 1 permit 192.168.200.0 0.0.0.255

!

line con 0

login local

stopbits 1

line vty 0 4

access-class 1 in

exec-timeout 0 0

login local

!

scheduler max-task-time 5000

4 REPLIES
Hall of Fame Super Silver

Re: c1721 with a WIC 1ADSL - PPPoE Trouble Configuration

Hello Jonas,

this looks like a possible problem with IOS version on the C1721: a dialer string is needed for a dialer interface used for ISDN DDR.

However, I would move the configuration under an ATM point-to-point subinterface if supported:

int atm0

no ip address

no atm ilmi-keepalive

int atm0.1 point-to-point

pvc 0/35

pppoe-client dial-pool-number 1

!

if you do the following:

terminal monitor

debug ppp negotiation

debug ppp auth

then

conf t

int atm0

shut

! wait 60 seconds

int atm0

no sh

you can attach the output in a text file

As I've noted at the beginning this may be an IOS version issue.

Hope to help

Giuseppe

New Member

Re: c1721 with a WIC 1ADSL - PPPoE Trouble Configuration

Hi Giuseppe

Thanks for your help!

Well I have changed as you asked for but it's still the same.

Thanks again,

Jonas

-------------------------->

Maxirede-via-GVT#sh deb

PPP:

PPP authentication debugging is on

PPP protocol negotiation debugging is on

shut

00:08:22: %LINK-5-CHANGED: Interface ATM0, changed state to administratively down

00:08:23: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0, changed state to down

no shut

00:10:51: %LINK-3-UPDOWN: Interface ATM0, changed state to down

00:11:24: %LINK-3-UPDOWN: Interface ATM0, changed state to up

00:11:25: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0, changed state to up

---->

Maxirede-via-GVT#sh ver

Cisco Internetwork Operating System Software

IOS (tm) C1700 Software (C1700-ADVENTERPRISEK9-M), Version 12.3(26), RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2008 by cisco Systems, Inc.

Compiled Mon 17-Mar-08 14:24 by dchih

ROM: System Bootstrap, Version 12.2(7r)XM1, RELEASE SOFTWARE (fc1)

Maxirede-via-GVT uptime is 19 minutes

System returned to ROM by power-on

System image file is "flash:c1700-adventerprisek9-mz.123-26.bin"

cisco 1721 (MPC860P) processor (revision 0x200) with 61759K/3777K bytes of memory.

Processor board ID FOC07380ZCA (1056193944), with hardware revision 0000

MPC860P processor: part number 5, mask 2

Bridging software.

X.25 software, Version 3.0.0.

1 FastEthernet/IEEE 802.3 interface(s)

1 ATM network interface(s)

32K bytes of non-volatile configuration memory.

32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

Maxirede-via-GVT#

---->

The Configuration file:

Building configuration...

Current configuration : 1831 bytes

!

version 12.3

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Maxirede-via-GVT

!

boot-start-marker

boot-end-marker

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

no aaa new-model

ip subnet-zero

ip cef

!

ip dhcp excluded-address 192.168.200.1 192.168.200.2

!

ip dhcp pool Maxirede

network 192.168.200.0 255.255.255.252

domain-name Maxirede

default-router 192.168.200.1

dns-server 200.175.5.139 200.175.89.139

lease 0 0 1

!

no ip domain lookup

ip audit po max-events 100

vpdn enable

!

vpdn-group pppoe

request-dialin

protocol pppoe

!

username jonas privilege 15 password 7 ****

!

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

pvc 0/35

pppoe-client dial-pool-number 1

!

interface FastEthernet0

ip address 192.168.200.1 255.255.255.252

ip nat inside

ip tcp adjust-mss 1400

speed auto

hold-queue 100 out

!

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

encapsulation ppp

dialer pool 1

dialer string 0,35

dialer-group 1

ppp authentication pap callin

ppp chap hostname ***@turbonetpro

ppp chap password 7 ***

ppp pap sent-username ***@turbonetpro password 7 *****

ppp ipcp dns request

ppp ipcp username unique

!

ip nat inside source list 1 interface Dialer1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

no ip http server

no ip http secure-server

!

access-list 1 permit 192.168.200.0 0.0.0.255

dialer-list 1 protocol ip permit

!

line con 0

login local

stopbits 1

line aux 0

line vty 0 4

access-class 1 in

exec-timeout 0 0

login local

!

scheduler max-task-time 5000

New Member

Re: c1721 with a WIC 1ADSL - PPPoE Trouble Configuration

Hi Guys,

I just downloaded the c1700-sy7-mz.124-25.bin and it is working.

Jonas

Hall of Fame Super Silver

Re: c1721 with a WIC 1ADSL - PPPoE Trouble Configuration

Hello Jonas,

nice to hear you have solved: so it was an IOS version issue as suspected.

Hope to help

Giuseppe

589
Views
5
Helpful
4
Replies