cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1223
Views
5
Helpful
3
Replies

C4507r rate-limit question

hcintron
Level 1
Level 1

Hi Everyone.

  is it possible to do an equivalent to a rate-limit (CAR) on a C4507r?  What im looking to do is be able to have various rate-limits on a various vlan for both upload and download.  I've used the rate-limit (CAR) on a router but on the C4507r it looks like (CAR) is not allowed.

Thank You

3 Replies 3

Michael Johnson
Level 1
Level 1

I assume you mean applying rate limiting capabilities on layer 3 SVI's?

You can use the rate-limit command in interface config mode as well as the modular qos cli (MQC);

class-map

.......

policy-map vlanX

....

....

interface vlanX

service-policy .....

mike

Hi Mike.

  Thanks for the reply.  If I enter a interface vlanxxx I cannot add the rate-limit command:

spare_equipment(config)#int vlan800
spare_equipment(config-if)#r?
% Unrecognized command

I did read the "Applying QoS Features Using the MQC"  If I understand it correctly, if I have 2 policies

"test one" will have a download of 6m and upload of 4m

"test two" will have a download of 2m and upload of 1m

I would do the following:

! ********************* test one

class-map match-all test
  description test rate-limit
match any
!
!
policy-map vlan800in
class test
    police 6000000 bps 8000 byte conform-action transmit exceed-action drop

policy-map vlan800out
class test
    police 4000000 bps 8000 byte conform-action transmit exceed-action drop

! ******************** test 2

class-map match-all test2
  description test2 rate-limit
match any
!
!
policy-map vlan900in
class test2
    police 2000000 bps 8000 byte conform-action transmit exceed-action drop

policy-map vlan900out
class test2
    police 1000000 bps 8000 byte conform-action transmit exceed-action drop

! ************** applied

interface Vlan800
ip address 10.94.0.2 255.255.255.0
service-policy input vlan800in
service-policy output vlan800out

interface Vlan900
ip address 10.95.0.2 255.255.255.0
service-policy input vlan900in
service-policy output vlan900out

is this correct?

Hi Hector,

If you are planning to apply the service-policy under the SVI, you must configure the physical interfaces with the qos vlan-based command.

Additionally, you can avoid configuring the class-map and instead use the policy-map with the class class-default.

Another note, the accuracy of the policer configured is +/- 1.5 % so you will experience traffic over the policed limit.

For more information, I highly suggest you read the documentation on implementing QoS on 4500 for any other caveats you may face

depending upon the hardware that is used.

http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/12.2/52sg/configuration/guide/qos.html#wp1461453

Regards

Edison.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: