Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

CABLE MODEM / 2600

What type of hardware do I need to setup a 2620 or 2610 Cisco Router to interface a cable modem? I want to setup a home lab.

9 REPLIES
Hall of Fame Super Gold

Re: CABLE MODEM / 2600

These routers have a single fasthernet, so you need either an nm-1e, or a lan switch that supports vlans and use trunk/subinterfaces in the router.

Hope this helps, please help if it does!

New Member

Re: CABLE MODEM / 2600

My router already has a serial card in it as well as a built-in FastEthernet port. My 2950 switch does support vlan using dot1q. How would I connect my cable modem to my router using the serial WIC1 card?

Hall of Fame Super Gold

Re: CABLE MODEM / 2600

You can't. You can do:

interface fa0

ip address dhcp

ip nat outside

interface fa0.20

ip address 10.0.0.1 255.255.255.0

ip nat inside

encapsulation dot1q 20

ip access-list 1 permit 10.0.0.0 0.0.0.255

ip nat inside source list 1 interface fa0 overload

Note on router you need an ip plkus image new engough to support dhcp, on the switch set mode trunk to port going to router, access vlan 20 to ports going to PCs.

Cheers to Tina.

Hope this helps, please rate post if it does!

New Member

Re: CABLE MODEM / 2600

Ok, it seems like I need 2 ethernet ports and since the router only comes with one I need to purchase another one. Having the cable modem and the switch communicate through the same ethernet port is impossible. I do understand vlans and trunking. Also is the router capable of accepting dynamic IP ADDRESS from my cable modem. If so how is done or will the above directions on that festure on for the fa0 port. Please reply if what I am saying is right.

Hall of Fame Super Gold

Re: CABLE MODEM / 2600

All right. Not sure if your ios does dhcp, if does not, you need to upgrade IOS. Also I think vlans needs a plus image or router.

New Member

Re: CABLE MODEM / 2600

Got that part but, how do I get the fa0 port that my cable will be plugged into the recieve setting form my ISO's DHCP server. I mean what are the commands to tell the router it to recieve it automatically? I ahve never done this before.

Hall of Fame Super Gold

Re: CABLE MODEM / 2600

As mentioned before, "ip address dhcp".

That's it.

Hope this helps, please rate post if it does

New Member

Re: CABLE MODEM / 2600

That's Great. Thanks for helping me out so much.

Hall of Fame Super Gold

Re: CABLE MODEM / 2600

You're welcome.

As a recognition to those providing answers, please rate useful posts with the scrollbox below!

357
Views
0
Helpful
9
Replies
CreatePlease to create content