Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Can a 3640 handle a DS-3?

Any reason a 3640 with an NM-A1-T3 couldn't handle a ds-3 circuit? We have a 10mb pvc on it which I believe can burst upto the full ds-3 speed. We seem to be losing UDP packets at the application level at a rate of about 5-10 per minute under steady load.

Here is the output from show interface:

Cisco#show interface atm 1/0

ATM1/0 is up, line protocol is up

Hardware is RS8234 ATM DS3

MTU 4470 bytes, sub MTU 4470, BW 45000 Kbit, DLY 190 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ATM, loopback not set

Encapsulation(s): AAL5

1023 maximum active VCs, 1 current VCCs

VC Auto Creation Disabled.

VC idle disconnect time: 300 seconds

Last input 00:00:00, output 00:00:01, output hang never

Last clearing of "show interface" counters 03:25:56

Input queue: 0/200/40/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: Per VC Queueing

5 minute input rate 27000 bits/sec, 20 packets/sec

5 minute output rate 2000 bits/sec, 2 packets/sec

856451 packets input, 156468990 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

139135 packets output, 8915907 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

The drops (40) from the input queue don't seem to coorespond to the udp packets that application is not receiving. I think the drops are in the network or on this router as I have the same data and application working on another circuit (ima atm with 3 T1s) working with only a few dropped packets a day and I can trace this to data bursts that exceed the 4.5mb bandwidth.

I'm trying to figure out if the loss in in the atm cloud or at my router. Any thoughts on how to proceed would be appriciated. -- Bud

5 REPLIES
Silver

Re: Can a 3640 handle a DS-3?

3640's are old, slow routers. While it can accommodate a DS3 card, dont expect it to be able to even get close to filling it up. While I dont have hard numbers on how much it can push, i'd estimate you'll max out at about 8-10Mbps.

In order to push a full DS3, you'll need a 3825 if you aren't running any features (qos), and a 3845 if you are.

Make sure you have 'ip cef' enabled globally, and there isn't any 'no ip route-cache' on any of your interfaces in order to get the most performance out of your router.

New Member

Re: Can a 3640 handle a DS-3?

Thanks wochanda for some feedback. I have confirmed that others are using the same hardware for this application and aren't seeing dropped packets so I am now more confident that it is a configuration issue or bad piece of hardware. We basically have a fast ethernet interface and a DS3/ATM module:

Cisco#show hardware

Cisco Internetwork Operating System Software

IOS (tm) 3600 Software (C3640-JS-M), Version 12.3(17a), RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2005 by cisco Systems, Inc.

Compiled Mon 12-Dec-05 16:29 by evmiller

Image text-base: 0x60008B00, data-base: 0x61F08000

ROM: System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

ROM: 3600 Software (C3640-JS-M), Version 12.3(17a), RELEASE SOFTWARE (fc2)

Cisco uptime is 17 hours, 15 minutes

System returned to ROM by power-on

System image file is "flash:c3640-js-mz.123-17a.bin"

cisco 3640 (R4700) processor (revision 0x00) with 124928K/6144K bytes of memory.

Processor board ID 26878521

R4700 CPU at 100MHz, Implementation 33, Rev 1.0

Bridging software.

X.25 software, Version 3.0.0.

SuperLAT software (copyright 1990 by Meridian Technology Corp).

TN3270 Emulation software.

1 FastEthernet/IEEE 802.3 interface(s)

1 ATM network interface(s)

DRAM configuration is 64 bits wide with parity disabled.

125K bytes of non-volatile configuration memory.

32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

New Member

Re: Can a 3640 handle a DS-3?

Cisco#show control atm 1/0

Interface ATM1/0 is up

Hardware is RS8234 ATM DS3

LANE client MAC address is 0008.2156.0b50

hwidb=0x634920D8, ds=0x634938A4

RS8234 base 3C800000, ds 634938A4, PM5346 base 3CC00000, slave base 3CC00000

SBDs - avail 2048, guaranteed 1, unguaranteed 2047, starved 0 rbds 4098

Seg VCC SCH access timeout 0

[snip]

PCI bus err 0, DMA fifo full err 0, RSM parity err 0

RSM sync err 0, RSM/SEG Q full err 0, RSM overflow err 0

RSM stat Q full err 0, no free buff Q err 0, RSM ignore rbd CPI count 0

RSM ignore rbd CPI&PAD count 0, RSM ignore rbd abort count 0

RSM ignore rbd unknown count 0, pdu_check flag 0x0, error flag 0x0

SEG stat Q full err 0, SEG underflow err 0

Framer Chip Type PM7345

Framer Chip ID 0x20

Framer State RUNNING

Defect Status NO ERRORS

Loopback Mode NONE

Clock Source INTERNAL (but the source of this clock is derived from LINE)

DS3 Scrambling ON

Framing DS3 C-bit direct mapping

TX cells 1392577

TX bytes 73806581

Last output time 17:10:48

RX cells 9659689

RX bytes 511963517

Last input time 17:10:48

Line Code Violations (LCV) 198

DS3: F/M-bit errors 0

DS3: parity errors 30

DS3: path parity errors 30

DS3/E3: G.832 FEBE errors 10

T3/E3: excessive zeros 121

uncorrectable HEC errors 13

idle/unassigned cells dropped 0

LCV errored secs 6

DS3: F/M-bit errored secs 0

DS3: parity errored secs 6

DS3: path parity errored secs 6

T3/E3: excessive zeros errored secs 6

DS3/E3: G.832 FEBE errored secs 1

uncorrectable HEC errored secs 4

LCV error-free secs 61825

DS3: F/M-bit error-free secs 61831

DS3: parity error-free secs 61825

DS3: path parity error-free secs 61825

T3/E3: excessive zeros error-free secs 61825

DS3/E3: G.832 FEBE error-free secs 61830

uncorrectable HEC error-free secs 61827

PM 7345 registers (base 0x3CC00000):

[snip]

The errors that show up here don't seem to correspond to the drops I am seeing. In other words, these counts don't change when I am seeing dropped packets.

New Member

Re: Can a 3640 handle a DS-3?

Here is my running config:

Cisco#show run

Building configuration...

Current configuration : 1848 bytes

!

version 12.3

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Cisco

!

boot-start-marker

boot-end-marker

!

logging buffered 20000 debugging

enable secret xxxxxx

!

no aaa new-model

ip subnet-zero

ip tcp synwait-time 5

!

!

no ip domain lookup

!

no ip bootp server

ip multicast-routing

ip cef

!

buffers small permanent 200

buffers small max-free 300

buffers middle permanent 300

buffers middle max-free 500

!

interface Loopback0

no ip address

shutdown

!

interface FastEthernet0/0

description HPH LAN segment

ip address 172.21.x.x 255.255.255.224

no ip redirects

no ip unreachables

no ip proxy-arp

ip pim neighbor-filter PIMFilter

ip pim sparse-mode

no ip mroute-cache

speed 100

full-duplex

no cdp enable

!

interface ATM1/0

no ip address

atm scrambling cell-payload

no atm ilmi-keepalive

hold-queue 200 in

!

interface ATM1/0.1 point-to-point

description PVC

ip address 172.20.x.x 255.255.255.252

ip pim sparse-mode

pvc 1/40

oam-pvc manage 30

oam ais-rdi 30 3

encapsulation aal5snap

!

!

no ip http server

ip classless

ip route 65.x.x.0 255.255.255.0 172.20.x.x

ip route 204.x.x.0 255.255.255.0 172.20.x.x

!

ip pim bidir-enable

ip pim rp-address 65.x.x.x THE_WAN

ip pim spt-threshold infinity

!

ip access-list standard PIMFilter

deny any

ip access-list standard THE_WAN

permit 233.x.x.0 0.0.0.63

deny any

no logging trap

no cdp run

!

line con 0

exec-timeout 0 0

login

line aux 0

login

transport input all

line vty 0

exec-timeout 120 0

password xxxxx

logging synchronous

login

length 0

line vty 1 4

exec-timeout 120 0

password xxxxx

logging synchronous

login

!

!

end

New Member

Re: Can a 3640 handle a DS-3?

Two more notes. 98% of the traffic is multicast data coming into the DS3 interface. "show proc cpu hist" shows peek of 20% while packets are being dropped.

113
Views
0
Helpful
5
Replies
CreatePlease login to create content