Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Can not ping OSPF multicast IP address

I’m adding router CB to OSPF. I tried to add the router using a different area than 0 but  the status keeps saying INIT/DROTHER. Router IG shows the  information from the routers that are already part of OSPF but no information  from CB. Since IG and the other routers are working fine with area 0 I  decided to try adding ROUTER CB to area 0 but I got the same INIT state  problem. I started to troubleshoot the configuration and everything is fine  with the output from:


sh ip ospf int
debug ip ospf events
debug ip  ospf adj – (this one didn’t shows any data)

The MTU is also fine on both  routers and no ACLs or authentication is in use on any of the  routers.

Then I check doing a ping to the multicast address 224.0.0.5 in  IG and the ones that were already working and got a reply to each of the interfaces  IP address with OSPF. When I did the same thing at CB I got just one  single period.

CB# ping 224.0.0.5

Type escape sequence to  abort.
Sending 1, 100-byte ICMP Echos to 224.0.0.5, timeout is 2  seconds:
.
CB#

So the ping to the OSPF multicast is not working with CB. Please advice what to do in this case.


ROUTER IG is a 3825 with advanced security 12.4(7c)

ROUTER CB is same router/IOS

The routers are connected with a ethernet link from service provider. They use MPLS but that's transparent for us.

Here is the  routers config:

=============================ROUTER IG=============================

version 12.4
!
service nagle
no service  pad
service tcp-keepalives-in
service tcp-keepalives-out
!
hostname  IG
!
no aaa new-model
!
resource policy
!
no ip  source-route
ip cef
ip tcp synwait-time 10
!
interface  Loopback1
ip address 10.200.200.1 255.255.255.0
!
interface  GigabitEthernet0/0
description LAN Interface
bandwidth 1048576
ip  address 192.168.10.1 255.255.255.0
no ip redirects
no ip  unreachables
no ip proxy-arp
ip nbar protocol-discovery
ip flow  ingress
ip flow egress
ip virtual-reassembly
ip route-cache  flow
duplex auto
speed auto
media-type rj45
negotiation  auto
no mop enabled
!
interface GigabitEthernet0/1
description to  CCTV1
ip address 172.10.1.1 255.255.255.252
no ip redirects
no ip  unreachables
no ip proxy-arp
ip nbar protocol-discovery
ip flow  ingress
ip flow egress
ip pim dense-mode
ip  virtual-reassembly
ip route-cache flow
ip ospf cost 10
ip ospf  hello-interval 1
ip ospf dead-interval 2
ip ospf retransmit-interval  3
ip ospf transmit-delay 3
duplex auto
speed auto
media-type  rj45
negotiation auto
no mop enabled
!
interface  GigabitEthernet0/1/0
description Service Provider Fiber Link
no ip  address
negotiation auto
!
interface  GigabitEthernet0/1/0.10
description to CCTV2
encapsulation dot1Q  10
ip address 172.10.2.1 255.255.255.252
ip nbar  protocol-discovery
ip flow ingress
ip flow egress
ip ospf  hello-interval 1
ip ospf dead-interval 2
ip ospf retransmit-interval  3
ip ospf transmit-delay 3
no snmp trap link-status
no cdp  enable
!
interface GigabitEthernet0/1/0.32
description to  CB
encapsulation dot1Q 32
ip address 10.10.1.1 255.255.255.252
no  snmp trap link-status
no cdp enable
!
router ospf  1
log-adjacency-changes
network 10.10.1.0 0.0.0.3 area 0
network  172.10.1.0 0.0.0.3 area 0
network 172.10.2.0 0.0.0.3 area 0
network  192.168.10.0 0.0.0.255 area 0
!
ip route 0.0.0.0 0.0.0.0  XXX.XXX.XXX.XXX

===================================== R O U T E R CB ======================

version 12.4
!
hostname CB
!
logging  buffered 51200 warnings
!
no aaa new-model
!
resource  policy
!
ip cef
!
no ip dhcp use vrf connected
!
ip  multicast-routing
!
interface Loopback1
ip address 10.200.204.1  255.255.255.224
!
interface GigabitEthernet0/0
description LAN  Interface
ip address 192.168.1.1 255.255.255.0
no ip redirects
no ip  unreachables
no ip proxy-arp
ip virtual-reassembly
duplex  auto
speed auto
media-type rj45
negotiation auto
no mop  enabled
!
interface GigabitEthernet0/0/0
ip address 10.10.1.2  255.255.255.252
no ip redirects
no ip unreachables
no ip  proxy-arp
ip virtual-reassembly
negotiation auto
!
router ospf  1
log-adjacency-changes
network 10.10.1.0 0.0.0.3 area 0
network  192.168.1.0 0.0.0.255 area 0
!
ip route 0.0.0.0 0.0.0.0 10.10.1.1  permanent

Everyone's tags (2)
8 REPLIES
New Member

Re: Can not ping OSPF multicast IP address


IG#sh ip os in g0/1/0.32
GigabitEthernet0/1/0.32 is up, line protocol is up
  Internet Address 10.10.1.1/30, Area 0
  Process ID 1, Router ID 10.200.200.1, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 10.200.200.1, Interface address 10.10.1.1
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:07
  Supports Link-local Signaling (LLS)
  Index 5/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)

CB#sh ip ospf int g0/0/0
GigabitEthernet0/0/0 is up, line protocol is up
  Internet Address 10.10.1.2/30, Area 0
  Process ID 1, Router ID 10.200.204.1, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 10.200.204.1, Interface address 10.10.1.2
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:05
  Supports Link-local Signaling (LLS)
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)

Hall of Fame Super Silver

Re: Can not ping OSPF multicast IP address

Edil

I believe that the problem is that router IG sees the connection as a VLAN in a trunk, and since it is not configured as the native VLAN then IG expects the Ethernet frames to be tagged as part of the VLAN. But CB sees it as a normal Ethernet interface and not as part of a trunk. So it is not tagging the frames.

HTH

Rick

New Member

Re: Can not ping OSPF multicast IP address

Rick,

Thank you very much for your suppoort. As you can see in IG config I also have another interface that is connected to router CCTV#2. CCTV#2 is also receive truogh the same ethernet link from the same provider in another vlan and it is working fine. CCTV#2 is not a 3825 though but a 3550.

Please keep advising.

best regards

Hall of Fame Super Silver

Re: Can not ping OSPF multicast IP address

Edil

From what you tell us it seems that CCTV#2 is sending data for VLAN 10 in tagged frames as part of a trunk and the provider is sending the data tagged as part of a trunk. You have not told us much about CB and how it is connected. Would it be possible to configure it to trunk (and make VLAN 32 a tagged VLAN)?

HTH

Rick

New Member

Re: Can not ping OSPF multicast IP address

Rick,

As far as I know I'm not using trunk at the 3550 since the port are configured as no switchport here is the output from CCTV#2 and the show ip ospf neighbors and debug ip ospf events from IG. CB and CCTV#2:

======================= 3550 CCTV#2 =============================

hostname CCTVSW2
!
no errdisable detect cause pagp-flap
no errdisable detect cause dtp-flap
no errdisable detect cause link-flap
no errdisable detect cause l2ptguard
no errdisable detect cause gbic-invalid
no errdisable detect cause loopback
ip subnet-zero
ip routing
ip multicast-routing
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
switchport mode access
no ip address
spanning-tree portfast
*
*
*
*
*
interface FastEthernet0/24
description to CCTV#3
no switchport
ip address 172.10.3.1 255.255.255.252
ip ospf hello-interval 1
ip ospf dead-interval 2
ip ospf retransmit-interval 3
ip ospf transmit-delay 3
!
interface GigabitEthernet0/1
description provider link to IG
no switchport
ip address 172.10.2.2 255.255.255.252
ip ospf hello-interval 1
ip ospf dead-interval 2
ip ospf retransmit-interval 3
ip ospf transmit-delay 3
!
router ospf 27
router-id 172.10.3.1
log-adjacency-changes
network 172.10.2.0 0.0.0.3 area 0
network 172.10.3.0 0.0.0.3 area 0
!
ip classless
end

======================================================================================

CCTV#2 OSPF NEIGHBORS

CCTVSW2#sh ip ospf neigh

Neighbor ID     Pri   State           Dead Time   Address         Interface
172.10.4.1       10   FULL/DR         00:00:01    172.10.3.2      FastEthernet0/24
10.200.200.1      1   FULL/DR         00:00:01    172.10.2.1      GigabitEthernet0/1
CCTVSW2#

=====================================================================================

CCTV#2 DEBUG OSPF EVENTS

CCTVSW2#term monitor
CCTVSW2#debug ip ospf events
OSPF events debugging is on
CCTVSW2#
000061: Sep 22 20:38:41.927 GMT: OSPF: Rcv hello 10.200.200.1 area 0 from GigabitEthernet0/1 172.10.2.1
000062: Sep 22 20:38:41.927 GMT: OSPF: End of hello processing
000063: Sep 22 20:38:42.619 GMT: OSPF: Rcv hello 172.10.4.1 area 0 from FastEthernet0/24 172.10.3.2
000064: Sep 22 20:38:42.619 GMT: OSPF: End of hello processing
000065: Sep 22 20:38:42.927 GMT: OSPF: Rcv hello 10.200.200.1 area 0 from GigabitEthernet0/1 172.10.2.1
000066: Sep 22 20:38:42.927 GMT: OSPF: End of hello processing
000067: Sep 22 20:38:43.619 GMT: OSPF: Rcv hello 172.10.4.1 area 0 from FastEthernet0/24 172.10.3.2
000068: Sep 22 20:38:43.619 GMT: OSPF: End of hello processing
000069: Sep 22 20:38:43.927 GMT: OSPF: Rcv hello 10.200.200.1 area 0 from GigabitEthernet0/1 172.10.2.1
000070: Sep 22 20:38:43.927 GMT: OSPF: End of hello processing

==========================================================================================

IG SHOW OSPF NEIGHBORS

IG#sh ip os ne

Neighbor ID     Pri   State           Dead Time   Address         Interface
172.10.10.1      10   FULL/DR         00:00:01    172.10.1.2      GigabitEthernet0/1
172.10.3.1        1   FULL/BDR        00:00:01    172.10.2.2      GigabitEthernet0/1/0.10
IG#

=========================================================================================

IG OSPF EVENTS

IG#debug ip ospf events
OSPF events debugging is on
IG#
2294210: Sep 22 23:01:09.055 GMT: OSPF: Send hello to 224.0.0.5 area 0 on GigabitEthernet0/1/0.10 from 172.10.2.1
2294211: Sep 22 23:01:09.055 GMT: OSPF: Send hello to 224.0.0.5 area 0 on GigabitEthernet0/1 from 172.10.1.1
2294212: Sep 22 23:01:09.475 GMT: OSPF: Rcv hello from 172.10.3.1 area 0 from GigabitEthernet0/1/0.10 172.10.2.2
2294213: Sep 22 23:01:09.475 GMT: OSPF: End of hello processing
2294214: Sep 22 23:01:09.579 GMT: OSPF: Rcv hello from 172.10.10.1 area 0 from GigabitEthernet0/1 172.10.1.2
2294215: Sep 22 23:01:09.579 GMT: OSPF: End of hello processing
2294216: Sep 22 23:01:10.055 GMT: OSPF: Send hello to 224.0.0.5 area 0 on GigabitEthernet0/1/0.10 from 172.10.2.1
2294217: Sep 22 23:01:10.055 GMT: OSPF: Send hello to 224.0.0.5 area 0 on GigabitEthernet0/1 from 172.10.1.1
2294218: Sep 22 23:01:10.475 GMT: OSPF: Rcv hello from 172.10.3.1 area 0 from GigabitEthernet0/1/0.10 172.10.2.2
2294219: Sep 22 23:01:10.475 GMT: OSPF: End of hello processing
2294220: Sep 22 23:01:10.579 GMT: OSPF: Rcv hello from 172.10.10.1 area 0 from GigabitEthernet0/1 172.10.1.2
2294221: Sep 22 23:01:10.579 GMT: OSPF: End of hello processing

==================================================================================================================

CB DEBUG OSPF EVENTS

CB#debug ip ospf events
OSPF events debugging is on
CB#terminal monitor
CB#
Sep 22 2010 23:05:21.918: OSPF: Send hello to 224.0.0.5 area 0 on GigabitEthernet0/0/0 from 10.10.1.2
Sep 22 2010 23:05:21.918: OSPF: Send hello to 224.0.0.5 area 0 on GigabitEthernet0/0 from 192.168.1.1
Sep 22 2010 23:05:22.286: OSPF: Rcv hello from 10.200.200.1 area 0 from GigabitEthernet0/0/0 10.10.1.1
Sep 22 2010 23:05:22.286: OSPF: End of hello processing
Sep 22 2010 23:05:31.918: OSPF: Send hello to 224.0.0.5 area 0 on GigabitEthernet0/0/0 from 10.10.1.2
Sep 22 2010 23:05:31.918: OSPF: Send hello to 224.0.0.5 area 0 on GigabitEthernet0/0 from 192.168.1.1
Sep 22 2010 23:05:32.286: OSPF: Rcv hello from 10.200.200.1 area 0 from GigabitEthernet0/0/0 10.10.1.1
Sep 22 2010 23:05:32.286: OSPF: End of hello processing

Hall of Fame Super Silver

Re: Can not ping OSPF multicast IP address

Edil

From what you have posted it does look like CCTV2 is not trunking on its interface to the provider.

So let us look at this issue from a slightly different perspective: do we have correct connectivity between IQ and CB? Does the MAC of CB show up in the ARP table if IQ and does the MAC of IQ show up in the ARP table of CB? Also can IQ and CB ping each others interface?

HTH

Rick

New Member

Re: Can not ping OSPF multicast IP address

Rick,

I went to CB site and power re-cycle the router (not a reload but a conmplete power down). After that the adjacencies were created and now everything is working fine.

Thanks for all your help.

Hall of Fame Super Silver

Re: Can not ping OSPF multicast IP address

Edil

I am glad that you got it working. Thank you for posting to the forum to tell us that it is now working and what you did to fix it. It makes the forum more useful when people can read about a problem and can also read what was done to fix it, and you have now supplied that answer. Perhaps you could mark this issue as resolved so that people will recognize that this problem is fixed.

HTH

Rick

3248
Views
0
Helpful
8
Replies