Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Can PPPoE in a trunk port?

I have a customer who has this PPPoE configuration below, not I am not sure it would work.

interface GigabitEthernet0/0.1

encapsulation dot1Q 1 native

ip address x.x.x.x 255.255.255.0

interface GigabitEthernet0/0.10

encapsulation dot1Q 10

pppoe enable group global

pppoe-client dial-pool-number 1 dial-on-demand

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap callin

ppp chap hostname xxxxxxx

ppp chap password 7 131400430E1E563E32

ppp pap sent-username xxxxxxx password 7 010211555E19541B38

Any help on this is highly appreciated.

1 REPLY
Hall of Fame Super Silver

Re: Can PPPoE in a trunk port?

Hello Jose,

recently this feature PPPoE client on a LAN subif has been introduced.

If you have a LAN switch in the middle and the ADSL modem LAN port is connected to a switch port that is in access mode and in Vlan10 this setup can work.

A Broadband NAS could also be able to process PPPoE that have a vlan-tag:

ethernet header_p1 (DA,SA) -- 802.1Q header --- PPPoE header--

Hope to help

Giuseppe

290
Views
0
Helpful
1
Replies
CreatePlease to create content