Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Can't connect to carrier via 3G

I can connect to carrier via PCCW 3G in HongKong , but failed by using SmarTone 3G. Any Idea?

Platform: Cisco ISR887+PCEX-3G-HSPA-G

The detail info of my testing are as following:

Configuration:

Specially for PCCW:

cellular 0 gsm profile create 1 pccw

For SmarTone:

cellular 0 gsm profile create 1 SmarTone-Vodafone

Suitable for both two 3G card:

chat-script gsm "" "ATDT*98*1#" TIMEOUT 60 "CONNECT"

interface Cellular0

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer in-band

dialer idle-timeout 0

dialer string gsm

dialer-group 1

async mode interactive

ppp chap hostname 53660933@pccwmobile.com

ppp chap password 0 53660933

!

interface Vlan1

ip nat inside

ip address 10.99.99.1 255.255.255.0

!

ip route 0.0.0.0 0.0.0.0 Cellular0

!

access-list 1 permit any

dialer-list 1 protocol ip list 1

!

line 3

exec-timeout 0 0

script dialer gsm

modem InOut

no exec

rxspeed 7200000

txspeed 5760000

Debug Log:

PCCW:

Router#ping 8.8.8
*Nov 18 15:59:59.315: %SYS-5-CONFIG_I: Configured from console by console.8

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:

*Nov 18 16:00:01.531: Ce0 DDR: place call
*Nov 18 16:00:01.531: Ce0 DDR: Dialing cause ip (s=10.99.99.1, d=8.8.8.8)
*Nov 18 16:00:01.531: Ce0 DDR: Attempting to dial gsm
*Nov 18 16:00:01.531: CHAT3: Attempting async line dialer script
*Nov 18 16:00:01.531: CHAT3: Dialing using Modem script: gsm & System script: none
*Nov 18 16:00:01.531: CHAT3: process started
*Nov 18 16:00:01.531: CHAT3: Asserting DTR
*Nov 18 16:00:01.543: CHAT3: Chat script gsm started
*Nov 18 16:00:01.543: CHAT3: Sending string: ATDT*98*1#
*Nov 18 16:00:01.543: CHAT3: Expecting string: CONNECT
*Nov 18 16:00:01.547: CHAT3: Completed match for expect: CONNECT
*Nov 18 16:00:01.547: CHAT3: Chat script gsm finished, status = Success.
*Nov 18 16:00:03.619: %LINK-3-UPDOWN: Interface Cellular0, changed state to up
*Nov 18 16:00:03.619: Ce0 DDR: Dialer statechange to up
*Nov 18 16:00:03.619: Ce0 DDR: Dialer call has been placed
*Nov 18 16:00:03.619: Ce0 PPP: Sending cstate UP notification
*Nov 18 16:00:03.619: Ce0 PPP: Processing CstateUp message
*Nov 18 16:00:03.647: PPP: Alloc Context [851F9A74]
*Nov 18 16:00:03.647: ppp1 PPP: Phase is ESTABLISHING
*Nov 18 16:00:03.647: Ce0 PPP: Using dialer call direction
*Nov 18 16:00:03.647: Ce0 PPP: Treating connection as a callout
*Nov 18 16:00:03.647: Ce0 PPP: Session handle[DD000001] Session id[1]
*Nov 18 16:00:03.647: Ce0 LCP: Event[OPEN] State[Initial to Starting]
*Nov 18 16:00:03.647: Ce0 PPP: No remote authentication for call-out
*Nov 18 16:00:03.647: Ce0 LCP: O CONFREQ [Starting] id 1 len 20
*Nov 18 16:00:03.647: Ce0 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Nov 18 16:00:03.647: Ce0 LCP:    MagicNumber 0x3DECB157 (0x05063DECB157)
*Nov 18 16:00:03.647: Ce0 LCP:    PFC (0x0702)
*Nov 18 16:00:03.647: Ce0 LCP:    ACFC (0x0802)
*Nov 18 16:00:03.647: Ce0 LCP: Event[UP] State[Starting to REQsent]
*Nov 18 16:00:03.659: Ce0 LCP: I CONFREQ [REQsent] id 0 len 25
*Nov 18 16:00:03.659: Ce0 LCP:    ACCM 0x00000000 (0x020600000000)
*Nov 18 16:00:03.659: Ce0 LCP:    AuthProto CHAP (0x0305C22305)
*Nov 18 16:00:03.659: Ce0 LCP:    MagicNumber 0x27647E40 (0x050627647E40)
*Nov 18 16:00:03.659: Ce0 LCP:    PFC (0x0702)
*Nov 18 16:00:03.659: Ce0 LCP:    ACFC (0x0802)
*Nov 18 16:00:03.659: Ce0 LCP: O CONFACK [REQsent] id 0 len 25
*Nov 18 16:00:03.659: Ce0 LCP:    ACCM 0x00000000 (0x020600000000)
*Nov 18 16:00:03.659: Ce0 LCP:    AuthProto CHAP (0x0305C22305)
*Nov 18 16:00:03.659: Ce0 LCP:    MagicNumber 0x27647E40 (0x050627647E40)
*Nov 18 16:00:03.659: Ce0 LCP:    PFC (0x0702)
*Nov 18 16:00:03.659: Ce0 LCP:    ACFC (0x0802)
.*Nov 18 16:00:03.659: Ce0 LCP: Event[Receive ConfReq+] State[REQsent to ACKsent]
*Nov 18 16:00:03.659: Ce0 LCP: I CONFACK [ACKsent] id 1 len 20
*Nov 18 16:00:03.659: Ce0 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Nov 18 16:00:03.659: Ce0 LCP:    MagicNumber 0x3DECB157 (0x05063DECB157)
*Nov 18 16:00:03.659: Ce0 LCP:    PFC (0x0702)
*Nov 18 16:00:03.659: Ce0 LCP:    ACFC (0x0802)
*Nov 18 16:00:03.659: Ce0 LCP: Event[Receive ConfAck] State[ACKsent to Open]
*Nov 18 16:00:03.667: Ce0 PPP: Queue CHAP code[1] id[1]
*Nov 18 16:00:03.675: Ce0 PPP: Phase is AUTHENTICATING, by the peer
*Nov 18 16:00:03.675: Ce0 CHAP: Redirect packet to Ce0
*Nov 18 16:00:03.675: Ce0 CHAP: I CHALLENGE id 1 len 35 from "UMTS_CHAP_SRVR"
*Nov 18 16:00:03.675: Ce0 LCP: State is Open
*Nov 18 16:00:03.675: Ce0 CHAP: Using hostname from interface CHAP
*Nov 18 16:00:03.675: Ce0 CHAP: Using password from interface CHAP
*Nov 18 16:00:03.675: Ce0 CHAP: O RESPONSE id 1 len 44 from "53660933@pccwmobile.com"
*Nov 18 16:00:03.683: Ce0 CHAP: I SUCCESS id 1 len 4
*Nov 18 16:00:03.683: Ce0 PPP: Phase is FORWARDING, Attempting Forward
*Nov 18 16:00:03.687: Ce0 PPP: Phase is ESTABLISHING, Finish LCP
*Nov 18 16:00:03.687: Ce0 PPP: Phase is UP
*Nov 18 16:00:03.687: Ce0 IPCP: Protocol configured, start CP. state[Initial]
*Nov 18 16:00:03.687: Ce0 IPCP: Event[OPEN] State[Initial to Starting]
*Nov 18 16:00:03.687: Ce0 IPCP: O CONFREQ [Starting] id 1 len 10
*Nov 18 16:00:03.687: Ce0 IPCP:    Address 0.0.0.0 (0x030600000000)
*Nov 18 16:00:03.687: Ce0 IPCP: Event[UP] State[Starting to REQsent]
*Nov 18 16:00:04.687: Ce0 IPCP: I CONFNAK [REQsent] id 1 len 16
*Nov 18 16:00:04.687: Ce0 IPCP:    PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Nov 18 16:00:04.!!
Success rate is 40 percent (2/5), round-trip min/avg/max = 80/80/80 ms
Router#.687: Ce0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
*Nov 18 16:00:04.687: Ce0 IPCP: O CONFREQ [REQsent] id 2 len 10
*Nov 18 16:00:04.691: Ce0 IPCP:    Address 0.0.0.0 (0x030600000000)
*Nov 18 16:00:04.691: Ce0 IPCP: Event[Receive ConfNak/Rej] State[REQsent to REQsent]
*Nov 18 16:00:05.695: Ce0 IPCP: I CONFNAK [REQsent] id 2 len 16
*Nov 18 16:00:05.695: Ce0 IPCP:    PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Nov 18 16:00:05.695: Ce0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
*Nov 18 16:00:05.695: Ce0 IPCP: O CONFREQ [REQsent] id 3 len 10
*Nov 18 16:00:05.695: Ce0 IPCP:    Address 0.0.0.0 (0x030600000000)
*Nov 18 16:00:05.699: Ce0 IPCP: Event[Receive ConfNak/Rej] State[REQsent to REQsent]
*Nov 18 16:00:06.703: Ce0 IPCP: I CONFNAK [REQsent] id 3 len 16
*Nov 18 16:00:06.703: Ce0 IPCP:    PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Nov 18 16:00:06.703: Ce0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
*Nov 18 16:00:06.703: Ce0 IPCP: O CONFREQ [REQsent] id 4 len 10
*Nov 18 16:00:06.703: Ce0 IPCP:    Address 0.0.0.0 (0x030600000000)
*Nov 18 16:00:06.703: Ce0 IPCP: Event[Receive ConfNak/Rej] State[REQsent to REQsent]
*Nov 18 16:00:06.759: Ce0 IPCP: I CONFREQ [REQsent] id 0 len 4
*Nov 18 16:00:06.759: Ce0 IPCP AUTHOR: Done. Her address 0.0.0.0, we want 0.0.0.0
*Nov 18 16:00:06.759: Ce0 IPCP: O CONFACK [REQsent] id 0 len 4
*Nov 18 16:00:06.759: Ce0 IPCP: Event[Receive ConfReq+] State[REQsent to ACKsent]
*Nov 18 16:00:06.759: Ce0 IPCP: I CONFNAK [ACKsent] id 4 len 10
*Nov 18 16:00:06.759: Ce0 IPCP:    Address 10.162.86.143 (0x03060AA2568F)
*Nov 18 16:00:06.759: Ce0 IPCP: O CONFREQ [ACKsent] id 5 len 10
*Nov 18 16:00:06.759: Ce0 IPCP:    Address 10.162.86.143 (0x03060AA2568F)
*Nov 18 16:00:06.759: Ce0 IPCP: Event[Receive ConfNak/Rej] State[ACKsent to ACKsent]
*Nov 18 16:00:06.771: Ce0 IPCP: I CONFACK [ACKsent] id 5 len 10
*Nov 18 16:00:06.771: Ce0 IPCP:    Address 10.162.86.143 (0x03060AA2568F)
*Nov 18 16:00:06.771: Ce0 IPCP: Event[Receive ConfAck] State[ACKsent to Open]
*Nov 18 16:00:06.811: Ce0 IPCP: State is Open
*Nov 18 16:00:06.811: Ce0 IPCP: Install negotiated IP interface address 10.162.86.143
*Nov 18 16:00:06.815: Ce0 DDR: dialer protocol up
Router#
Router#
Router#
Router#sh ip int br
Any interface listed with OK? value "NO" does not have a valid configuration

Interface                  IP-Address      OK? Method Status                Protocol
ATM0                       unassigned      YES unset  administratively down down   
Cellular0                  10.162.86.143   YES IPCP   up                    up     
FastEthernet0              unassigned      YES unset  up                    down   
FastEthernet1              unassigned      YES unset  up                    down   
FastEthernet2              unassigned      YES unset  up                    down   
FastEthernet3              unassigned      YES unset  up                    down   
NVI0                       unassigned      NO  unset  up                    up     
Vlan1                      10.99.99.1      YES manual up                    up     
Wlan-GigabitEthernet0      unassigned      YES unset  up                    up     
wlan-ap0                   unassigned      YES unset  administratively down down   
Router#
Router#
Router#ping 8.8.8.8

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 72/78/80 ms
Router#
Router#

SmarTone:

Router#ping 8.8.8.8

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:

*Nov 18 17:00:23.427: Ce0 DDR: place call
*Nov 18 17:00:23.427: Ce0 DDR: Dialing cause ip (s=192.168.99.1, d=8.8.8.8)
*Nov 18 17:00:23.427: Ce0 DDR: Attempting to dial gsm
*Nov 18 17:00:23.427: CHAT3: Attempting async line dialer script
*Nov 18 17:00:23.427: CHAT3: Dialing using Modem script: gsm & System script: none
*Nov 18 17:00:23.427: CHAT3: process started
*Nov 18 17:00:23.427: CHAT3: Asserting DTR
*Nov 18 17:00:23.427: CHAT3: Chat script gsm started
*Nov 18 17:00:23.431: CHAT3: Sending string: ATDT*98*1#
*Nov 18 17:00:23.431: CHAT3: Expecting string: CONNECT
*Nov 18 17:00:23.447: CHAT3: Completed match for expect: CONNECT
*Nov 18 17:00:23.447: CHAT3: Chat script gsm finished, status = Success.
*Nov 18 17:00:25.523: %LINK-3-UPDOWN: Interface Cellular0, changed state to up
*Nov 18 17:00:25.523: Ce0 DDR: Dialer statechange to up
*Nov 18 17:00:25.523: Ce0 DDR: Dialer call has been placed
*Nov 18 17:00:25.523: Ce0 PPP: Sending cstate UP notification
*Nov 18 17:00:25.523: Ce0 PPP: Processing CstateUp message
*Nov 18 17:00:25.523: PPP: Alloc Context [85CE98F4]
*Nov 18 17:00:25.523: ppp13 PPP: Phase is ESTABLISHING
*Nov 18 17:00:25.523: Ce0 PPP: Using dialer call direction
*Nov 18 17:00:25.523: Ce0 PPP: Treating connection as a callout
*Nov 18 17:00:25.523: Ce0 PPP: Session handle[CD00000D] Session id[13]
*Nov 18 17:00:25.523: Ce0 LCP: Event[OPEN] State[Initial to Starting]
*Nov 18 17:00:25.523: Ce0 PPP: No remote authentication for call-out
*Nov 18 17:00:25.523: Ce0 LCP: O CONFREQ [Starting] id 1 len 20
*Nov 18 17:00:25.523: Ce0 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Nov 18 17:00:25.523: Ce0 LCP:    MagicNumber 0x3E189672 (0x05063E189672)
*Nov 18 17:00:25.523: Ce0 LCP:    PFC (0x0702)
*Nov 18 17:00:25.523: Ce0 LCP:    ACFC (0x0802)
*Nov 18 17:00:25.527: Ce0 LCP: Event[UP] State[Starting to REQsent]
*Nov 18 17:00:25.531: Ce0 LCP: I CONFACK [REQsent] id 1 len 20
*Nov 18 17:00:25.531: Ce0 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Nov 18 17:00:25.531: Ce0 LCP:    MagicNumber 0x3E189672 (0x05063E189672)
*Nov 18 17:00:25.531: Ce0 LCP:    PFC (0x0702)
*Nov 18 17:00:25.531: Ce0 LCP:    ACFC (0x0802)
*Nov 18 17:00:25.531: Ce0 LCP: Event[Receive ConfAck] State[REQsent to ACKrcvd]
*Nov 18 17:00:26.531: Ce0 LCP: I CONFREQ [ACKrcvd] id 27 len 25
*Nov 18 17:00:26.531: Ce0 LCP:    ACCM 0x00000000 (0x020600000000)
*Nov 18 17:00:26.531: Ce0 LCP:    AuthProto CHAP (0x0305C22305)
*Nov 18 17:00:26.531: Ce0 LCP:    MagicNumber 0x279BC52C (0x0506279BC52C)
*Nov 18 17:00:26.531: Ce0 LCP:    PFC (0x0702)
*Nov 18 17:00:26.531: Ce0 LCP:.    ACFC (0x0802)
*Nov 18 17:00:26.531: Ce0 LCP: O CONFACK [ACKrcvd] id 27 len 25
*Nov 18 17:00:26.531: Ce0 LCP:    ACCM 0x00000000 (0x020600000000)
*Nov 18 17:00:26.531: Ce0 LCP:    AuthProto CHAP (0x0305C22305)
*Nov 18 17:00:26.531: Ce0 LCP:    MagicNumber 0x279BC52C (0x0506279BC52C)
*Nov 18 17:00:26.531: Ce0 LCP:    PFC (0x0702)
*Nov 18 17:00:26.531: Ce0 LCP:    ACFC (0x0802)
*Nov 18 17:00:26.531: Ce0 LCP: Event[Receive ConfReq+] State[ACKrcvd to Open]
*Nov 18 17:00:26.535: Ce0 PPP: Queue CHAP code[1] id[1]
*Nov 18 17:00:26.547: Ce0 PPP: Phase is AUTHENTICATING, by the peer
*Nov 18 17:00:26.547: Ce0 CHAP: Redirect packet to Ce0
*Nov 18 17:00:26.547: Ce0 CHAP: I CHALLENGE id 1 len 35 from "UMTS_CHAP_SRVR"
*Nov 18 17:00:26.547: Ce0 LCP: State is Open
*Nov 18 17:00:26.547: Ce0 CHAP: Unable to authenticate for peer
*Nov 18 17:00:26.547: Ce0 PPP DISC: User failed CHAP authentication
*Nov 18 17:00:26.547: Ce0 LCP: O TERMREQ [Open] id 2 len 4
*Nov 18 17:00:26.547: Ce0 LCP: Event[CLOSE] State[Open to Closing]
*Nov 18 17:00:26.547: Ce0 PPP: Phase is TERMINATING
*Nov 18 17:00:26.551: Ce0 LCP: I TERMACK [Closing] id 2 len 4
*Nov 18 17:00:26.551: Ce0 PPP: No remote authentication for call-out
*Nov 18 17:00:26.551: Ce0 LCP: Event[Receive TermAck] State[Closing to Closed]
*Nov 18 17:00:26.551: Ce0 LCP: Event[DOWN] State[Closed to Initial]
*Nov 18 17:00:26.551: Ce0 PPP: Phase is DOWN
*Nov 18 17:00:28.555: %LINK-5-CHANGED: Interface Cellular0, changed state to reset.
*Nov 18 17:00:28.555: Ce0 PPP: Sending cstate DOWN notification
*Nov 18 17:00:28.555: Ce0 PPP: Processing CstateDown message..
Success rate is 0 percent (0/5)
Router#
*Nov 18 17:00:33.627: %LINK-3-UPDOWN: Interface Cellular0, changed state to down
Router#
*Nov 18 17:00:33.627: Ce0 PPP: Sending cstate DOWN notification
*Nov 18 17:00:33.627: Ce0 PPP: Processing CstateDown message
Router#
Router#
Router#
*Nov 18 17:00:43.555: Ce0 DDR: re-enable timeout
Router#
Router#show cel 0 pro 1
Profile 1 = INACTIVE*
--------
PDP Type = IPv4
Access Point Name (APN) = SmarTone-Vodafone
Authentication = None
Username: , Password:

* - Default profile
Router#

.

Everyone's tags (3)
936
Views
0
Helpful
0
Replies
CreatePlease to create content