Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

can't connect to my own site ... router issue !?

hi,

I have a router with a dialer interface(dsl).

everything with the connection works great.

in my internal network I have 2 computers, (webserver1) and (pc).

I'm using the router to do a static nat and forward all the connections to my router on port 80 to the webserver and it works fine.

the problem is that when I access this site (www.xyz.com) from the internet it works fine but when I try to access it from the internal pc, it does not work it just can't see the webserver.

I've used some debugging and this is what I get when I try to access the site from my pc (internal).

Mar 10 20:23:13 192.168.76.1 6624: architect: Mar 10 20:23:12.829: IP: tableid=0, s=192.168.76.2 (Ethernet0), d=X.X.X.X (Dialer1), routed via RIB

Mar 10 20:23:13 192.168.76.1 6625: architect: Mar 10 20:23:12.829: IP: s=192.168.76.2 (Ethernet0), d=X.X.X.X, len 48, rcvd 4

Mar 10 20:23:14 192.168.76.1 6626: architect: Mar 10 20:23:12.829: TCP src=1194, dst=80, seq=589242596, ack=0, win=65535 SYN

Mar 10 20:23:14 192.168.76.1 6627: architect: Mar 10 20:23:13.349: IP: tableid=0, s=192.168.76.2 (Ethernet0), d=X.X.X.X (Dialer1), routed via RIB

Mar 10 20:23:14 192.168.76.1 6628: architect: Mar 10 20:23:13.349: IP: s=192.168.76.2 (Ethernet0), d=X.X.X.X, len 48, rcvd 4

Mar 10 20:23:14 192.168.76.1 6629: architect: Mar 10 20:23:13.357: TCP src=1194, dst=80, seq=589242596, ack=0, win=65535 SYN

Mar 10 20:23:14 192.168.76.1 6630: architect: Mar 10 20:23:13.897: IP: tableid=0, s=192.168.76.2 (Ethernet0), d=X.X.X.X (Dialer1), routed via RIB

Mar 10 20:23:15 192.168.76.1 6631: architect: Mar 10 20:23:13.897: IP: s=192.168.76.2 (Ethernet0), d=X.X.X.X, len 48, rcvd 4

Mar 10 20:23:15 192.168.76.1 6632: architect: Mar 10 20:23:13.897: TCP src=1194, dst=80, seq=589242596, ack=0, win=65535 SYN

I can see that it tries 3 times and then it stops but I just don't understant how this can happen...

also, I can access any other sites on the internet from my pc but just not my own site ...

webserver (192.168.76.5) pc(192.168.76.2) router(192.168.76.1 the GW)

1 ACCEPTED SOLUTION

Accepted Solutions
Purple

Re: can't connect to my own site ... router issue !?

Hi,

Because of the NAT configuration, you cannot access your web-site using its public IP address. The only way you can access this site is by using its internal (non-NATed) address. There is nothing wrong with this - it is simply a consequence of using NAT.

Hope that helps - pls rate the post if it does.

Paresh

2 REPLIES
Purple

Re: can't connect to my own site ... router issue !?

Hi,

Because of the NAT configuration, you cannot access your web-site using its public IP address. The only way you can access this site is by using its internal (non-NATed) address. There is nothing wrong with this - it is simply a consequence of using NAT.

Hope that helps - pls rate the post if it does.

Paresh

New Member

Re: can't connect to my own site ... router issue !?

thank you for your information.

appreciate it!!

246
Views
0
Helpful
2
Replies