Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Can't get ISATAP to connect from XP

I'm just not sure what part of the config I am doing wrong or there is some bug i am running into.  I am running c3725-advipservicesk9-mz.124-15.T9.bin.

  The following is the config i have on the router.

interface Tunnel10
description ISATAP itnterface for windows and linux
no ip address
no ip redirects
ipv6 address FD39:26B1:DA1C:2::/64 eui-64
ipv6 enable
no ipv6 nd ra suppress
ipv6 ospf 1 area 0
tunnel source FastEthernet0/0
tunnel mode ipv6ip isatap

  This is the interface brief

ipv6gateway#sh ipv6 int brief
FastEthernet0/0            [up/up]
FastEthernet0/1            [up/up]
    FE80::C000:2EFF:FEF1:1
    FD39:26B1:DA1C:1::1
Tunnel0                    [up/up]
    FE80::C000:2EFF:FEF1:0
    unnumbered (Tunnel10)
Tunnel10                   [up/up]
    FE80::C000:2EFF:FEF1:0
    FD39:26B1:DA1C:2:C000:2EFF:FEF1:0

ipv6gateway#sh ipv6 route
IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
C   FD39:26B1:DA1C:1::/64 [0/0]
     via ::, FastEthernet0/1
L   FD39:26B1:DA1C:1::1/128 [0/0]
     via ::, FastEthernet0/1
C   FD39:26B1:DA1C:2::/64 [0/0]
     via ::, Tunnel10
L   FD39:26B1:DA1C:2:C000:2EFF:FEF1:0/128 [0/0]
     via ::, Tunnel10
L   FF00::/8 [0/0]
     via ::, Null0

  In XP, I ran 'netsh int ipv6 isatap set router 10.156.68.40'.

Tunnel adapter Teredo Tunneling Pseudo-Interface:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
        Physical Address. . . . . . . . . : FF-FF-FF-FF-FF-FF-FF-FF
        Dhcp Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : fe80::ffff:ffff:fffd%5
        Default Gateway . . . . . . . . . :
        NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Automatic Tunneling Pseudo-Interface:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : Automatic Tunneling Pseudo-Interface

        Physical Address. . . . . . . . . : 0A-9C-35-54
        Dhcp Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : fe80::5efe:10.156.53.84%2
        Default Gateway . . . . . . . . . :
        DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                            fec0:0:0:ffff::2%1
                                            fec0:0:0:ffff::3%1
        NetBIOS over Tcpip. . . . . . . . : Disabled

C:\Documents and Settings\ggee>netsh interface ipv6 show route
Querying active state...

No entries were found.

  What part am I doing wrong?  Is there a better IOS I should be using?  What address should I use to ping6?

Thanks,

Greg

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Can't get ISATAP to connect from XP

Hi,

I'm also using VB ;-)

Here is what I have when my router is off:

Tunnel adapter Automatic Tunneling Pseudo-Interface:


        Connection-specific DNS Suffix  . :

        Description . . . . . . . . . . . : Automatic Tunneling Pseudo-Interface


        Physical Address. . . . . . . . . : AC-10-00-01

        Dhcp Enabled. . . . . . . . . . . : No

        IP Address. . . . . . . . . . . . : fe80::5efe:172.16.0.1%2

        Default Gateway . . . . . . . . . :

        DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%3

                                            fec0:0:0:ffff::2%3

                                            fec0:0:0:ffff::3%3

        NetBIOS over Tcpip. . . . . . . . : Disabled

Once my router is ON:

C:\Documents and Settings\laaubert>netsh interface ipv6 isatap set router 172.16.0.254

Ok.


C:\Documents and Settings\laaubert>ipconfig /all

...

Tunnel adapter Automatic Tunneling Pseudo-Interface:


        Connection-specific DNS Suffix  . :

        Description . . . . . . . . . . . : Automatic Tunneling Pseudo-Interface


        Physical Address. . . . . . . . . : AC-10-00-01

        Dhcp Enabled. . . . . . . . . . . : No

        IP Address. . . . . . . . . . . . : 2011:1::5efe:172.16.0.1

        IP Address. . . . . . . . . . . . : fe80::5efe:172.16.0.1%2

        Default Gateway . . . . . . . . . : fe80::5efe:172.16.0.254%2

        DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%3

                                            fec0:0:0:ffff::2%3

                                            fec0:0:0:ffff::3%3

        NetBIOS over Tcpip. . . . . . . . : Disabled

Here is my router configuration:

ipv6 unicast-routing

ipv6 cef

!

interface Tunnel0

description ISATAP

no ip address

no ip redirects

ipv6 address 2011:1::/64 eui-64

ipv6 enable

no ipv6 nd ra suppress

tunnel source Ethernet1/0

tunnel mode ipv6ip isatap


!

interface Ethernet1/0

description ISATAP GW

ip address 172.16.0.254 255.255.255.0

!

I used 12.2(33)SRE.

You can run debug ipv6 icmp and debug ipv6 packet to track the RA and RS:

*Dec 12 03:59:01.515: IPV6: source FE80::5EFE:AC10:1 (Tunnel0)

*Dec 12 03:59:01.515:       dest FF02::2

*Dec 12 03:59:01.515:       traffic class 0, flow 0x0, len 48+20, prot 58, hops 255, forward to ulp

*Dec 12 03:59:01.515: ICMPv6: Received R-Solicit, Src=FE80::5EFE:AC10:1, Dst=FF02::2

*Dec 12 03:59:01.524: IPV6: source FE80::5EFE:AC10:FE (local)

*Dec 12 03:59:01.524:       dest FE80::5EFE:AC10:1 (Tunnel0)

*Dec 12 03:59:01.524:       traffic class 224, flow 0x0, len 96+0, prot 58, hops 255, originating

*Dec 12 03:59:01.524: IPv6-Fwd: Sending on Tunnel0

*Dec 12 03:59:01.524: ICMPv6: Sent R-Advert, Src=FE80::5EFE:AC10:FE, Dst=FE80::5EFE:AC10:1

HTH

Laurent.

6 REPLIES
New Member

Re: Can't get ISATAP to connect from XP

I guess I should ask, has anyone done ISATAP from Windows XP?  How?

Thanks,

Greg

Cisco Employee

Re: Can't get ISATAP to connect from XP

Hi Greg,

Can you ping 10.156.68.40 from your station ?

Your tunnel configuration looks good.

I did the same configuration on my laptop (XR SP2) and it's working fine.

HTH

Laurent.

New Member

Re: Can't get ISATAP to connect from XP

Yes, I have no problem doing ping and telnet to the router.  Out of curiosity,
what router model and IOS version are you using?

I am trying on:

Cisco 3725

c3725-advipservicesk9-mz.124-15.T9.bin

Now to be specific, My XP SP3 is running in Virtual box while I test this setup.  Maybe SP3 has issues.

Thanks,

Greg

New Member

Re: Can't get ISATAP to connect from XP

Related to above, how can I tell if it works?  How do I test it?

Greg

Cisco Employee

Re: Can't get ISATAP to connect from XP

Hi,

I'm also using VB ;-)

Here is what I have when my router is off:

Tunnel adapter Automatic Tunneling Pseudo-Interface:


        Connection-specific DNS Suffix  . :

        Description . . . . . . . . . . . : Automatic Tunneling Pseudo-Interface


        Physical Address. . . . . . . . . : AC-10-00-01

        Dhcp Enabled. . . . . . . . . . . : No

        IP Address. . . . . . . . . . . . : fe80::5efe:172.16.0.1%2

        Default Gateway . . . . . . . . . :

        DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%3

                                            fec0:0:0:ffff::2%3

                                            fec0:0:0:ffff::3%3

        NetBIOS over Tcpip. . . . . . . . : Disabled

Once my router is ON:

C:\Documents and Settings\laaubert>netsh interface ipv6 isatap set router 172.16.0.254

Ok.


C:\Documents and Settings\laaubert>ipconfig /all

...

Tunnel adapter Automatic Tunneling Pseudo-Interface:


        Connection-specific DNS Suffix  . :

        Description . . . . . . . . . . . : Automatic Tunneling Pseudo-Interface


        Physical Address. . . . . . . . . : AC-10-00-01

        Dhcp Enabled. . . . . . . . . . . : No

        IP Address. . . . . . . . . . . . : 2011:1::5efe:172.16.0.1

        IP Address. . . . . . . . . . . . : fe80::5efe:172.16.0.1%2

        Default Gateway . . . . . . . . . : fe80::5efe:172.16.0.254%2

        DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%3

                                            fec0:0:0:ffff::2%3

                                            fec0:0:0:ffff::3%3

        NetBIOS over Tcpip. . . . . . . . : Disabled

Here is my router configuration:

ipv6 unicast-routing

ipv6 cef

!

interface Tunnel0

description ISATAP

no ip address

no ip redirects

ipv6 address 2011:1::/64 eui-64

ipv6 enable

no ipv6 nd ra suppress

tunnel source Ethernet1/0

tunnel mode ipv6ip isatap


!

interface Ethernet1/0

description ISATAP GW

ip address 172.16.0.254 255.255.255.0

!

I used 12.2(33)SRE.

You can run debug ipv6 icmp and debug ipv6 packet to track the RA and RS:

*Dec 12 03:59:01.515: IPV6: source FE80::5EFE:AC10:1 (Tunnel0)

*Dec 12 03:59:01.515:       dest FF02::2

*Dec 12 03:59:01.515:       traffic class 0, flow 0x0, len 48+20, prot 58, hops 255, forward to ulp

*Dec 12 03:59:01.515: ICMPv6: Received R-Solicit, Src=FE80::5EFE:AC10:1, Dst=FF02::2

*Dec 12 03:59:01.524: IPV6: source FE80::5EFE:AC10:FE (local)

*Dec 12 03:59:01.524:       dest FE80::5EFE:AC10:1 (Tunnel0)

*Dec 12 03:59:01.524:       traffic class 224, flow 0x0, len 96+0, prot 58, hops 255, originating

*Dec 12 03:59:01.524: IPv6-Fwd: Sending on Tunnel0

*Dec 12 03:59:01.524: ICMPv6: Sent R-Advert, Src=FE80::5EFE:AC10:FE, Dst=FE80::5EFE:AC10:1

HTH

Laurent.

New Member

Re: Can't get ISATAP to connect from XP

Thanks.  Moving from a 3725 running c3725-advipservicesk9-mz.124-15.T9.bin to a 7200 running c7200-adventerprisek9-mz.122-33.SRC.bin made it all work.

Thanks,

Greg

720
Views
0
Helpful
6
Replies