Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Can't get telnet session to ADSL router

Hi

837 ADSL Router - Basic Config, no access-list

line vty 0 4

exec-timeout 0 0

password 7 <snip>

login local

transport preferred telnet

transport input telnet ssh

transport output none

!

what's missing?

12 REPLIES
Silver

Re: Can't get telnet session to ADSL router

Hi, try:

no login local

login

this is because with "login local" it's going to look at the local databasean d it's not going to use the password you set under teh line vty, so put only "login".

Regards

Hope this helps, if so pls rate post

New Member

Re: Can't get telnet session to ADSL router

removed.....still not working ;(

New Member

Re: Can't get telnet session to ADSL router

the telnet just hangs on

Trying XXX.XXX.XXX.XXX...

after a while i get this :

telnet: Unable to connect to remote host: Connection timed out

there is no connection refused or anything?

Silver

Re: Can't get telnet session to ADSL router

Hi, ping is working?

New Member

Re: Can't get telnet session to ADSL router

there is no problem with ping. it works fine. the other problem is that i cannot config dyndns.

i will try to upgrade the IOS. should this fix the prob? The router has the dfault IOS it was shipped with. Will upgrade to latest advIP IOS but will it fix prob?

Silver

Re: Can't get telnet session to ADSL router

Hi, why don't you try with the simpliest config first to see that telnet is working and after you can add more commands.

Try:

line vty 0 4

exec-timeout 0 0

login

password xxxx

!

New Member

Re: Can't get telnet session to ADSL router

First try the basic commands as below....

line vty 0 4

exec-timeout 0 0

password 7

login local

New Member

Re: Can't get telnet session to ADSL router

This is not working! What am I doing wrong? This should be simple. What am I missing?

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

logging console errors

!

clock timezone utc 2

no aaa new-model

ip subnet-zero

ip dhcp excluded-address 10.10.10.1

!

!

ip cef

ip audit notify log

ip audit po max-events 100

ip ssh break-string

no ftp-server write-enable

no scripting tcl init

no scripting tcl encdir

!

!

!

no crypto isakmp enable

!

!

!

!

interface Ethernet0

ip address 192.168.0.1 255.255.0.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip tcp adjust-mss 1348

hold-queue 100 out

!

interface ATM0

no ip address

no atm ilmi-keepalive

pvc 8/35

pppoe-client dial-pool-number 1

!

dsl operating-mode auto

!

interface FastEthernet1

no ip address

duplex auto

speed auto

!

interface FastEthernet2

no ip address

duplex auto

speed auto

!

interface FastEthernet3

no ip address

duplex auto

speed auto

!

interface FastEthernet4

no ip address

duplex auto

speed auto

!

interface Dialer0

ip address negotiated

ip mtu 1452

ip nat outside

encapsulation ppp

ip tcp adjust-mss 1348

dialer pool 1

dialer-group 1

ppp authentication pap callin

ppp chap refuse

ppp pap sent-username password

!

ip nat inside source route-map SDM_RMAP_1 interface Dialer0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

no ip http server

no ip http secure-server

!

!

access-list 10 permit

access-list 20 permit

access-list 23 permit 10.10.10.0 0.0.0.255

dialer-list 1 protocol ip permit

route-map SDM_RMAP_1 permit 1

!

!

control-plane

!

!

line con 0

exec-timeout 120 0

no modem enable

transport preferred all

transport output all

stopbits 1

line aux 0

transport preferred all

transport output all

line vty 0 4

exec-timeout 0 0

password

login

transport preferred telnet

transport input telnet ssh

transport output none

!

scheduler max-task-time 5000

!

end

Re: Can't get telnet session to ADSL router

Hi ,

Everything looks fine . Just a basic check , Your sessions are not full in your router right . Because you have given " exec-timeout 0 0 " , earlier telnet sessions might not have timed-out.

Can u check " sh users " and look out any sessions. If present do a "clear line vty *"

Hope this helps

regards

vanesh k

New Member

Re: Can't get telnet session to ADSL router

nope.... no other sessions except a console session. Cannot be that?

New Member

Re: Can't get telnet session to ADSL router

when i connect my notebook to the port on the router and get DHCP address, I am able to telnet to the router ehternet IP as well as the ADSL IP.

If I try from my office LAN I can't telnet to the ADSL IP Address.

New Member

Re: Can't get telnet session to ADSL router

Hi,

Is there any IP conflict between your LAN IP and ADSL IP.

Senthil

338
Views
0
Helpful
12
Replies