Cisco Support Community
Community Member

can't ping across l2tp tunnel after switching HP procurve for 3750x switch


   Here in our remote office we get dhcp from our corporate office via a L2TP tunnel between two 2901 routers.  This was working fine, until I replaced our old hp procurve 1800 switch with a new 3750x switch, and now I can't get the layer 3 working across the tunnel. 

quick diagram:
remote hosts----> 3750x --->2901 l2tp <--------->2901 l2tp ----->  HP procurve ------>  corporate office/servers/dhcp server

my first thought was it was just not letting dhcp through, but then I assigned a static ip address on my remote end, and I still can't ping across to the corporate office.

The l2tp tunnel is up, because I can see the MAC address on the corporate site if I do a:  show mac address-table. 

Jax3750x#show mac address-table
          Mac Address Table

Vlan    Mac Address       Type        Ports
----      -----------               --------       -----
....<abbreviated output>

1    d43d.7e57.619f    DYNAMIC     Gi1/0/17&#8232;  

1    f46d.042c.8ec6    DYNAMIC     Gi1/0/17&#8232;  

1    f46d.044e.aac2    DYNAMIC     Gi1/0/17&#8232;  

1    f872.ea21.cba9    DYNAMIC     Gi1/0/17&#8232; 

50    001f.2863.5ea0    DYNAMIC     Gi1/0/24&#8232; 

50    14da.e9da.8a00    DYNAMIC     Gi1/0/14&#8232; 

50    c82a.1440.152d    DYNAMIC     Gi1/0/15

Total Mac Addresses for this criterion: 66

Gi 1/0/17 is the port on the 3750x switch that is connected to the 2901 router, and it shows about 30 MAC's learned from the corporate office on VLAN 1.

interface GigabitEthernet1/0/17
switchport trunk encapsulation dot1q
switchport mode trunk

but DHCP requests and pings are not getting across!

I've banged my head on this for about 8 hours and can't find anything on the support boards about this issue. 
Any push in the right direction would be greatly appreciated.


Everyone's tags (1)
CreatePlease to create content