Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Can't read USB key on 2800's

I'm in the middle of deploying a number of 2800 routers. For convenience I'd like to be able to copy some files into flash from a usb key I have. If I plug the key into the router and type dir I get the following error:

%Error opening usbflash0:/ (Invalid DOS media or no media in slot)

However, if I format the usb key from the router console, I'm able to read and write to the key from the console.

If I go back and copy the files I want to move to the key from a windows machine and connect the key back to the router, I get the same error again.

Long story short; if I write to the key from a windows machine, the router is no longer able to read it.

I'm sure the key I'm using isn't on the supported list but, since the router can read and write to it fine when I format it, I don't think the key is the problem.

Any suggestions would be appreciated.

  • WAN Routing and Switching
3 REPLIES

Re: Can't read USB key on 2800's

Hi,

I've got 3 memory sticks here (up to 1GB) from different manufacturers which all work great. I've never needed to format one though as the routers seem to be able to read FAT just fine (and will even format a memory stick to FAT from the command line - I just checked).

If you're having problems then my money would be on the stick - have you any others you could try?

HTH

Andrew.

Silver

Re: Can't read USB key on 2800's

According to the USB Q&A, Cisco mentioned only support up to 256MB USB flash. According to Andrew's post, it may work w/ other size and brand. However, it flash should be formatted by FAT16 and using propoer API in Windows. If you are using non-Microsoft API for the USB, you can try to install the USB driver come / Microsoft rather than 3rd party.

http://www.cisco.com/en/US/products/ps6247/products_qanda_item0900aecd80232483.shtml

Hope this helps.

New Member

Re: Can't read USB key on 2800's

It must be my USB key. We have company branded simple-tech 1 GB keys and I've tried a few different ones and the router won't read any of them. I tried a different type of key and it worked fine.

1329
Views
3
Helpful
3
Replies