Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Cisco Support Community site will be in read only mode on Dec14, 2017 from 12:01am PST to 11:30am for standard maintenance. Sorry for the inconvenience.

New Member

Cannot access 1131ag access point from 1801 Router

Hi,

I wish to extend Wireless access in our office and have a AP1131AG access point connected to a 1801 Router on port FastEthernet2,

The 1801 has several VLANs configured, Public Internet access is on VLAN7.

The access point is still on the default Native Vlan 1 and I have assigned it IP address 192.168.10.2

The clients connect to the access point but cannot receive DHCP from the 1801, I also cannot ping/ssh to 192.168.10.2 from the 1801.

Here is a snippet from the 1801 config, can anyone point me in the right direction as to what could be wrong..........

Thanks,

Chris


dot11 ssid Wireless
   vlan 7
   authentication open
   authentication key-management wpa
   guest-mode
   wpa-psk ascii 7 xxxxxxxxxxxxxxxxxxxxxx

!

vlan 7

bridge irb
!
interface FastEthernet2
switchport access vlan 7
!
!
interface Dot11Radio0
no ip address
no ip route-cache cef
no ip route-cache
!
  !
encryption vlan 7 mode ciphers aes-ccm
!
ssid Wireless
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Dot11Radio0.7
encapsulation dot1Q 7 native
ip virtual-reassembly
no ip route-cache
timeout absolute 120 0
no cdp enable
bridge-group 7
bridge-group 7 subscriber-loop-control
bridge-group 7 spanning-disabled
bridge-group 7 block-unknown-source
no bridge-group 7 source-learning
no bridge-group 7 unicast-flooding
!
interface Vlan7
no ip address
bridge-group 7
bridge-group 7 spanning-disabled

!
interface BVI7
ip address 192.168.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly

!

Everyone's tags (5)
9 REPLIES

Re: Cannot access 1131ag access point from 1801 Router

Hi,

Out of which physical interface on the 1811 do you have the AP connected to?

Do you see the AP on the ''sh cdp neigh'' on the router?

Do you see the AP on the ARP table?

Federico.

New Member

Re: Cannot access 1131ag access point from 1801 Router

Hi,

The device is not showing up on the arp table, the WAP is connected to the 1801 port FastEthernet2

I'll take a look at cdp neighbours when I'm back in the office in the morning...

I'm sure this is some sort of VLAN issue as I connected it to a 877W (which only had the default vlan1 configured) and it extended the Wireless signal successfully and picked up dhcp from the 877W

Thanks

Chris

Hall of Fame Super Gold

Re: Cannot access 1131ag access point from 1801 Router

Your configuration snippet doesn't make sense.  You have a router, 1800.  Your configuration shows BOTH the router (you have Fastethernet 2) and the AP (BVI, SSID and Wireless).

Can you please post BOTH separately?

New Member

Re: Cannot access 1131ag access point from 1801 Router

Hi, sorry the device is a 1801W so has integrated wireless, so the config is correct

I can confirm I can see the AP using cdp neighbors from the 1801W

Below is a snippet of the config from the AP1131AG

dot11 ssid Wireless

authentication open

authentication key-management wpa

guest-mode

wpa-psk ascii 7 xxxxxxxxxxxxxxxxxxxxxx

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption mode ciphers tkip

!

ssid Wireless

!

station-role root

bridge-group 1

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

shutdown

no dfs band block

channel dfs

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 192.168.10.2 255.255.255.0

no ip route-cache

!

bridge 1 route ip

!

Re: Cannot access 1131ag access point from 1801 Router

The 1801's Fa2 is connected to the AP.
You see the neighbor using CDP
But you cannot PING?

You're saying the 1801 has 192.168.10.1 and the AP 192.168.10.2
Can you confirm that information doing a ''sh cdp neigh det''
And see if you can PING then?

Federico.

New Member

Re: Cannot access 1131ag access point from 1801 Router

Hi Federico,

Yes the AP is connected to the 1801W's Fa2 port

"sh cdp neighbours detail" shows the AP and the correct IP address (192.168.10.2)

When I try to ping 192.168.10.2 from the 1801W it doesn't work, also clients connected to the AP cannot pick up a DHCP address from the 1801W

Thanks
Chris

Re: Cannot access 1131ag access point from 1801 Router

Can you confirm the correct interfaces by posting the output of the ''sh cdp neigh det'' here?

Is there an ACL applied to the Fa2 interface on the 1801?


Federico.

New Member

Re: Cannot access 1131ag access point from 1801 Router

Hello Chris!

Maybe you can look at this configuration example.

http://www.cisco.com/en/US/partner/tech/tk722/tk809/technologies_configuration_example09186a0080665ceb.shtml

Greetings,

Marko

New Member

Re: Cannot access 1131ag access point from 1801 Router

Thanks for the link, the AP has suddenly kicked into life so seems like the config was ok after all.

956
Views
0
Helpful
9
Replies
CreatePlease to create content