Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Cannot access internet, ping PC with Cisco 871W

I am new to Cisco and am studying for my CCENT certification. At the moment, I am attempting to correctly configure a Cisco 871W lab router. Since I have undertaken this task, I have run into nothing but problems. First off it was finding that the previous owner had left a password on it, having to purchase a new USB to DB9 adapter to pass the "break" sequence to the router, and then resetting the router in ROM Monitor mode.

Now, I cannot seem to configure the router correctly, and am quite stumped.

My ISP is Charter (cable internet), and the home network that I am using consists of a Motorola SBV5122 Digital Voice Modem, Motorola SB6120 Cable modem, and, ideally, should also include my Cisco 871W router.

When I connect my router to the SB6120 Cable modem, the router receives an IP address via DHCP and the WAN indicator light turns on.

I have a VLAN configured on the 4 switchports of the router, and it is setep to act as a DHCP server. However, when I connect my PC to rhe router via Cat5e Crossover cable, I cannot access the internet. The router gives the PC an IP address, yet all attempts to ping the PC from the router fail.

Somehow, I can connect to the router via SSH though.

Furthermore, I can ping the 127.0.0.1 loopback address from my PC, but cannot do so from the router.

All in all, I am very confused, and would appreciate any help/insight on my situation. All that I would like to do is learn how to correctly configure this router to function as intended in my network situation, however, this is proving to be seemingly unsurmountable!

I have attached the config of my router along with both outputs and commands relating to my predicament.

ping of pc from router.bmp

Router ping of loopback.bmp

show vlan-switch brief.bmp

11 REPLIES
Hall of Fame Super Silver

Re: Cannot access internet, ping PC with Cisco 871W

Hello Peter,

in order to be able to access the internet from a PC connected downstream the router, you need to configure NAT, network address translation

Here are the commands that you need:

configure terminal

int vlan 1

desc the internal interface

ip nat inside

int fas4

desc WAN interface

ip nat outside

exit

access-list 11 permit 192.168.1.0 0.0.0.255

! the nat global statement is needed to instruct the router on how to translate

ip nat inside source list 11 interface fas4 overload

this will translate IP source addresses matching ACL 11 when a packet crosses from INSIDE To OUTSIDE interfaces and will put the FAs4 ip address in its place.

you can check NAT activity with

show ip nat translations

an entry should be created when the PC attempts to connect to the internet in show ip nat trans

Edit:

see this tutorial

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080094e77.shtml

Edit2:

Cisco routers has a different implentation of loopbacks so it is normal that it does not answer to ping to 127.0.0.1. Router TCP/IP stack is different.

You may need a static default route

check from the router shell if you can ping 8.8.8.8, if you can you are fine, otherwise you should add

config term

ip route 0.0.0.0 0.0.0.0 fas4

remember to save configuration after changes

exit

wr mem

or

copy running startup

Hope to help

Giuseppe

New Member

Cannot access internet, ping PC with Cisco 871W

Thank you to both of you, Giuseppe Larosa and cadet alain!

NAT configuration was next on my list, but I thought that I would be able to access the internet before configuring it, so it appeared to me as if something else was wrong. Now, it makes complete sense that NAT is needed so the PC can access the internet under the "guise" of the router's IP address, per say.

I do recall reading that loopback (127.0.0.1) was just for hosts, not Cisco devices. I've just been taking in so much inforation lately, that it is hard to retain it all!

I will make the changes to my configuration that you have posted, Giuseppe. However, first I want to make sure that I understand all of them, instead of just typing them in and not understanding why my router is now functioning as intended. On top of this, I also need to find a window of time to commandeer the internet and properly configure my router!

Thnaks again, and I will post back once I make these changes.

New Member

Re: Cannot access internet, ping PC with Cisco 871W

Okay, following the configuration of network address translation on my Cisco 871W, I am still unable to connect to the internet.

Furthermore, I did not see any entries under "show ip nat translations" following the configuration of NAT.

I was able to ping 8.8.8.8 from the router though.

On top of this, I was also wondering how am to know what I should configure the DNS Server ip address to, or is this unnecessary on the router, as the cable modem takes care of it?

Thank you all for sticking with me an helping me out!

Purple

Cannot access internet, ping PC with Cisco 871W

Hi,

try this, these are things  to change:

bridge irb

bridge 1

bridge 1 protocol ieee

bridge 1 route ip

!

interface Dot11Radio0

no ip address

ssid MainFlr WLAN

vlan 1

interface Dot11Radio0.1
encapsulation dot1Q 1 native
no cdp enable
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding

ip dhcp excluded-address 192.168.1.1
interface Vlan1
no ip address
bridge-group 1
bridge-group 1 spanning-disabled

interface BVI1

ip address 192.168.1.1 255.255.255.0

ip nat inside

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Re: Cannot access internet, ping PC with Cisco 871W

Thank you cadet alain.

Could you explain what the purpose of these commands are, and what they do, exactly?

I would appreciate it!

Edit:

I entered the commands that you specified, yet I am still unable to connect to the Internet, and am not sure what could be preventing this. Where should I be looking for the problem, and what information would be helpful to post to attempt to resolve this issue?

Purple

Cannot access internet, ping PC with Cisco 871W

Hi,

from where do you want to connect ?  I suppose from a machine in VLAN 1 ?

when you ping 8.8.8.8 from this machine what does show ip nat translation output ?

Can you also tell us more about this machine ? is this the only machine connected and is it wireless ?

Can you also post following:

-sh ip int br

and also ipconfig and arp -a on the machine

Regards.

Alain.

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Purple

Cannot access internet, ping PC with Cisco 871W

Hi,

not being able to ping the PC is due to PC firewall or Antivirus/Firewall, on Windows 7 your NIC must be in a Private network otherwise pings are blocked if you have a public profile.

For loopback 127.0.0.1 it is for hosts not for cisco routers which have no loopback ip address configured by default and it can be any address as long as it is configured on a Loopback interface.

Regards.

Alain.

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Cannot access internet, ping PC with Cisco 871W

routing service must be activated  (static or dynamic routing) if you want to connect the internet, because your PC/laptop using private IP address.

cheers

Regards, Habibi
New Member

Re: Cannot access internet, ping PC with Cisco 871W

Hi Alain,

Sorry for the delay in between my responses. It is just hard to find time to wetup the router and troubleshoot it all the time!

At the moment, I only have my laptop connected to the 871W, and I intend to connect through VLAN 1. As you can see in the Network Topology diagram that I threw together, there will be additional hosts, and a switch connected to the 871W, once the router is finally configured correctly.

My laptop is currently connected via ethernet, but I have tested the wireless on the router by connecting via my wireless card.

Of course, I still had no internet connectivity.

Network Topology:

Here is the ip nat translation output following a successful ping of 8.8.8.8:

Here is the show ip interface brief:

Here is the ipconfig from my laptop:

Here is the arp -a from my laptop:

Here is show adjadency FastEthernet 4(WAN port) from the 871W:

Here is show hosts all from the 871W:

I have not yet setup a type of routing for the 871W, so I would think that that would be the problem? At the moment, I reading about how to to setup static routing. Dynamic routing and default routing are next. However, I would just like to get this router up and running properly, so yhat I can practice commands, configuring ut, upgrading IOS's, etc, as I learn how to do those things.

Let me know if any more information is needed.

Thanks again for your help, Alain.

Purple

Cannot access internet, ping PC with Cisco 871W

Hi Peter,

1) there won't be any nat translation if you do a ping from the router as the source IP will be the WAN IP not the LAN IP

   so the empty output is normal.

2) your PC hasn't got a default-gateway configured so it won't go to the internet.

   if your router is a dhcp server then under the dhcp pool config you should configure: default-router 192.168.1.1

   if you have a static address on the PC then configure the default-gateway as 192.168.1.1

When you've done so then ping 8.8.8.8  from your PC and tell us if it is ok now.

Regards.

Alain.

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Cannot access internet, ping PC with Cisco 871W

I can now connect to the internet and feel inept, as I did not realize what the problem was, and how simple it was to fix.

Thank you very much for your help, Alain, this has been a learning experience, and I am all the more knowledgeable because of it.

1790
Views
24
Helpful
11
Replies
CreatePlease to create content