Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cannot connect WIC-1ENET to PPPoE ADSL

I have a verified connection on ADSL & my laptop connects fine using the supplied PPPoE credentials. The router does not connect using the WIC-1ENET or on board FastE. I'm continuously getting "Authentication Failed" even though we know the ID is correct. I've tried PAP, Chap, MS-Chap & MS-Chap V2. Debug PPP authentication shows the following message.

Jun 6 04:44:12: Vi3 PAP: Using hostname from interface PAP

Jun 6 04:44:12: Vi3 PAP: Using password from interface PAP

Jun 6 04:44:12: Vi3 PAP: O AUTH-REQ id 1 len 39 from "xxxxx"

RTR#

Jun 6 04:44:14: Vi3 PAP: I AUTH-ACK id 1 len 5

Jun 6 04:44:14: Vi3 PAP: I AUTH-REQ id 1 len 34 from "rback14.chcgil"

Jun 6 04:44:14: Vi3 PAP: Authenticating peer rback14.chcgil

Jun 6 04:44:14: Vi3 PPP: Sent PAP LOGIN Request

Jun 6 04:44:14: Vi3 PPP: Received LOGIN Response FAIL

Jun 6 04:44:14: Vi3 PAP: O AUTH-NAK id 1 len 26 msg is "Authentication failed"

RTR#

Jun 6 04:44:18: %DIALER-6-UNBIND: Interface Vi3 unbound from profile Di1

RTR#

Jun 6 04:44:18: %LINK-3-UPDOWN: Interface Virtual-Access3, changed state to down

Router config is as follows:

interface Ethernet0

no ip address

half-duplex

pppoe enable

pppoe-client dial-pool-number 1

no cdp enable

!

interface Dialer1

ip address negotiated

ip mtu 1492

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication pap

ppp pap sent-username xxxx password 7 xxxx

1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: Cannot connect WIC-1ENET to PPPoE ADSL

It looks like the PPP negotiation is failing with an outbound "Authentication failed".

Try removing 'ppp authentication pap' from your Dialer1 interface. This command tells the router to expect the aggregator to authenticate to it. The 'ppp pap sent-username' is sufficient for remote authentication.

You can also use pap and chap at the same time. The router will accept "ppp pap sent-username' in conjunction with "ppp chap hostname" and "ppp chap password"

4 REPLIES
Silver

Re: Cannot connect WIC-1ENET to PPPoE ADSL

MTU should be Manually configured,no autonegotiation feature Current Cisco IOS Software supports the WIC-1ENET only in Slot 0 of a Cisco 1700

Refer the Following link for more information

http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a0080093fbf.shtml#wic-1enetrest

New Member

Re: Cannot connect WIC-1ENET to PPPoE ADSL

Thank you for the reply. I did move the WIC-1ENET to slot 0 & the config still shows it in slot 1. ?? I'll try to force the WIC to half-duplex & 10mbs as well. Any other ideas? This is a simple DSL failover & it has proven very, very finicky & difficult to setup. Thanks again!

Silver

Re: Cannot connect WIC-1ENET to PPPoE ADSL

It looks like the PPP negotiation is failing with an outbound "Authentication failed".

Try removing 'ppp authentication pap' from your Dialer1 interface. This command tells the router to expect the aggregator to authenticate to it. The 'ppp pap sent-username' is sufficient for remote authentication.

You can also use pap and chap at the same time. The router will accept "ppp pap sent-username' in conjunction with "ppp chap hostname" and "ppp chap password"

New Member

Re: Cannot connect WIC-1ENET to PPPoE ADSL

Awesome advice! I removed the line ppp authentication pap & the DSL connected immediately! Strange, but it works! Thanks for the help.

458
Views
0
Helpful
4
Replies
CreatePlease login to create content