Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cannot see 2600 router through catalyst 2950 switch

Hello,

New to Cisco so please bare with me. I am having trouble  connecting the Cisco 2600 to the Catalyst 2950. All ports on switch are set to Vlan 1 and show status as being connected except those not connected to anything of course. However, Interface Fa0/1 is showing NOT connected with the router connected to it.

I have reset the switch:

flash_init

load_helper

boot

then i configure IP address and Gatewway, but still show status as "not connected"

 

Looking for a starting point please.

 

Much Appreciated,

Mark L

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Hi Mark,The fa0/0 connection

Hi Mark,

The fa0/0 connection has to go to the switch. They are both ethernet connections.

The T1/CSU/DSU is used mainly for older T1 modems, or CSU/DSU devices, which can break down up to 24 channels (in U.S. - in Europe its a little different at 30 channels). CSU/DSU connections were used a lot for phone lines, but they had the added benefit that you could stack a bunch of channels as data. So you could have say 384k of data, and a dozen phones running through it.

The bottom line is that the CSU card is not ethernet. Your switch is an ethernet only device, therefore it must connect to another ethernet connection.

On your router, you only have one ethernet connection which must be connected to the switch. If you need an ethernet connection to your Comcast (which is an ethernet connection off the back of the Comcast router), you will unfortunately need to get an ethernet card, which would go into the empty module next to your CSU card in the picture you sent. These cards are called network modules, and Cisco has a one port card (part number nm-1e I believe). They go as high as 4 ports for a 2600 router.

But:

The cheapest, but also more complicated way would be to set up a router-to-router connection using those CSU cards (you will only need a rolled T1 cable (I believe the pinouts on an RJ-45 are 1 to 4 and 2 to 5). This is exactly what I will be setting up in my lab. It only costs 1 cable vs. a $150 network module card. It will only be a 1.5MB connection, but it should work this way

 

So I will have 1 ethernet connection to comcast from the ethernet port on my router, then another from its CSU card to my second router's CSU card (with a rolled T1 cable), then out to my switch from that router's ethernet port.

 

Please let me know if this helps. Did you get the connection to the switch to work from the router's ethernet port?

18 REPLIES
New Member

1. Are the ports coming up

1. Are the ports coming up when you plug in the Ethernet cable? They should light up when you plug them in. Rule out a layer 1 issue first (it sounds like you already checked that though).

2. On the switch you should configure the port you plug in to, and the VLAN

int fa0/1

switchport

switchport mode access

switchport access vlan 1

no shut

exit

ip default-gateway 192.168.1.1

(if you are running at layer 3 of the switch, try these 5 lines instead of the above line)

ip routing

interface vlan1

ip address 192.168.1.2 255.255.255.0

exit

ip route 0.0.0.0 0.0.0.0 192.168.1.1

 

on the router:

interface gi0/0

ip address 192.168.1.1 255.255.255.0

no shut

 

I believe that should work. If you are running at layer 3 on both switch and router, they should be able to ping each other's IP addresses

 

New Member

John,thanks for the quick

John,

thanks for the quick reply! all ports that have an ethernet cable plugged in are up except for the first port Fa0/1 where the cable from the router (2600) in plugged in, no activity there.

 

I did run the commands previously, but ran them again, maybe this will help?....


SWITCH

Switch#
Switch#enable
Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#int fa0/1
Switch(config-if)#switchport
% Incomplete command.

Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 1
Switch(config-if)#no shut
Switch(config-if)#exit
Switch(config)#ip default-gateway 192.168.10.25
Switch(config)#


ROUTER


TestRouter1#show interfaces
FastEthernet0/0 is up, line protocol is up
  Hardware is AmdFE, address is 0012.7fec.7a60 (bia 0012.7fec.7a60)
  Internet address is 192.168.10.25/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:03, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/16/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 5000 bits/sec, 8 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     663358 packets input, 47934512 bytes
     Received 662373 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     11665 packets output, 1156544 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets

TestRouter1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
TestRouter1(config)#interface FastEthernet0/0
TestRouter1(config-if)#ip address 192.168.10.25 255.255.255.0
TestRouter1(config-if)#no shut
TestRouter1(config-if)#exit

 

thanks again

Mark

 

New Member

Hi Mark,Can you post the show

Hi Mark,

Can you post the show interface for the switch as well? On your router's show interface, it looks like you have data coming "into" the interface from the switch:

5 minute input rate 5000 bits/sec, 8 packets/sec

Nothing appears to be going out to the switch at the time you ran the test:

5 minute output rate 0 bits/sec, 0 packets/sec

But, it appears that some packets did go out at one time:

11665 packets output, 1156544 bytes, 0 underruns

 

on both router and switch, you can reset these counters (you don't have to be in config mode):

clear counters int fax/x

 

Your port appears to be good on the router, as it shows up/up full duplex, and 100mb

 

New Member

John,Thanks again for the

John,

Thanks again for the quick reply, and sorry for my late one, i need to create my own account ASAP.

When trying your suggestion for switching the port to trunk i keep receiving the following error...

TestSwitch1(config)#interface FastEthernet0/1
TestSwitch1(config-if)#switchport trunk encapsulation dot1q
                                        ^
% Invalid input detected at '^' marker.

also tried using interface fa0/1 which yielded the same result

 

here is what i have from the switch interfaces......


Vlan1 is up, line protocol is up
  Hardware is CPU Interface, address is 0018.18d0.1b40 (bia 0018.18d0.1b40)
  Internet address is 192.168.10.26/24
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 2000 bits/sec, 2 packets/sec
  5 minute output rate 5000 bits/sec, 1 packets/sec
     180946 packets input, 23209310 bytes, 0 no buffer
     Received 115236 broadcasts (0 IP multicast)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 83 ignored
     75175 packets output, 46426014 bytes, 0 underruns
     0 output errors, 2 interface resets
     0 output buffer failures, 0 output buffers swapped out

 

Finally, can you tell me what part stood out as being in Layer3 mode rather than layer2?

 

I appreciate your patience with the new guy, im learning a lot from this site.

 

Mark

 

 

 

New Member

maybe i should reset configs

maybe i should reset configs on both devices and start over?

New Member

Hi Mark,Sorry, I have a 3750

Hi Mark,

Sorry, I have a 3750 in the lab, so the commands may be slightly different. It almost sounds like you have an IP address on the switch's port, or that it is set up as an access port. You might try removing the port as a switchport and adding it back in (this should clear all the configs from the port) and then turning the port into a trunk before putting in the commands from the previous post. It may need to be set up as a trunk port first:

no switchport

switchport

switchport mode trunk

(On your model switch, it may be switchport trunk vs. switchport mode trunk)

At any point you can put in a command followed by the ? and it should show you the options:

switchport ?

or

switchport mode ?

 

You could reset the configs if that is easier, but the switch may set the ports as access ports. You may still need to turn fa0/1 into a trunk port.

As for the layer 3 vs. layer 2 modes, what stood out was that the ip default-gateway that you used, is used for layer two devices. Had you used 'IP routing' and then the IP route 0.0.0.0 0.0.0.0 192.168.10.25, those commands are layer 3 commands.

The IP routing command enables layer 3 on the switch, and if not in the configs, it would be layer 2

Hope this helps, and please let me know if you have success!!

New Member

John,I was able to get the

John,

I was able to get the ports configured but it still looks like port 1 on the switch not connected. can you confirm this looks OK? here is the ports status and running config  of each device....


TestSwitch1#show interfaces status

Port      Name               Status       Vlan       Duplex  Speed Type
Fa0/1                        notconnect   1            auto   auto 10/100BaseTX
Fa0/2                        connected    1          a-full  a-100 10/100BaseTX
Fa0/3                        connected    1          a-full  a-100 10/100BaseTX
Fa0/4                        notconnect   1            auto   auto 10/100BaseTX
Fa0/5                        notconnect   1            auto   auto 10/100BaseTX
Fa0/6                        notconnect   1            auto   auto 10/100BaseTX
Fa0/7                        notconnect   1            auto   auto 10/100BaseTX
Fa0/8                        notconnect   1            auto   auto 10/100BaseTX
Fa0/9                        notconnect   1            auto   auto 10/100BaseTX
Fa0/10                       notconnect   1            auto   auto 10/100BaseTX
Fa0/11                       notconnect   1            auto   auto 10/100BaseTX
Fa0/12                       notconnect   1            auto   auto 10/100BaseTX
Fa0/13                       notconnect   1            auto   auto 10/100BaseTX
Fa0/14                       notconnect   1            auto   auto 10/100BaseTX
Fa0/15                       notconnect   1            auto   auto 10/100BaseTX
Fa0/16                       notconnect   1            auto   auto 10/100BaseTX
Fa0/17                       notconnect   1            auto   auto 10/100BaseTX
Fa0/18                       notconnect   1            auto   auto 10/100BaseTX
Fa0/19                       notconnect   1            auto   auto 10/100BaseTX
Fa0/20                       notconnect   1            auto   auto 10/100BaseTX
Fa0/21                       notconnect   1            auto   auto 10/100BaseTX


TestSwitch1#show running-config
Building configuration...

Current configuration : 1329 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname TestSwitch1
!
enable secret 5 $1$fRM6$.58.4aG4xA8NJGJ5GHA.h.
enable password test123
!
ip subnet-zero
!
ip ssh time-out 120
ip ssh authentication-retries 3
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
 switchport mode trunk
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
 ip address 192.168.10.26 255.255.255.0
 no ip route-cache


TestRouter1#show interfaces
FastEthernet0/0 is up, line protocol is up
  Hardware is AmdFE, address is 0012.7fec.7a60 (bia 0012.7fec.7a60)
  Internet address is 192.168.10.25/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:02, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/10/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 5000 bits/sec, 9 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     21866 packets input, 1527820 bytes
     Received 21834 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     267 packets output, 27588 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets

 


TestRouter1#show running-config
Building configuration...

Current configuration : 964 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname TestRouter1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$ar88$uUxzlP7H.KJhZiqM5.z7O/
!
no aaa new-model
!
resource policy
!
no network-clock-participate slot 1
no network-clock-participate wic 0
ip subnet-zero
ip cef
!
!
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.10.25 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 encapsulation dot1Q 1 native
 no snmp trap link-status

 

This equipment is a cisco test package we purchased from Ebay, hoping its not bad

New Member

Ok, there are several things

Ok, there are several things that look like they are in need of change. First and most important is that the interface is indeed down on the switch, and having the status 'notconnect' means that the cable is bad, or the port is bad, or it is not connected at all. Since your router interface is up, but the switch port is not connected, I would verify that the cable is going to the correct port. Second, if you have not tried a different ethernet cable on port fa0/1, then I would try that next. Make sure it is a straight-thru ethernet cable. Lastly, you can try a different port as your uplink port as a last resort. It is odd that the router interface shows as up but the switch shows as not connected, so get your layer one checked first. My suspicion is that the router interface is plugged into somewhere else

Next, it appears that you are trying to assign an IP address to VLAN 1 on the switch. This is fine if you plan to manage the switch by ssh into it. But if you do this, you will need to put in the default gateway again so the switch knows where to go to get out to the Internet:

Switch

ip default-gateway 192.168.10.25

Next on the switch is to set the encapsulation to dot1q on port fa0/1. Currently, you have correctly set port fa0/1 as a trunk port, but the rest of the configs are not in there:

switch:

interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1

 

On the router, you have an IP in there, but it needs to be on the VLAN 1 sub-interface you have built, so we need to remove it from the main interface, and apply it to the sub-interface

Router:

interface FastEthernet0/0

no ip address

interface FastEthernet0/0.1

ip address 192.168.10.25 255.255.255.0

 

You can also verify your interfaces on the switch

show int fa0/1

It should look much like the router interface you posted

 

Let me know how it looks after you have a chance to check these

New Member

Oh boy this is getting tough,

Oh boy this is getting tough, but at least there will be some takeaway from this.

So, i followed everything you posted and i had to transpose a couple of things since i learned that the 2950 supports 802.1Q trunking.

I did try a few cables before posting here, all straight thrus. Network connection goes into 2600 routers yellow FastEthernet port, from router T1/DSU/CSU port to switches first port on front fa0/1....sound right?

TestRouter1#show int f0/0.1
FastEthernet0/0.1 is up, line protocol is up
  Hardware is AmdFE, address is 0012.7fec.7a60 (bia 0012.7fec.7a60)
  Internet address is 192.168.10.25/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  1.
  ARP type: ARPA, ARP Timeout 04:00:00
  Last clearing of "show interface" counters never

TestSwitch1#show int fa0/1
FastEthernet0/1 is down, line protocol is down (notconnect)
  Hardware is Fast Ethernet, address is 0018.18d0.1b41 (bia 0018.18d0.1b41)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Auto-duplex, Auto-speed, media type is 100BaseTX
  input flow-control is unsupported output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 01:51:39, output 01:51:15, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     313 packets input, 33432 bytes, 0 no buffer
     Received 48 broadcasts (48 multicast)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 48 multicast, 0 pause input
     0 input packets with dribble condition detected
     5473 packets output, 477944 bytes, 0 underruns

 

now, i have 3 of these routers as well as 3 of these switches which are doing the same which tells me i'm doing something way way wrong.

 

New Member

Hi Mark,Am I reading

Hi Mark,

Am I reading correctly that the router's T1 port is connected to the switch?

"Network connection goes into 2600 routers yellow FastEthernet port, from router T1/DSU/CSU port to switches first port on front fa0/1....sound right?"

On the router, you have an fa0/0 and an fa0/1 port - fa0/0 on the router should go to the switch on port fa0/1

The router T1/DSU/CSU port would go to a T1 device (CSU/DSU device, which has 24 channels and is 1.544 MB in the U.S.)

If you hook up your router to an external network connection (such as your Comcast modem), it would need to be plugged into fa0/1 on your router - not the T1 card.

I have T1/CSU/DSU cards in my lab, and I can plug both routers into their T1 cards (special cable needed), but they are a different protocol than the ethernet connection on your switch.

 

Let me know if this is the issue!! I think we're getting close!!

New Member

John,This is in fact how the

John,

This is in fact how the cables were labeled to be set up when shipped to me (Maybe another test?) but on the back of the 2600 router there is only a FastEthernet F0/0, Console, and AUX ports aside from the 2 T1/DSU ports.

Sorry again, im new to this.

 

Mark

New Member

(No subject)

 

There is only 1 Ethernet port, i imagine then it would have to be configured differently?

 

New Member

Hi Mark,The fa0/0 connection

Hi Mark,

The fa0/0 connection has to go to the switch. They are both ethernet connections.

The T1/CSU/DSU is used mainly for older T1 modems, or CSU/DSU devices, which can break down up to 24 channels (in U.S. - in Europe its a little different at 30 channels). CSU/DSU connections were used a lot for phone lines, but they had the added benefit that you could stack a bunch of channels as data. So you could have say 384k of data, and a dozen phones running through it.

The bottom line is that the CSU card is not ethernet. Your switch is an ethernet only device, therefore it must connect to another ethernet connection.

On your router, you only have one ethernet connection which must be connected to the switch. If you need an ethernet connection to your Comcast (which is an ethernet connection off the back of the Comcast router), you will unfortunately need to get an ethernet card, which would go into the empty module next to your CSU card in the picture you sent. These cards are called network modules, and Cisco has a one port card (part number nm-1e I believe). They go as high as 4 ports for a 2600 router.

But:

The cheapest, but also more complicated way would be to set up a router-to-router connection using those CSU cards (you will only need a rolled T1 cable (I believe the pinouts on an RJ-45 are 1 to 4 and 2 to 5). This is exactly what I will be setting up in my lab. It only costs 1 cable vs. a $150 network module card. It will only be a 1.5MB connection, but it should work this way

 

So I will have 1 ethernet connection to comcast from the ethernet port on my router, then another from its CSU card to my second router's CSU card (with a rolled T1 cable), then out to my switch from that router's ethernet port.

 

Please let me know if this helps. Did you get the connection to the switch to work from the router's ethernet port?

New Member

Thanks for all the help and

Thanks for all the help and sticking with me John,

I had a feeling this was the issue and had these ports connected as described, i guess that this test system is really kind of "ClosedLoop" in that it cannot be configured to connect the internet then until i acquire the additional ethernet module?

New Member

You're Welcome Mark! Glad to

You're Welcome Mark! Glad to hear that it is working.

If you get (or make) a rolled T1 cable, you can connect two of your routers to each other's T1 ports, and on router 1's ethernet port can connect to the Internet connection, while the other router goes to your switch as you have it set up now. This will require some configuring, but is cheaper than buying a card.

 

I am including a drawing to help show what I mean.

Good Luck!!

New Member

There is an easier way:Create

There is an easier way:

Create a seperate Internet VLAN on your switch (assuming vlan 1 is your plain data VLAN): e.g. vlan999.

Setup fa0/24 as follows:

 

int fa0/24

 description ** Internet **

 switchport mode access

 switchport access vlan 999

 spanning-tree portfast

!

Create a trunk port for the router

int fa0/23

 switchport mode trunk

!

Setup a trunk port on the router:

int fa0/0

 no ip address

!

fa0/0.1

 encapsulation dot1q 1 native

 ip address 192.168.1.1 255.255.255.0

 ip nat inside

!

int fa 0/0.99

 encapsulation dot1q 99
 ip address DHCP

 ip nat outside

!

Setup NAT

ip nat inside source NAT-ACL interface fa0/0.99 overload

ip access-list extended NAT-ACL

 10 permit ip 192.168.1.0 0.0.0.255 any

!

 

What this solves is your lack of ethernet ports on your router by using some of your switch ports.

New Member

i did get the network

i did get the network connection working from routers eth port to the switch and can ping the router

New Member

Oops - very sorry that I

Oops - very sorry that I missed this, but it didn't hit me until the drive home. I just verified that this works from my lab.

The issue is that your switch is running as a layer 2 device, so if you are going to layer 3 from layer 2, it has to have an IP that it can get to on that VLAN at layer 3. Hence you need to configure your uplink to the router as a trunk port, not a switchport on the switch. And you need to configure the VLAN on the router using a sub-interface and VLAN ID of 1. Hope this makes sense....

Here are the configs

Switch

interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1
 switchport mode trunk

no ip default-gateway 192.168.10.25

your other interfaces would be access ports and vlan 1, or just access if you have no other vlans

interface FastEthernet0/3
 switchport mode access

 

On the router, you configure the sub-interface and vlan info as follows:

interface FastEthernet0/0.1
 encapsulation dot1Q 1 native
 ip address 192.168.10.25 255.255.255.0

 

if you decide to add another VLAN later, just put in:

interface fa0/0.5

encapsulation dot1q 5

ip address 192.168.5.1 255.255.255.0

and on the switch you simply modify your trunk port line

interface FastEthernet0/1
  switchport trunk allowed vlan 1, 5

then assign access ports to VLAN 5 as needed

 

Hope this helps and sorry for the other post - please disregard

 

p.s. As a security precaution, it is good practice to not use VLAN 1 - many places I've worked at do not use it, and instead use other VLANs. They shut down VLAN 1.

315
Views
25
Helpful
18
Replies
CreatePlease login to create content