Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Bronze

Cat0-3750 upgrade. Error: system number 1 does not support the same feature

I am trying to upgrade or rather downgrade from ipadvservices (inadvertently upgraded to) to ipservices on a stack of Cat-3750s, but I get the following error message:

Ios Image File Size: 0x00877A00

Total Image File Size: 0x00B04200

Minimum Dram required: 0x08000000

Image Suffix: ipservicesk9-122-37.SE1

Image Directory: c3750-ipservicesk9-mz.122-37.SE1

Image Name: c3750-ipservicesk9-mz.122-37.SE1.bin

Image Feature: IP|LAYER_3|PLUS|SSH|3DES|MIN_DRAM_MEG=128

Error: The image in the archive which would be used to upgrade

Error: system number 1 does not support the same feature set.

Any ideas?

Chris

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Cat0-3750 upgrade. Error: system number 1 does not support the s

Great!

Thanks you saved my day.

15 REPLIES
Bronze

Re: Cat0-3750 upgrade. Error: system number 1 does not support t

Just figured it out.

I just got this error message while upgrading a Cisco Catalyst 3560 from 12.2(35)SE5 to 12.2(44)SE. The older version was IP BASE and the new version is ADVANCED IP SERVICES.

It seems that Cisco has added a check into there upgrade process to prevent you from accidentally changing the feature set during an IOS upgrade. This is a really nice sanity check since changing feature sets on a production switch could really ruin your day.

To bypass this check, add the /allow-feature-upgrade parameter to the archive download-sw command. According to the documentation, this feature is new as of 12.2(35).

Tx to http://slaptijack.com/networking/gotcha-upgrading-catalyst-to-new-feature-set/

for pointing me in the right direction on this!

ChrisO

New Member

Cat0-3750 upgrade. Error: system number 1 does not support the s

4 years later, googling for "

The image in the archive which would be used to upgrade system number 1 does not support the same feature set" brings up this thread first, and has exactly the answer I needed.  Thanks

New Member

Thanks!

Thanks!

New Member

Cat0-3750 upgrade. Error: system number 1 does not support the s

I have the same problem, however it didn't work for me.

archive download-sw /allow-feature-upgrade /overwrite tftp://10.70.39.40/c3750-ipbasek9-tar.122-46.SE.tar

Loading c3750-ipbasek9-tar.122-46.SE.tar from 10.70.39.40 (via Vlan240): !!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
examining image...
extracting info (105 bytes)
extracting c3750-ipbasek9-mz.122-46.SE/info (611 bytes)
extracting info (105 bytes)

Stacking Version Number: 1.40

System Type:             0x00000000
  Ios Image File Size:   0x008C7A00
  Total Image File Size: 0x00B4CA00
  Minimum Dram required: 0x08000000
  Image Suffix:          ipbasek9-122-46.SE
  Image Directory:       c3750-ipbasek9-mz.122-46.SE
  Image Name:            c3750-ipbasek9-mz.122-46.SE.bin
  Image Feature:         IP|LAYER_3|SSH|3DES|MIN_DRAM_MEG=128


Error: The image in the archive which would be used to upgrade
Error: system number 1 does not support that system type.

Cisco Employee

I was having the same issue

I was having the same issue even with entering the following:

archive download-sw /overwrite /allow-feature-upgrade tftp://172.18.108.26/c3kx-sm10g-tar.150-2.SE7.tar

I noticed the image which was running on the switch was correct without the ".bin" at the end:

3560#sh ver | i image
System image file is "flash:c3560e-universalk9-mz.150-2.SE7"

I uploaded a fresh IOS image from CCO and made sure the image name had ".bin" at the end. Seems trivial except the error is produced through a sanity check. See below (please excuse the extra unplugging in the output):

3560#sh ver | i image
System image file is "flash:c3560e-universalk9-mz.150-2.SE7.bin"

3560#$de tftp://172.18.108.26/c3kx-sm10g-tar.150-2.SE7.tar
Loading c3kx-sm10g-tar.150-2.SE7.tar from 172.18.108.26 (via Vlan1): !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!                             !!!!!!!!!
Mar 30 01:33:35.480: %USBFLASH-5-CHANGE: usbflash0 has been removed!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Mar 30 01:34:15.636: %PLATFORM_ENV-1-FRU_PS_ACCESS: FRU Power Supply is not responding!!!!!!!!!!!
[OK - 24893440 bytes]

Loading c3kx-sm10g-tar.150-2.SE7.tar from 172.18.108.26 (via Vlan1): !!!
Mar 30 01:34:35.593: %PLATFORM_ENV-6-FRU_PS_OIR: FRU Power Supply 2 removed!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!                             !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
examining image...
extracting info (100 bytes)
extracting c3kx-sm10g-mz.150-2.SE7/info (499 bytes)
extracting info (100 bytes)

System Type:             0x00010002
  Ios Image File Size:   0x017BDA00
  Total Image File Size: 0x017BDA00
  Minimum Dram required: 0x08000000
  Image Suffix:          sm10g-150-2.SE7
  Image Directory:       c3kx-sm10g-mz.150-2.SE7
  Image Name:            c3kx-sm10g-mz.150-2.SE7.bin
  Image Feature:         IP|LAYER_3|MIN_DRAM_MEG=128
  FRU Module Version:    03.00.78


Updating FRU Module on switch 1...
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Updating FRU FPGA image...

FPGA image update complete.

All software images installed.

 

Worked for me, hope this helps.

 

New Member

Again, 6 years out this was

Again, 6 years out this was the fix again.  In my case my ipbase licensed 3750X switches came with the universal IOS code, but my licensing level only allows me to download the ipbase software.  Using this parameter seems to have fixed the issue for me.

New Member

Glad I found this, 6 years

Glad I found this, 6 years out as well, still the perfect answer on the first google search.  Nice job :)

New Member

Worked for me too!

Worked for me too!

New Member

Worked for me, too.Thanks for

Worked for me, too.

Thanks for the fix, cogden!!

New Member

Worked for me too upgrading a

Worked for me too upgrading a 3750g and 3750e mixed stack from 12..2(58)SE2 to 12.2(55)SE9 ..... yes that's an upgrade :p

 

The 3750e's were permenant license going to ipbase

New Member

Thanks for the tip. It have

Thanks for the tip. It have worked perfectly on my 3750x .

Regards,

Nicolas

New Member

I am going to try that "

I am going to try that "/allow-feature-upgrade" command-line switch (no pun intended).  Thanks for posting!  But what drives me nuts is, Cisco's web site (which is a great site by the way), when I select the exact model number of the switch, and I download the software from their site for this switch (which has the ipbase feature set), and I download the ipbase feature set, and then it tells me it is not supported.... what???  I sometimes wonder if they are trying to make it impossible to save money by not getting SMARTnet renewals and/or making it impossible to do this stuff on my own unless I am a triple-CCIE. Cheers!

Flux-

New Member

Cat0-3750 upgrade. Error: system number 1 does not support the s

I googled also and found on the first hit this thread.

Thank you for help.

New Member

Cat0-3750 upgrade. Error: system number 1 does not support the s

Yeap, the same with me, thank you cogden for this tip

New Member

Cat0-3750 upgrade. Error: system number 1 does not support the s

Great!

Thanks you saved my day.

13884
Views
80
Helpful
15
Replies
CreatePlease login to create content