Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

CATOS to IOS Layer-3 Etherchannel

Hello,

I am trying to configure a Layer-3 etherchannel between a 6500 running CATOS (with MSFC Layer-3 card) and a 6500 IOS device.

IOS:

interface Port-channel2

description G7/1 & G7/2 Ether to HAVC6501 7/1 & 7/2

no switchport

ip address 10.5.3.177 255.255.255.252

!

interface GigabitEthernet7/1

description <cct ID> HAVC6501 G7/1 to Corporate Core

no switchport

channel-group 2 mode active

!

interface GigabitEthernet7/2

description <cct ID> HAVC6501 G7/2 to Corporate Core

no switchport

channel-group 2 mode active

!

CATOS:

set channelprotocol lacp 7

!

set vlan 403 7/1-2

set port lacp-channel 7/1-2 mode active

!

MSFC (IOS):

!

int vlan 403

Description /30_VLAN_to_HAVAGG_X650_01C_Po2

ip address 10.5.3.178 255.255.255.252

!

It works fine when its just a Layer-2 etherchannel at each end, but I can't get the Layer-3 working. Can anyone advise what is wrong, or how this should be configured?

Thanks

Phil

2 REPLIES
Hall of Fame Super Blue

Re: CATOS to IOS Layer-3 Etherchannel

Phil

There is nothing wrong as such but unfortunately CatOS only supports L2 etherchanneling and not L3 so a switch in hybrid mode is limited to L2 etherchannels only.

Jon

New Member

Re: CATOS to IOS Layer-3 Etherchannel

I was hoping that wasn't the answer!.... I suppose the below may work instead?

6500 IOS

G7/1

descr To CATOS_6500_7/1

no sw

ip address 10.0.0.1 255.255.255.252

ip load-sharing per-packet

!

G7/2

descr To CATOS_6500_7/2

no sw

ip address 10.1.0.1 255.255.255.252

ip load-sharing per-packet

!

6500 CATOS:

set vlan 403 7/1

set vlan 404 7/2

!

6500 MSFC:

interface vlan 403

descr To Ports_7/1

ip addres 10.0.0.2 255.255.255.252

ip load-sharing per-packet

!

interface vlan 404

descr To Ports_7/2

ip address 10.1.0.2 255.255.255.252

ip load-sharing per-packet

!

Thanks

Phil

309
Views
0
Helpful
2
Replies
CreatePlease to create content