Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CBWFQ : Can be enabled as an output feature only

Dear support,

I have configured a QoS policy, but am unable to apply it to an interface. (have had to apply it as output service-policy)

The following statement is produced if I try to apply the service-policy to the inbound interface;

CBWFQ : Can be enabled as an output feature only

Can anyone help me as I seem to be digging a hole. (all I want to do ensure 50% of the bandwidth is reserved for voice, that is already mark with the dscp value of 'cs5' via the third party phone.

Thanks in advance,

Regards, Adrian

Thanks in advance

5 REPLIES

Re: CBWFQ : Can be enabled as an output feature only

Hi Adrian,

your policy looks somewhat like this:

class-map VoIP

match ip dscp cs5

policy-map Out

class-map VoIP

priority percent 50

class class-default

fair-queue

random-detect

interface Serial0/0

service-policy output Out

Well this means you enable Class Based Weighted Fair Queueing (CBWFQ), or better Low-Latency Queueing (LLQ), which is an output ONLY feature on standard routers. So IOS tells you that it can not be applied inbound.

Make sure to use the "priority percent" command and not "bandwidth percent" as the latter does not guarantee lowest delay.

Regards

Martin

New Member

Re: CBWFQ : Can be enabled as an output feature only

Hi Martin,

Many thanks for your response.

I have several site routers, all 2621 xm's that have are connected via fa0/1 to LAN and fa0/0 with sub interfaces to the wan (have a 2Mbps connection to the HQ site).

If I try to apply the service-policy to the sub int, I get the following;

CBWFQ : Not supported on subinterfaces

I have the following config (obviously trimmed down).

(it seems to work, as tested with large transfer, but being a qos novice, I am not completely sure i've done the config right).

Thanks again, regards, adrian.

!

class-map match-all BULK-DATA

match ip dscp af11 af12

class-map match-all INTERACTIVE-VIDEO

match ip dscp af41 af42

class-map match-all VOICE

match ip dscp cs5

class-map match-all MISSION-CRITICAL-DATA

match ip dscp 25

class-map match-all ROUTING

match ip dscp cs6

class-map match-all SCAVENGER

match ip dscp cs1

class-map match-all NET-MGMT

match ip dscp cs2

class-map match-any CALL-SIGNALING

match ip dscp cs3

match ip dscp af31

class-map match-all TRANSACTIONAL-DATA

match ip dscp af21 af22

!

!

policy-map BRANCH-WAN-EDGE

class VOICE

priority percent 50

class INTERACTIVE-VIDEO

priority percent 2

class CALL-SIGNALING

bandwidth percent 5

class ROUTING

bandwidth percent 3

class NET-MGMT

bandwidth percent 2

class MISSION-CRITICAL-DATA

bandwidth percent 5

random-detect

class TRANSACTIONAL-DATA

bandwidth percent 2

random-detect dscp-based

class BULK-DATA

bandwidth percent 2

random-detect dscp-based

class SCAVENGER

bandwidth percent 1

class class-default

bandwidth percent 3

random-detect

!

!

!

interface FastEthernet0/0

no ip address

no ip split-horizon eigrp 100

duplex full

speed 10

no mop enabled

!

interface FastEthernet0/0.1106

description *** primary wan connection ***

bandwidth 2000

encapsulation dot1Q 1106

ip address 172.16.31.34 255.255.255.252

no ip redirects

ip bandwidth-percent eigrp 100 90

rate-limit output 2000000 2000000 2000000 conform-action transmit exceed-action

drop

!

interface FastEthernet0/0.1116

description *** backup wan connection ***

bandwidth 1999

encapsulation dot1Q 1116

ip address 172.16.32.34 255.255.255.252

no ip redirects

ip bandwidth-percent eigrp 100 90

rate-limit output 2000000 2000000 2000000 conform-action transmit exceed-action

drop

!

interface FastEthernet0/1

description Connection to LAN

service-policy output BRANCH-WAN-EDGE

======================================

Re: CBWFQ : Can be enabled as an output feature only

Oh, that gives a different picture.

Well you do NOT do the right thing now.

Applying the policy BRANCH-WAN-EDGE to F0/1 does not do anything. Queueing - as activated by "priority" or "bandwidth" in the policy - will only be invoked when your interface is overloaded. This will never happen in your setup, i.e. when feeding a FE with only 4 MBit.

So what you need is a so called nested policy. Try this:

policy-map Shaper

class class-default

shape 1984000

service-policy output BRANCH-WAN-EDGE

interface FastEthernet0/0.1106

description *** primary wan connection ***

bandwidth 2000

encapsulation dot1Q 1106

ip address 172.16.31.34 255.255.255.252

no ip redirects

ip bandwidth-percent eigrp 100 90

service-policy output Shaper

!

interface FastEthernet0/0.1116

description *** backup wan connection ***

bandwidth 1999

encapsulation dot1Q 1116

ip address 172.16.32.34 255.255.255.252

no ip redirects

ip bandwidth-percent eigrp 100 90

service-policy output Shaper

REMOVE the rate-limit statements (they are policing your traffic, which is NOT what you want). remove the service-policy from F0/1 there is no effect of it (other than to confuse people).

What that will do: limit all traffic through FastEthernet0/0.1106 to 2 MBit/s and guarantee out of these 2 MBit/s 50% to voip etc if requested.

Regards

Martin

New Member

Re: CBWFQ : Can be enabled as an output feature only

Hi Martin,

Many thanks again for your assistance, I think muddled my way through and come up with the following as per your example.

policy-map Shaper

class class-default

shape average 1984000

service-policy BRANCH-WAN-EDGE

!

interface FastEthernet0/0.1106

service-policy output Shaper

!

interface FastEthernet0/0.1116

service-policy output Shaper

i'm not sure if i need the shape average or shape peak command (look the same)

shape ?

adaptive Enable Traffic Shaping adaptation to BECN

average configure token bucket: CIR (bps) [Bc (bits) [Be (bits)]],

send out Bc only per interval

fecn-adapt Enable Traffic Shaping reflection of FECN as BECN

fr-voice-adapt Enable rate adjustment depending on voice presence

max-buffers Set Maximum Buffer Limit

peak configure token bucket: CIR (bps) [Bc (bits) [Be (bits)]],

send out Bc+Be per interval

but think it looks ok? (are buffers set ok?)

sh policy-map

Policy Map Shaper

Class class-default

Traffic Shaping

Average Rate Traffic Shaping

CIR 1984000 (bps) Max. Buffers Limit 1000 (Packets)

service-policy BRANCH-WAN-EDGE

many thanks for your help.

regards, adrian.

New Member

Re: CBWFQ : Can be enabled as an output feature only

Hi Martin,

Sorry, last question (I have the QoS study guide on order)

on the HQ site (or one of the two), how should the policy be set?

Each HQ site has a LES 10 rather than a 2Mbps connection.

All spoke-to-spoke traffic goes via one of the hub sites.

please see extract below;

interface FastEthernet1/0

no ip address

speed 10

full-duplex

!

!

interface FastEthernet1/0.1100

description **

bandwidth 1999

!

interface FastEthernet1/0.1111

description ***

bandwidth 1999

!

interface FastEthernet1/0.1113

description **

bandwidth 1999

!

interface FastEthernet1/0.1114

description ***

bandwidth 1999

!

interface FastEthernet1/0.1115

description ***

bandwidth 1999

!

interface FastEthernet1/0.1116

description ***

bandwidth 1999

encapsulation dot1Q 1116

ip address 172.16.32.33 255.255.255.252

no ip redirects

ip bandwidth-percent eigrp 100 90

rate-limit output 2000000 2000000 2000000 conform-action transmit exceed-action drop

do i need a separate policy-map for each sub-int or can it been done with a single one?

thanks again, regards adrian.

3340
Views
7
Helpful
5
Replies
CreatePlease to create content