Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

[CBWFQ - Insufficient bandwidth]

Hi

I'm unable to apply the service-policy to the interface with the config below.

majormatic-pta-mount(config-if)#service-policy output CE-OUTPUT
Insufficient bandwidth 1024 kbps for the bandwidth guarantee (512)

majormatic-pta-mountgrace-mi-ce#sh controllers Serial0/1/0
Interface Serial0/1/0
Hardware is GT96K
DTE V.11 (X.21) TX and RX clocks detected.


interface Serial0/1/0
description Link to xxxx
bandwidth 1024
ip address x.x.x.x
ip access-group 101 in
ip access-group 101 out
no ip redirects
no ip proxy-arp
ip flow ingress
no ip mroute-cache
load-interval 30
down-when-looped
no cdp enable
max-reserved-bandwidth 100
end

policy-map CE-OUTPUT
class CE-OUTPUT-PLATINUM
    bandwidth 256
     random-detect dscp-based
class CE-OUTPUT-GOLD
    bandwidth 256
     random-detect dscp-based
class CE-OUTPUT-SILVER
    bandwidth 512
     random-detect dscp-based

Regards,

Werner

4 REPLIES

Re: [CBWFQ - Insufficient bandwidth]

I think you will have to leave a minimum of 64k for the default class even though it is not defined

So you will have to redo the bandwidth allocations so that you leave atleast 64k for the default BW class something like

policy-map CE-OUTPUT
class CE-OUTPUT-PLATINUM
    bandwidth 192
     random-detect dscp-based
class CE-OUTPUT-GOLD
    bandwidth 256
     random-detect dscp-based
class CE-OUTPUT-SILVER
    bandwidth 512
     random-detect dscp-based

Try this and let us know

HTH

Narayan

New Member

Re: [CBWFQ - Insufficient bandwidth]

Hi Narayan

I'm able to apply the same config on a different 2801 routers, looks like it's IOS dependant.

Example:

interface Serial0/3/0
description Link to xxxx
bandwidth 256
ip address x.x.x.x.
no ip redirects
no ip proxy-arp
ip route-cache flow
no ip mroute-cache
load-interval 30
down-when-looped
no cdp enable
max-reserved-bandwidth 100
service-policy output CE-OUTPUT
end

policy-map CE-OUTPUT
class CE-OUTPUT-PLATINUM
  bandwidth 64
  random-detect dscp-based
class CE-OUTPUT-GOLD
  bandwidth 64
  random-detect dscp-based
class CE-OUTPUT-SILVER
  bandwidth 128
  random-detect dscp-based

I had a look at the output of sh policy-map interface x

Router that requires extra 64K for default-class:

Class-map: class-default (match-any)
      787 packets, 94518 bytes
      30 second offered rate 0 bps, drop rate 0 bps
      Match: any

      queue limit 64 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 787/51931

Router that doesn't require extra 64K for default-class:

Class-map: class-default (match-any)
      2000 packets, 112873 bytes
      30 second offered rate 0 bps, drop rate 0 bps
      Match: any

Thanks for your help!

Regards,

Werner

Cisco Employee

Re: [CBWFQ - Insufficient bandwidth]

Hi Werner,

I think that's because of one of the router is running HQF model. With HQF model, class-default has minimal 1% of interface bandwidth; before HQF, class-default doesn't have pre-assigned bandwidth. The IOS starts using HQF model from 12.4(20)T. Also the 64 is queue limit, or you can consider it is the depth of this queue.

http://www.cisco.com/en/US/prod/collateral/iosswrel/ps6537/ps6558/white_paper_c11-481499.html

HTH,

Lei Tian

New Member

[CBWFQ - Insufficient bandwidth]

Thank you Lei..The linked helped me trouble shoot an issue with my customer after we did an IOS upgrade from pre- HQF version to 12.4(24) version.

11400
Views
4
Helpful
4
Replies
CreatePlease login to create content