Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CBWQ and interface bandwidth

Hi,

I'm trying to use CBWQ to share a career link beetween two agencies.

I'm using classe based weight queue to do that.

I have one interface by agency and one wan interface (fastethernet connected to a 2mbit/s link where the policy is applied).

The problem is not in the bandwidth sharing (I have two class with a match input interface and a policy that provide a bandwith percent for each class) but about the wan interface. How can i tell the qos mecanism that my total bandwidth is not 100mbit/s (fastethernet) but 2mbit/s ?

I've tried with the keyword bandwith in the interface config mode but it does not limit the trafic...

Thank you for your help

1 ACCEPTED SOLUTION

Accepted Solutions

Re: CBWQ and interface bandwidth

np - glad to help.

9 REPLIES

Re: CBWQ and interface bandwidth

You need to look at Traffic Shaping, see the below link:-

http://www.cisco.com/en/US/docs/internetworking/technology/handbook/QoS.html

New Member

Re: CBWQ and interface bandwidth

I've already read that.

My config :

class one

match input interface f0/1

class two

match input interface f0/0/0

policy-map bandwith-share

class one bandwith 50 percent

class two bandwith 50 percent

int f0/0

service policy output bandwdwith-share

How can I configure my router to tell the qos that there is only 2mbit/s to share and not 100mbit/s ?

Re: CBWQ and interface bandwidth

That is not traffic shaping, you are just allocating 50% of the available interface bandwith, you need to shape the traffic, ie define how much bandwidth can be sent over a time period, or you can police the traffic witch defines how much bandwidth can be used in bits.

Re: CBWQ and interface bandwidth

read the below link and use the config examples to build your requirements:-

http://www.cisco.com/en/US/tech/tk543/tk545/technologies_tech_note09186a00800a3a25.shtml#trafficshaping

HTH>

Re: CBWQ and interface bandwidth

I would configure something like:-

ip access-list standard customer1

permit 172.16.1.0 0.0.0.255

ip access-list standard customer2

permit 172.16.31.0 0.0.0.255

class-map match-all cust-1

match access-group name customer1

class-map match-all cust-2

match access-group name customer2

policy-map customers

class cust-1

bandwidth percent 50

class cust-2

bandwidth percent 50

policy-map shape-customers

class class-default

shape average 4194304

service-policy customers

HTH>

New Member

Re: CBWQ and interface bandwidth

Ok thank you very much !

Re: CBWQ and interface bandwidth

np - glad to help.

New Member

Re: CBWQ and interface bandwidth

Ok so the above config will do the job ?

class one

match input interface f0/1

class two

match input interface f0/0/0

policy-map bandwith-share

class one bandwith 50 percent

class two bandwith 50 percent

policy-map parent

class class-default

police 2048000 103000 103000 conform-action transmit exceed-action drop

service-policy bandwidth-share

int f0/0

service policy output bandwdwith-share

Thank you very much !

Super Bronze

Re: CBWQ and interface bandwidth

No, you want:

(edit2 NB: syntax might be incorrect)

class one

match input interface f0/1

class two

match input interface f0/0/0

policy-map bandwith-share

class one

!syntax might be bandwith percent remaining 50

bandwith remaining percent 50

class two

bandwith remaining percent 50

policy-map parent

class class-default

shape avg 2048000

service-policy bandwidth-share

int f0/0

service policy output parent

[edit]

BTW, on many platforms/IOSs, the shaper alone will do (W)FQ. I.e. you might find traffic behavior is better without the child policy.

[edit2]

i.e.

either

policy-map apolicy

class class-default

shape avg 2048000

int f0/0

service policy output apolicy

or

int fa0/0

traffic-shape avg 2048000

433
Views
0
Helpful
9
Replies