Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CHECK OUT THIS CONFIGURATION

We are presently using the config below to connect our Branch office1 LAN to the Head Office. We have Cisco2800 at Head office and Branch office1.

We want to connect the Branch office1 to another Branch office2.

the Cisco 2800 we are using has only 2 fast ethernet interfaces, so we decided to configure sub interfaces on one of the fast ethernet interface.

The Branch office2 will use Cisco871.

I attached here a simple network topology of our network and the configuration i made. (i tried this on my simulator, but i could not ping end to end.)

With the configurations below, will I be able to connect our Head office to the branch office2?

Is the configuration on Branch Office2 and 2950 switch ok.

Is my topology drawing ok, We use 2950 switch at branch office1.

Head Office

Router Configuration (Cisco2800)

conf t

int fa 0/1

description $WAN Interface$

ip address 172.30.1.1 255.255.255.0

int fa 0/0

description $LAN Interface$

ip address 172.20.1.1 255.255.255.0

exit

ip route 172.25.2.0 255.255.255.0 172.30.1.2 permanent

ip route 172.25.3.0 255.255.255.0 172.30.1.2 permanent

ip route 172.25.5.0 255.255.255.0 172.30.1.2 permanent

exit

Branch 1 Office router configuration (cisco2800)

conf t

int fa 0/1

ip address 172.30.1.2 255.255.255.0

no shut

int fa 0/0

description $native vlan$

ip address 172.25.2.1

int fa 0/0.10

encapsulation dot1q 10

description $VLAN TO Branch 2 $

ip address 172.25.3.1 255.255.255.0

exit

conf t

ip route 172.25.5.0 255.255.255.0 172.25.3.2 permanent

ip route 172.20.1.0 255.255.255.0 172.30.1.1 permanent

exit

Branch 1 office Switch (cisco2950) configuration

conf t

int vlan 1

ip address 172.25.2.2 255.255.255.0

exit

exit

vlan database

vlan 10

exit

int fa 0/1

switchport mode access

switchport access vlan 10

exit

int fa 0/12

switchport mode trunk

exit

Branch 2 office router configuration (cisco 871)

conf t

int vlan 1

ip address 172.25.5.1 255.255.255.0

exit

int fa 4

ip address 172.25.3.2 255.255.255.0

no shut

exit

ip route 172.25.2.0 255.255.255.0 172.25.3.1 permanent

ip route 172.30.1.0 255.255.255.0 172.25.3.1 permanent

ip route 172.20.1.0 255.255.255.0 172.25.3.1 permanent

exit

1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

Re: CHECK OUT THIS CONFIGURATION

In Branch 1 office router configure the subnet mask for the ip address “172.30.1.2”

For interVLAN routing, be sure to configure the default gateway on all workstations that connect to the switches. This default gateway is the IP address that you configure on the sub interface. You create a sub interface on the router for each VLAN.

The following URL helps to configure Intervlan routing between a router and switch:

http://www.cisco.com/en/US/products/hw/switches/ps628/products_configuration_example09186a00800ef797.shtml#diag

1 REPLY
Bronze

Re: CHECK OUT THIS CONFIGURATION

In Branch 1 office router configure the subnet mask for the ip address “172.30.1.2”

For interVLAN routing, be sure to configure the default gateway on all workstations that connect to the switches. This default gateway is the IP address that you configure on the sub interface. You create a sub interface on the router for each VLAN.

The following URL helps to configure Intervlan routing between a router and switch:

http://www.cisco.com/en/US/products/hw/switches/ps628/products_configuration_example09186a00800ef797.shtml#diag

268
Views
0
Helpful
1
Replies