Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Cisco 1600 does not allow ip route command

This router runs IOS 11.1, see attempt to add route below - it just fails as if the command does not exist:

Router>en

Password:

Router#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#ip route 0.0.0.0 0.0.0.0 Serial0

^

% Invalid input detected at '^' marker.

Router(config)#

The marker points to the "o" in route

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Cisco 1600 does not allow ip route command

Hi,

Yes, you are in ROMMON. You cannot use "ip routing" there. You need to load to a valid IOS. If you already have the IOS installed, set the registry to boot to it the next time you reload the router. i.e.

Router(boot)(config)#config-register 0x2102

Router(boot)# reload

Regards,

Dandy

17 REPLIES
Hall of Fame Super Gold

Re: Cisco 1600 does not allow ip route command

Nardus

That is quite strange. It acts as if IP routing were disabled. Can you check and verify whether the router is configured with no ip routing (would be used if someone wanted to configure bridging for example)? If it is then I suggest that you configure ip routing and then attempt to add the static route again.

I would also suggest that you check and verify that the serial 0 interface is configured with a valid IP address.

HTH

Rick

New Member

Re: Cisco 1600 does not allow ip route command

I trashed the config and used the wizard to configure it from scratch via console. I even tried the write erase and did the config again. Same problem. I was hoping that it was an IOS 11.1 problem with a wierd workaround - give me a moment to comment out any personal info and I will submit the sh runn

New Member

Re: Cisco 1600 does not allow ip route command

You will notice that I configured a default-gateway (the closest thing I could find related to routing...):

Router(boot)#sh runn

Building configuration...

Current configuration:

!

version 11.1

service udp-small-servers

service tcp-small-servers

!

hostname Router

!

enable secret !@##$$

enable password pass

!

!

interface Ethernet0

ip address 10.0.0.1 255.255.255.0

no ip route-cache

!

interface Serial0

ip address 192.168.0.2 255.255.255.0

encapsulation ppp

no ip route-cache

no fair-queue

!

ip default-gateway 192.168.0.1

!

line con 0

line vty 0

password pass

login

length 25

line vty 1 4

password pass

login

!

end

Re: Cisco 1600 does not allow ip route command

Hi,

Yes, you are in ROMMON. You cannot use "ip routing" there. You need to load to a valid IOS. If you already have the IOS installed, set the registry to boot to it the next time you reload the router. i.e.

Router(boot)(config)#config-register 0x2102

Router(boot)# reload

Regards,

Dandy

New Member

Re: Cisco 1600 does not allow ip route command

Hi Dandy, well spotted. I will need more of an idiot guide here. What is the easiest way to see if I still have an IOS installed? The reload command did not work.

error:

boot: cannot determine first file name on device "flash:"

Re: Cisco 1600 does not allow ip route command

Hi,

That is pretty strange.

Are you sure you are not in ROMMON? i.e. "Router(boot)(config-if)#"

Because you cannot configure "ip route" there, but you can use "ip default-gateway" to be able to load an IOS thru network.

Regards,

Dandy

Hall of Fame Super Gold

Re: Cisco 1600 does not allow ip route command

Dandy

I believe that you have a very good suggestion - especially given this line from the recent post:

Router(boot)#sh runn

It sure looks like rommon. And that would explain the symptoms.

HTH

Rick

Re: Cisco 1600 does not allow ip route command

Thanks Rick.

Regards,

Dandy

New Member

Re: Cisco 1600 does not allow ip route command

Excuse my ignorance...how will I know if I am in ROMMON - how do you quit from it? - I did not use Ctrl Break or anything like that.

Connected the Blue serial console cable, switched on the router and type in en and password to check the config.

This could be the answer - how do I go back to normal mode?

Hall of Fame Super Gold

Re: Cisco 1600 does not allow ip route command

Nardus

In general you would know that you were in rommon if the prompt includes the symbols (boot), which is the case in your post.

There are several common reasons why you would be in rommon:

- you did a break during the boot process (which you say you did not do).

- the config register is set to boot into rommon. (if this is the case try the suggestion from Dandy about setting the config register to 0x2102)

- the router has a problem loading the config from flash.

If you would connect to the console, power down the router, and then power up the router and capture all the console messages as the router boots and post that output we might understand better what is going on.

HTH

Rick

New Member

Re: Cisco 1600 does not allow ip route command

I did do the ctrl break this morning when I had to kill the password. This router was mothballed about 2 years ago and today my 2600 packed up and I need to get a replacement working in a hurry. I only work with these routers when something goes wrong - pretty much self taught... hence the reason that I am not so sharp with the deeper technical stuff. Will capture the boot screens for you - Thanks for the help so far

Hall of Fame Super Gold

Re: Cisco 1600 does not allow ip route command

Nardus

Assuming that it is supported on this router I believe that the best way to get a valid IOS into flash is to use the tftpdnld command.

tftpdnld assumes that you have a valid IOS on a tftp server which is reachable from the router. Is this the case? If so, you need to set some variables like address, mask, default gateway, tftpserver address and then tftpdnld will load the IOS into flash.

If tftpdnld is not supported (or does not work) then the alternative is probably to use XMODEM to put the IOS into flash.

HTH

Rick

New Member

Re: Cisco 1600 does not allow ip route command

This leaves me with a bit of a dilemma, the support and downloads for the 1600 series has been discontinued. Where can I find a valid IOS image file?

New Member

Re: Cisco 1600 does not allow ip route command

Hi Rick,

Boot text as requested:

System Bootstrap, Version 11.1(7)AX [kuong (7)AX], EARLY DEPLOYMENT RELEASE SOFTWARE (fc2)

Copyright (c) 1994-1996 by cisco Systems, Inc.

C1600 processor with 2048 Kbytes of main memory

program load complete, entry point: 0x4018060, size: 0x1da950

Loading cisco2-C1600 ... [timed out]

boot of "cisco2-C1600" using boot helper "eprom:c1600-boot-r.111-7.AX." failed

error returned: File read failed -- Time out

loadprog: error - on file open

boot: cannot load "cisco2-C1600"ú

System Bootstrap, Version 11.1(7)AX [kuong (7)AX], EARLY DEPLOYMENT RELEASE SOFTWARE (fc2)

Copyright (c) 1994-1996 by cisco Systems, Inc.

C1600 processor with 2048 Kbytes of main memory

boot: cannot determine first file name on device "flash:"ú

System Bootstrap, Version 11.1(7)AX [kuong (7)AX], EARLY DEPLOYMENT RELEASE SOFTWARE (fc2)

Copyright (c) 1994-1996 by cisco Systems, Inc.

C1600 processor with 2048 Kbytes of main memory

program load complete, entry point: 0x4018060, size: 0x1da950

Restricted Rights Legend

Use, duplication, or disclosure by the Government is

subject to restrictions as set forth in subparagraph

(c) of the Commercial Computer Software - Restricted

Rights clause at FAR sec. 52.227-19 and subparagraph

(c) (1) (ii) of the Rights in Technical Data and Computer

Software clause at DFARS sec. 252.227-7013.

cisco Systems, Inc.

170 West Tasman Drive

San Jose, California 95134-1706

Cisco Internetwork Operating System Software

IOS (tm) 1600 Software (C1600-BOOT-R), Version 11.1(7)AX, EARLY DEPLOYMENT RELEASE SOFTWARE (fc2)

Copyright (c) 1986-1996 by cisco Systems, Inc.

Compiled Fri 18-Oct-96 00:20 by kuong

Image text-base: 0x04018060, data-base: 0x02005000

cisco 1600 (68360) processor (revision C) with 1536K/512K bytes of memory.

Processor board ID 04908727

X.25 software, Version 2.0, NET2, BFE and GOSIP compliant.

1 Ethernet/IEEE 802.3 interface.

1 Serial(sync/async) network interface.

System/IO memory with parity disabled

8K bytes of non-volatile configuration memory.

4096K bytes of processor board PCMCIA flash (Read/Write)

Press RETURN to get started!

%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down

%LINK-3-UPDOWN: Interface Ethernet0, changed state to up

%LINK-3-UPDOWN: Interface Serial0, changed state to down

%SYS-5-CONFIG_I: Configured from memory by console

%SYS-5-RESTART: System restarted

Hall of Fame Super Gold

Re: Cisco 1600 does not allow ip route command

Nardus

Thanks for the additional information posted here. It does confirm that the issue is not control-break or the config register but is a problem in loading the image from flash.

It might be worth trying to power down the router, reseat the flash, and try booting again. If the flash became lose during storage this might fix it. Otherwise I believe that there is a significant problem. When I look on the Cisco web site I can find software for several models of 1600 router but I do not find any that will fit into the 4 MB of flash that is available on this router. I am not sure where you would get an image that will run on this hardware.

HTH

Rick

New Member

Re: Cisco 1600 does not allow ip route command

Hi Rick,

I managed to track down a 3.5MB IOS file. Thanks for all the help. The router is back to useful status! Dandy thank you too for spotting the mode!

Regards,

Nardus

Re: Cisco 1600 does not allow ip route command

Hi Nardus,

I'm glad that your problem is solved, and thanks for the rating.

Sry, not able to monitor the progress as it was past 0100AM here in my place when I post my last reply :)

Regards,

Dandy

649
Views
3
Helpful
17
Replies
CreatePlease to create content