Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 1721 Config...adding PPPOE?

Hi,

I have three 1721s that have been using a simple ethernet config to access the Internet via my ISP. Now I've added a fourth 1721 and this one was given five static IPs that are "sticky" and thus my connection is now PPPOE.

My question is how do I modify the config below (which is standard across all three 1721s) so that it does the connection via PPPOE? I've been reading around this forum and Googling but thought I'd pose the question here as well.

Thanks in advance and let me know if more information is needed.

Cheers,

Jon

PS - The first three routers are using 12.3, the new router is using 12.4.

<BEGIN_CONFIG>

Using 1964 out of 29688 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname router

!

boot-start-marker

boot-end-marker

!

no logging console

enable secret

enable password

!

no aaa new-model

ip subnet-zero

!

!

ip dhcp excluded-address 192.168.0.1 192.168.0.9

ip dhcp excluded-address 192.168.0.20 192.168.0.254

!

ip dhcp pool LANpool

network 192.168.0.0 255.255.255.0

dns-server 206.13.28.12 206.13.31.12

default-router 192.168.0.1

!

!

ip name-server 206.13.28.12

ip name-server 206.13.31.12

ip cef

no scripting tcl init

no scripting tcl encdir

!

!

bridge irb

!

!

interface ATM0

no ip address

no atm ilmi-keepalive

pvc 0/35

encapsulation aal5snap

!

dsl operating-mode auto

bridge-group 1

!

interface FastEthernet0

description Internet Connection

no ip address

ip nat outside

speed auto

!

interface FastEthernet1

description Connection to Wireless LAN

switchport access vlan 26

no ip address

!

interface FastEthernet2

description Connect to LAN

switchport access vlan 26

no ip address

!

interface FastEthernet3

description Internal LAN Server

switchport access vlan 26

no ip address

!

interface FastEthernet4

description Connection to DMZ

switchport access vlan 99

no ip address

no cdp enable

!

interface Vlan99

description DMZ

ip address x.x.x.x 255.255.255.248

!

interface Vlan26

description routed interface for LAN segment

ip address 192.168.0.1 255.255.255.0

ip nat inside

!

interface Vlan1

no ip address

!

interface BVI1

ip address x.x.x.x 255.255.255.252

ip nat outside

!

ip nat inside source list 1 interface BVI1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 x.x.x.x

no ip http server

!

!

access-list 1 permit x.x.x.0 0.0.0.255

access-list 1 permit 192.168.0.0 0.0.0.255

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

!

line con 0

line aux 0

line vty 0 4

login

!

!

end

<END_CONFIG>

2 REPLIES
VIP Purple

Re: Cisco 1721 Config...adding PPPOE?

Hello Jon,

you are using a BVI as the interface pointing to the Internet, I am not sure if you can tie this to the ATM. Is there a specific need to use integrated routing and bridging ?

Regards,

GP

New Member

Re: Cisco 1721 Config...adding PPPOE?

Hi GP,

Thanks for getting back to me. This config represents how SBC set up their DSL at that time (~1 year ago). Now, they use the "sticky" scenario with PPPOE. My thoughts are I need to adjust my config to match something like this:

http://www.dslreports.com/faq/3643

or follow these guidelines for PPPOE:

http://www.linuxhomenetworking.com/cisco-hn/dsl-router.htm

What do you think? Let me know if this clarifies things for you.

Thanks,

Jon

393
Views
0
Helpful
2
Replies