Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Cisco 1721 WIc-1ADSL problems

Hi All,

I really hope someone can help me as I am struggling to solve this one. I can't see what is wrong.

I am trying to configure it to run on ADSL but I am getting large amounts or errors when I run "sh dsl int atm0" and can't work out why?

I am getting large quantities of Reed Solomon EC and then large bursts of CRC and Header errors.

Its causing my line to fall over quite alot. It appears stable at first but then all of a sudden errors start and it dies.

If I do "debug atm errors" I get alot of errors saying somthing along the lines of tsi not available.

Does anyone have any ideas?

This is my config:

!

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname stardock

!

boot system flash:C1700-y7-mz.122-15.T16.bin

logging queue-limit 100

enable secret 5 $1$7sgG$8C0ncXbNHlSwyIgLkePkN/

enable password *PASSWORD*

!

username all

ip subnet-zero

!

!

no ip domain lookup

ip name-server 62.24.199.13

ip name-server 62.24.199.23

ip dhcp excluded-address 192.168.10.1

ip dhcp excluded-address 192.168.10.254

ip dhcp excluded-address 192.168.10.10

ip dhcp excluded-address 192.168.10.2

ip dhcp excluded-address 192.168.10.3

!

ip dhcp pool InternalDHCP

   network 192.168.10.0 255.255.255.0

   default-router 192.168.10.254

   dns-server 62.24.199.13 62.24.199.23

!

ip cef

!

!

!

!

interface ATM0

no ip address

no ip route-cache

no atm ilmi-keepalive

bundle-enable

dsl operating-mode auto

hold-queue 224 in

!

interface ATM0.1 point-to-point

no ip route-cache

pvc 0/38

  encapsulation aal5mux ppp dialer

  pppoe max-sessions 1

  dialer pool-member 1

!

!

interface BRI0

no ip address

shutdown

!

interface FastEthernet0

ip address 192.168.10.254 255.255.255.0

ip nat inside

speed auto

full-duplex

!

interface Dialer0

no ip address

!

interface Dialer1

ip address negotiated

ip mtu 1432

ip nat outside

encapsulation ppp

dialer pool 1

ppp authentication chap callin

ppp chap hostname *USERNAME*

ppp chap password 0 *PASSWORD*

!

ip nat inside source list 1 interface Dialer1 overload

ip nat inside source static 192.168.10.10 interface Dialer1

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

no ip http server

!

!

access-list 1 permit 192.168.10.0 0.0.0.255

!

line con 0

logging synchronous

line aux 0

line vty 0 4

password *PASSWORD*

login

!

end

Everyone's tags (3)
10 REPLIES
Hall of Fame Super Silver

Re: Cisco 1721 WIc-1ADSL problems

Hello Richard,

you should have posted a show dsl interface atm0

Reed Solomon errors are errors at OSI layer 1 in the DSL contact the  DSL service provider and ask them to check the line.

Likely the signal to noise ratio is too low in one direction or on both directions, this can be seen in the show dsl interface atm0 ( referred as noise margin one per direction)

Your configuration looks like correct.

Hope to help

Giuseppe

New Member

Cisco 1721 WIc-1ADSL problems

Thanks, I was giong to post the show dsl interface atm0 but I had just cleared it so it was clean. As soon as I get some data I will do.

Thanks for checking my config.

Do you know how I can control my SNR in 12.2 as I have been struggling to pin down the commands pre-12.3?

This is my current atm but as I said the errors come in waves and I havnt had them turn up yet.

stardock#sh dsl int a0

Alcatel 20150 chipset information

                ATU-R (DS)                      ATU-C (US)

Modem Status:    Showtime (DMTDSL_SHOWTIME)

DSL Mode:        ITU G.992.1 (G.DMT)

ITU STD NUM:     0x01                            0x1

Vendor ID:       'ALCB'                          'IFTN'

Vendor Specific: 0x0000                          0x71C6

Vendor Country:  0x00                            0xB5

Capacity Used:   96%                             100%

Noise Margin:     5.5 dB                          6.0 dB

Output Power:    19.5 dBm                        12.0 dBm

Attenuation:     51.5 dB                         31.5 dB

Defect Status:   None                            None

Last Fail Code:  None

Selftest Result: 0x00

Subfunction:     0x15

Interrupts:      1438 (0 spurious)

PHY Access Err:  0

Activations:     13

Init FW:         embedded

Operation FW:    embedded

SW Version:      3.8131

FW Version:      0x1A04

                 Interleave             Fast    Interleave              Fast

Speed (kbps):          3904                0           800                 0

Reed-Solomon EC:        133                0            39                 0

CRC Errors:               9                0            35                 0

Header Errors:            4                0            14                 0

Bit Errors:               0                0

BER Valid sec:            0                0

BER Invalid sec:          0                0

DMT Bits Per Bin

00: 0 0 0 0 0 0 0 6 7 9 A B B B B B

10: B B B C B B B B B A A 9 8 8 0 0

20: 0 0 0 0 0 0 8 9 9 A A B B B 9 B

30: B B B C C C C C C C C B B C C C

40: C C C 2 B B B B B B B B B A A A

50: A A B A A A A A A A A 9 8 A 9 9

60: 9 9 9 9 8 9 9 A 9 A 9 9 8 8 7 8

70: 8 9 9 9 9 9 8 8 8 8 7 8 8 6 6 7

80: 7 7 7 7 6 0 7 7 7 7 6 6 6 5 6 6

90: 6 6 6 0 6 6 6 6 0 5 6 5 5 4 4 3

A0: 0 0 2 3 3 3 3 2 4 4 4 3 2 2 4 3

B0: 4 4 4 3 3 3 2 2 2 2 0 2 2 2 2 0

C0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

D0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

E0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

F0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

DSL: Training log buffer capability is not enabled

New Member

Cisco 1721 WIc-1ADSL problems

It appears the issue is with my SNR it keeps dropping into the negatives, as low as -15.

I've tried looking online but I cannot find any commands to fix or control the SNR. Any Ideas?

Hall of Fame Super Gold

Cisco 1721 WIc-1ADSL problems

Contact your DSL provider and give them your output.  They should know what to do.

Hall of Fame Super Silver

Cisco 1721 WIc-1ADSL problems

Hello Richard,

as suggested by Leo contact the DSL provider

to be noted also on your show dsl interface we see a positive SNR but with excessive downstream attenuation of 51.5 dB

The line is not clean

Hope to help

Giuseppe

New Member

Cisco 1721 WIc-1ADSL problems

Yes, I am quite a distance from the exchange but was getting consitent 4mbps with an SNR of 6dB on my Netgear 834G. So its definately an issue caused by the change over to using Cisco equipment.

I wish I could just find a way to fix the SNR to a set figure rather than have it auto negotiate.

I'm going to raise a support ticket with the ISP aswel, I just thought there should be someway of solving this on my end.

New Member

Cisco 1721 WIc-1ADSL problems

I've just been rechecking me config and I think my ISP needs PPPoA. I am with TalkTalk http://help.talktalk.co.uk/app/answers/detail/a_id/1400/~/the-dsl-light-on-my-router-is-on-but-i-can't-connect

Could that cause such issues?

Any ideas how I make sure I am using PPPoA, my opinion of my config is that its set to PPPoE but I would have thought that would just prevent connection at all?

Hall of Fame Super Silver

Cisco 1721 WIc-1ADSL problems

Hello Richard,

your issues are not related to a wrong encapsulation that would cause total lack of IP connectivity.

Your current configuration could be defined PPPoEoA just to add confusion in the naming!

Your issues are related to the line at OSI physical layer.

Hope to help

Giuseppe

New Member

Cisco 1721 WIc-1ADSL problems

Ah the

encapsulation aal5mux ppp dialer

is auto detection and it takes care of the vc-mux. I'm on the right page now. Thanks for that.

looks like I'm going to have to try new cables + filters etc then or concider switching back to a standard ADSL modem/router.

TalkTalk tech support is bloody awful.

Hall of Fame Super Gold

Cisco 1721 WIc-1ADSL problems

I agree with Giuseppe here.

Your issue has got nothing to do with your configuration.  It's got something to do with your physical line.  Granted your service degraded after you switched to Cisco but that's not the point.  Your physical line is awful or dirty. 

954
Views
0
Helpful
10
Replies
CreatePlease to create content