Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Cisco 1841 basic adsl configuration guide

Hi guys,

I am trying to configure a Cisco 1841 to allow the users to access the internet.

This is my first step with ppp. All the rest of the configuration is ok but I don't know how to setup the interfaces Dialer0 and ATM0/0/0.

Does somebody have a very basic configuration that I can analyze and use on my device?

Thanks,

Dario

10 REPLIES
Super Bronze

Cisco 1841 basic adsl configuration guide

Cisco 1841 basic adsl configuration guide

Hi Jennifer,

I have to setup a pppoe. Do I have to use the same config?

thanks,

Dario

Re: Cisco 1841 basic adsl configuration guide

Hi Dario,

If you would search the forum, you'll find a recent discussion on this topic (I've had this bookmarked). Just make sure you've got the necessary info (VPI/VCI, etc) from your ISP:

https://supportforums.cisco.com/message/3685750#3685750

Sent from Cisco Technical Support iPhone App

Cisco 1841 basic adsl configuration guide

Hi John,

I have tried to follow that guide last morning but it doesn't work on my router. The only differences between that guide and my config are "memory-size iomem 25" (otherwise NAT didn't work because of a memory error) and the VLAN1 that was not setup (I don't think I really need it). My ISP VPI/VCI are 8/35 but it doesn't work :-(

memory-size iomem 25

interface ATM0/0/0

no ip address

no atm ilmi-keepalive

pvc 8/35

!

!

interface Vlan1

no ip address

!

interface Dialer0

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

ip tcp adjust-mss 1452

dialer pool 1

ppp chap hostname MYLOGIN

ppp chap password 0 MYPASSWORD

ppp pap sent-username MYLOGIN password 0 MYPASSWORD

ppp ipcp dns request accept

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer0

no ip http server

no ip http secure-server

!

!

ip nat inside source list NAT interface Dialer0 overload

!

ip access-list standard NAT

permit 10.1.2.0 0.0.0.255

!

Any idea?

Thanks,

Dario

Re: Cisco 1841 basic adsl configuration guide

Hi Dario,

You'll need a LAN interface with the LAN IP and NAT to be set up. Kindly see sample config below.

Could you post your show run (hide sensitive data) and show ip interface brief output?

interface x

ip address 10.1.2.0 255.255.255.0

ip nat inside

no shut

Sent from Cisco Technical Support iPhone App

Cisco 1841 basic adsl configuration guide

Hi John,

Thanks for your help. Here below my running_config. I am using FastEthernet0/0 as internal interface.

Current configuration : 1634 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname router_melbourne

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

enable secret 5 MYSECRETCRYPTED

!

aaa new-model

!

!

!

!

aaa session-id common

memory-size iomem 25

dot11 syslog

ip source-route

!

!

!

!

ip cef

ip domain name router_melbourne.local

!

multilink bundle-name authenticated

!

!

!

!

!

username MYUSERNAME password 7 MYPASSCRYPTED

archive

log config

  hidekeys

!

!

!

!

!

ip ssh time-out 60

ip ssh version 2

!

!

!

interface FastEthernet0/0

ip address 10.1.2.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet0/1/0

!

interface FastEthernet0/1/1

!

interface FastEthernet0/1/2

!

interface FastEthernet0/1/3

!

interface ATM0/0/0

no ip address

no atm ilmi-keepalive

pvc 8/35

!

!

interface Vlan1

no ip address

!

interface Dialer0

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

ip tcp adjust-mss 1452

dialer pool 1

ppp chap hostname ISPUSERNAME

ppp chap password 7 ISPPASSWORD

ppp pap sent-username ISPUSERNAME password 7 ISPPASSWORD

ppp ipcp dns request accept

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer0

no ip http server

no ip http secure-server

!

!

ip nat inside source list NAT interface Dialer0 overload

!

ip access-list standard NAT

permit 10.1.2.0 0.0.0.255

!

!

!

!

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

transport input telnet ssh

!

scheduler allocate 20000 1000

end

Dario

Re: Cisco 1841 basic adsl configuration guide

Hi Dario,

Thanks for the show run output! Looks like you've got a 4-port switch module inserted on your 1841.

You'll need to use the VLAN 1 SVI to act as the gateway and have NAT enabled:

int f0/0

no ip address

interface vlan 1

ip add 10.1.2.0 255.255.255.0

ip nat inside

I would appreciate if you can provide the 'show ip interface brief' command and a ping result to any public IP address (4.2.2.2) using VLAN 1 as source.

Sent from Cisco Technical Support iPhone App

Cisco 1841 basic adsl configuration guide

Hi John,

I have a new problem: the command "memory-size iomem 25" has stuffed up my router and it doesn't want to boot anymore.

I've tried to boot in ROMMON but it keeps returning memory errors. As soon as I figure out a solution I will try your suggestion.

Thanks,

Dario

Re: Cisco 1841 basic adsl configuration guide

Hi Dario,

I'm sorry to hear you're running into a different issue . I haven't seen or used the 'memory-size iomem' command before on an 1841. I'm not sure whether it has a direct impact on the issue your currently having.

I would suggest if you could raise it with TAC and go back here to continue completing your setup. Good luck!

Sent from Cisco Technical Support iPhone App

Re: Cisco 1841 basic adsl configuration guide

Hi John,

I will install an extra module. It looks like a faster solution than asking for support.

I will update you as soon as the hardware is working again. Meanwhile, thanks a lot for your support.

Thanks,

Dario

17499
Views
0
Helpful
10
Replies