Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 1841: Can ping ip addresses but cannot connect to the Internet

Hi,

I have recently changed ISP and had to configure my router to accomodate the new ISP. But for some reason I cannot seem to connect to the Internet.

My setup consists of the ISP's modem, my router and then a bunch of switches for the LAN.

With the old ISP, the config was as follows:

Interface FastEthernet 0/0

Description LAN Interface

ip address 192.168.5.1 255.255.255.0

ip nat inside

Interface Serial 0/0/0

Description ISP INTERNET LINK

ip address 10.88.96.212 255.255.255.252

ip nat outside

ip name-server 123.108.252.50

ip name-server 123.108.252.51

ip route 0.0.0.0 0.0.0.0 10.88.96.212

ip nat inside source list 1 interface serial 0/0/0 overload

access-list 1 permit 192.168.0.0 0.0.0.255

access-list 1 permit 192.168.5.0 0.0.0.255

Everything worked fine. With the new ISP, the cable modem they provided has one ethernet port which I connect to one of my FastEthernet ports.

I setup the router for the new ISP like so:


Interface FastEthernet 0/0

Description CRS LAN Interface

ip address 192.168.5.1 255.255.255.0

ip nat inside

Interface FastEthernet 0/1

Description ISP INTERNET LINK

ip address 192.167.18.222 255.255.255.252

ip nat outside

ip name-server 51.202.229.132

ip name-server 51.202.229.130

ip route 0.0.0.0 0.0.0.0 192.167.18.221

ip nat inside source list 1 interface FastEthernet 0/1 overload

access-list 1 permit 192.168.0.0 0.0.0.255

access-list 1 permit 192.168.5.0 0.0.0.255

From my router, I can ping the gateway 192.167.18.221. I can ping all devices in my LAN but I cannot connect to the Internet.

If I connect the ISP modem via ethernet cable directly to my laptop, the Internet works so there seems to be a problem with my config.

Would like some assistance. Thanks in advance

Everyone's tags (3)
3 ACCEPTED SOLUTIONS

Accepted Solutions

Re: Cisco 1841: Can ping ip addresses but cannot connect to the

Hi David,

If traceroute output is from LAN PC, I would expect that first hop will be 192.168.5.1, not 192.167.18.221 which is ISP gateway.

Can you please upload these output from LAN PC:

ipconfig /all

route print

ping www.google.com

Also as pdriver suggested to try crosscable, I dont think it will be necessary cause it seems that connectivity is up.

Best Regards

Please rate all helpful posts and close solved questions

Best Regards Please rate all helpful posts and close solved questions
New Member

Cisco 1841: Can ping ip addresses but cannot connect to the Inte

Hi,

Its a DNS issue....try to config 4.4.4.4 as ur DNS in your laptop and even in router. it should work.

Regards,

Satya.M

Cisco 1841: Can ping ip addresses but cannot connect to the Inte

David,

Can you ping 8.8.8.8 from a workstation? If so, it's dns related. You can test this by taking out the two name servers in your router and adding 8.8.8.8. After that, try to ping www.google.com sourcing from fa0/0. If you get a response, your natting/internet is working. Then put the same config (dns entries) on a workstation. Try to ping google from there. If that works, you're good.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
27 REPLIES
New Member

Cisco 1841: Can ping ip addresses but cannot connect to the Inte

have you checked the NAT translation if its working?

New Member

Cisco 1841: Can ping ip addresses but cannot connect to the Inte

Will do when I get a chance. I have a feeling I messed up the NAT config

New Member

Cisco 1841: Can ping ip addresses but cannot connect to the Inte

What is subnet mask you gave to the laptop's ip address?

New Member

Cisco 1841: Can ping ip addresses but cannot connect to the Inte

Computers in the LAN are all on 255.255.255.0. I am using dhcp via windows server

If you mean for a direct connection from modem to laptop then:

255.255.255.252 (the isp's mask)

Silver

Cisco 1841: Can ping ip addresses but cannot connect to the Inte

Turn on NAT debugging "debug ip nat" and ping as follows:

ping 8.8.8.8 source fa0/0

and post the results. Don't forget to turn on "term mon" is you are not connected via console.

Hall of Fame Super Silver

Cisco 1841: Can ping ip addresses but cannot connect to the Inte

When you connect your laptop to the provider modem is the laptop using DHCP or did you manually set the address?

You tell us that the router is able to ping the next hop gateway. I wonder if the router is able to ping anything beyond that? And are you pinging using names for the destination or using IP addresses of the destination?

HTH

Rick

New Member

Cisco 1841: Can ping ip addresses but cannot connect to the Inte

I set the address manually when connected from laptop to modem.

I am pinging using IP addresses

Cisco 1841: Can ping ip addresses but cannot connect to the Inte

David,

Rick asked a good question that I didn't see an answer for. Can you ping anything outside of their modem? You have said that you can ping the default gateway from your router, which would be the ISP's router, but can you, from your Cisco, ping 8.8.8.8 or 8.8.4.4? If you can, try removing "ip nat outside" and "ip nat inside" from the router and then put them back on. I'm wondering if the nat translation table wasn't automatically rebuilt after changing the address on the router.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Cisco 1841: Can ping ip addresses but cannot connect to the Inte

Yes I can ping 8.8.8.8 and 8.8.4.4 from my router.

I have removed ip nat outside and ip nat inside from the rotuer and put them back in but nothing changed. Still unable to connect to the internet.

Unless I did it wrong. To remove, I entered the specific interface and typed 'no ip nat inside'

i.e

int fa0/0

no ip nat inside

exit

int fa0/1

no ip nat outside

exit

Cisco 1841: Can ping ip addresses but cannot connect to the Inte

Okay, let's do this. Can you run "debug ip nat" and then "ping 8.8.8.8 source fa0/0" and then post the results? Also post "sh ip nat trans".

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Re: Cisco 1841: Can ping ip addresses but cannot connect to the

debug ip nat

-------

*Feb 1 07:12:46.959: NAT: expiring 10.88.96.212 (192.168.5.8) udp 6100 (6100)

*Feb  1 07:12:51.055: NAT: expiring 10.88.96.212 (192.168.5.8) udp 6101 (6101)

*Feb  1 07:12:46.959: NAT: expiring 10.88.96.212 (192.168.5.8) udp 6102 (6102)

*Feb  1 07:12:58.735: NAT: expiring 10.88.96.212 (192.168.5.8) udp 6103 (6103)

*Feb  1 07:13:02.831: NAT: expiring 10.88.96.212 (192.168.5.8) udp 6104 (6104)

*Feb  1 07:13:06.927: NAT: expiring 10.88.96.212 (192.168.5.8) udp 6105 (6105

*Feb  1 07:13:24.847: NAT: expiring 10.88.96.212 (192.168.5.8) udp 6106 (6106)

*Feb  1 07:15:59.831: NAT*: s=192.168.5.10->10.88.96.212, d=132.245.1.25 [23311]

*Feb  1 07:16:00.307: NAT*: s=132.245.1.25, d=10.88.96.212->192.168.5.10 [590]

*Feb  1 07:16:39.915: NAT*: s=192.168.5.10->10.88.96.212, d=132.245.1.25 [23516]

*Feb  1 07:16:39.915: NAT*: s=192.168.5.10->10.88.96.212, d=132.245.1.25 [23517]

*Feb  1 07:16:39.919: NAT*: s=192.168.5.10->10.88.96.212, d=132.245.1.25 [23518]

*Feb  1 07:16:39.919: NAT*: s=192.168.5.10->10.88.96.212, d=132.245.1.25 [23519]

*Feb  1 07:16:40.183: NAT*: s=132.245.1.25, d=10.88.96.212->192.168.5.10 [15730]

*Feb  1 07:16:40.191: NAT*: s=132.245.1.25, d=10.88.96.212->192.168.5.10 [15735]

*Feb  1 07:16:40.911: NAT*: s=132.245.1.25, d=10.88.96.212->192.168.5.10 [16027]

*Feb  1 07:16:40.911: NAT*: s=132.245.1.25, d=10.88.96.212->192.168.5.10 [16028]

*Feb  1 07:16:40.915: NAT*: s=192.168.5.10->10.88.96.212, d=132.245.1.25 [23527]

*Feb  1 07:16:40.915: NAT*: s=132.245.1.25, d=10.88.96.212->192.168.5.10 [16029]

*Feb  1 07:16:40.919: NAT*: s=132.245.1.25, d=10.88.96.212->192.168.5.10 [16030]

*Feb  1 07:16:40.923: NAT*: s=192.168.5.10->10.88.96.212, d=132.245.1.25 [23528]

*Feb  1 07:20:00.951: NAT*: s=192.168.5.10->10.88.96.212, d=132.245.1.25 [24439]

*Feb  1 07:20:01.415: NAT*: s=132.245.1.25, d=10.88.96.212->192.168.5.10 [21093]

*Feb  1 07:20:36.331: NAT*: s=132.245.1.25, d=10.88.96.212->192.168.5.10 [7563]

*Feb  1 07:20:36.335: NAT*: s=132.245.1.25, d=10.88.96.212->192.168.5.10 [7564]

*Feb  1 07:20:36.335: NAT*: s=192.168.5.10->10.88.96.212, d=132.245.1.25 [24598]

*Feb  1 07:20:36.335: NAT*: s=192.168.5.10->10.88.96.212, d=132.245.1.25 [24599]

*Feb  1 07:20:36.799: NAT*: s=132.245.1.25, d=10.88.96.212->192.168.5.10 [8363]

*Feb  1 07:21:39.979: NAT*: s=192.168.5.10->10.88.96.212, d=132.245.1.25 [25017]

*Feb  1 07:21:39.979: NAT*: s=192.168.5.10->10.88.96.212, d=132.245.1.25 [25018]

*Feb  1 07:21:40.247: NAT*: s=132.245.1.25, d=10.88.96.212->192.168.5.10 [34]

*Feb  1 07:21:40.251: NAT*: s=132.245.1.25, d=10.88.96.212->192.168.5.10 [35]

*Feb  1 07:21:40.727: NAT*: s=192.168.5.10->10.88.96.212, d=132.245.1.25 [25023]

*Feb  1 07:21:40.995: NAT*: s=132.245.1.25, d=10.88.96.212->192.168.5.10 [257]

*Feb  1 07:21:40.995: NAT*: s=192.168.5.10->10.88.96.212, d=132.245.1.25 [25026]

*Feb  1 07:21:41.263: NAT*: s=132.245.1.25, d=10.88.96.212->192.168.5.10 [322]

*Feb  1 07:21:41.691: NAT*: s=132.245.1.25, d=10.88.96.212->192.168.5.10 [482]

*Feb  1 07:21:41.691: NAT*: s=132.245.1.25, d=10.88.96.212->192.168.5.10 [483]

*Feb  1 07:21:41.691: NAT*: s=132.245.1.25, d=10.88.96.212->192.168.5.10 [484]

*Feb  1 07:21:41.691: NAT*: s=132.245.1.25, d=10.88.96.212->192.168.5.10 [485]

*Feb  1 07:21:41.695: NAT*: s=192.168.5.10->10.88.96.212, d=132.245.1.25 [25028]

*Feb  1 07:21:41.695: NAT*: s=192.168.5.10->10.88.96.212, d=132.245.1.25 [25029]

ping 8.8.8.8 source fa0/0

-------

Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:

Packet sent with a source address of 192.168.5.1

!!!!!

Success rate is 0 percent (0/5)

--------

sh ip nat trans

-------

Pro Inside global          Inside local               Outside local          Outside global

tcp 192.167.18.222:2020          192.168.5.10:2020          132.245.1.25          132.245.1.24:443

-------

sh ip route

-------

Gateway of last resort is 192.167.18.221 to network 0.0.0.0

C          192.168.5.0/24 is directly connected, FastEthernet0/0

                192.167.18.0/30 is subnetted, 1 subnets

C          192.167.18.220 is directly connected, FastEthernet 0/1

S*         0.0.0.0/0 [1/0] via 192.167.18.221

-------

sh run | s nat

-------

ip nat inside

ip nat outside

ip nat outside

ip nat inside

ip nat inside source list 1 interface FastEthernet0/1 overload

Edit: typo in the debug part... 10.88.96.212 should be 192.167.18.222

Cisco 1841: Can ping ip addresses but cannot connect to the Inte

David,

Can you ping 8.8.8.8 from a workstation? If so, it's dns related. You can test this by taking out the two name servers in your router and adding 8.8.8.8. After that, try to ping www.google.com sourcing from fa0/0. If you get a response, your natting/internet is working. Then put the same config (dns entries) on a workstation. Try to ping google from there. If that works, you're good.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Re: Cisco 1841: Can ping ip addresses but cannot connect to the

Oh man, turns out it was a dns issue like you and satya said.

I changed the name-servers in the router (to 8.8.8.8 and 4.4.4.4) and on my Laptop and the Internet WORKS!!!!

Which made me realise that I hadn't changed the forwarders on my DNS Servers in my LAN. So I changed the forwarders (on my DNS Server) to the ISP DNS IPs and now I can use the ISP name-servers in the router.

You guys have all been so awesome. In just these few days I have learnt so much. Everyone has been so helpful. Great community here

Thanks a lot

Purple

Cisco 1841: Can ping ip addresses but cannot connect to the Inte

Hi,

in addition to John request could you also post sh ip route output as well as sh run | s nat

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

Re: Cisco 1841: Can ping ip addresses but cannot connect to the

Hello

Can you try give the wan interface of the router the mac address of your laptop and try again

Possibly you can only register one MAC address with ISP and this way you are spoofing the ISP into thinking your laptop is attached

Res
Paul

Sent from Cisco Technical Support iPad App

Please don't forget to rate any posts that have been helpful. Thanks.
New Member

Re: Cisco 1841: Can ping ip addresses but cannot connect to the

How do I give the wan interface the mac address of my laptop ?

Re: Cisco 1841: Can ping ip addresses but cannot connect to the

Hello

Int xxx(ISP link)
mac-address xxxx.xxxx.xxxx

To find MAC address of PC
====================
Start /run
Cmd

Get mac /v



Res
Paul



Sent from Cisco Technical Support iPad App

Please don't forget to rate any posts that have been helpful. Thanks.
New Member

Re: Cisco 1841: Can ping ip addresses but cannot connect to the

Entering the mac address doesn't help.

The problem still persists

Re: Cisco 1841: Can ping ip addresses but cannot connect to the

Hi David,

Please remove mac-address command from WAN interface and please upload your running-config.

Also you mentioned that you can ping 8.8.8.8 from router. Can you upload ouput of traceroute/tracert 8.8.8.8 from some of your LAN device, thanks.

Best Regards

Please rate all helpful posts and close solved questions

Best Regards Please rate all helpful posts and close solved questions
New Member

Re: Cisco 1841: Can ping ip addresses but cannot connect to the

tracert

------------

Tracing route to google-public-dns-a.google.com [8.8.8.8]

over a maximum of 30 hops:

  1     5 ms     5 ms     5 ms  192.167.18.221

  2     5 ms     5 ms     5 ms  41.202.226.93

  3     4 ms     5 ms     5 ms  41.202.226.5

  4   194 ms   195 ms   196 ms  gigabitethernet1-0-3.marcr1.Marseille.opentransi

t.net [193.251.251.197]

  5   189 ms   187 ms   199 ms  gigabitethernet13-2-1.marcr2.Marseille.opentrans

it.net [193.251.133.209]

  6   190 ms   189 ms   188 ms  tengige2-15-0-9.pastr1.Paris.opentransit.net [19

3.251.131.217]

  7   192 ms   187 ms   187 ms  google-10.GW.opentransit.net [193.251.250.44]

  8   205 ms   188 ms   189 ms  72.14.239.145

  9   186 ms   189 ms   186 ms  209.85.245.70

10   193 ms   197 ms   192 ms  209.85.245.87

11   193 ms   192 ms   192 ms  72.14.238.43

12     *        *        *     Request timed out.

13   193 ms   192 ms   192 ms  google-public-dns-a.google.com [8.8.8.8]

Trace complete.


sh run

-----------

Current configuration : 1564 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname CATHOLIC_RELIEF

!

boot-start-marker

boot-end-marker

!

enable secret 5 xxxxxxxxxxxxxxxxxxxx

enable password xxxxxxxxxxxxxxxxxxxx

!

no aaa new-model

!

resource policy

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

ip cef

!

!

no ip dhcp use vrf connected

!

!

ip name-server 51.202.229.132

ip name-server 51.202.229.130

!

username xxxxxxx privilege 15 secret 5 xxxxxxxxxxxxxxx

!

!

!

interface FastEthernet0/0

description CRS  LAN Interface

ip address 192.168.5.1 255.255.255.0

ip nat inside

duplex auto

speed auto

!

interface FastEthernet0/1

description ISP Internet Link

ip address 192.167.18.222 255.255.255.252

ip nat outside

duplex auto

speed auto

!

interface Serial0/0/0

description OLD INTERNET LINK

ip address a.b.c.d 255.255.255.252

shutdown

!

interface Serial0/1/0

description redundant

ip address w.x.y.z 255.255.255.252

shutdown

!

interface Serial0/1/1

no ip address

shutdown

clockrate 2000000

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.167.18.221

!

ip http server

ip http authentication local

ip nat inside source list 1 interface FastEthernet0/1 overload

!

access-list 1 permit 192.168.5.0 0.0.0.255

access-list 1 permit 192.168.0.0 0.0.0.255

!

control-plane

!

!

line con 0

password P0ssw0rd

login

line aux 0

line vty 0 4

privilege level 15

password xxxxxxxxxxx

login local

transport input telnet

!

end

Re: Cisco 1841: Can ping ip addresses but cannot connect to the

Hi David,

Config looks good. traceroute output is from your router, right? Can you upload traceroute from PC in your LAN, I think that internet connection works but your DNS config is probably not correct.

Do you use DHCP in your LAN? I dont see any DHCP config on router. Did you staticly configure your LAN PC? Can you upload ipconfig with traceroute output which I asked earlier? thanks

Best Regards

Please rate all helpful posts and close solved questions

Best Regards Please rate all helpful posts and close solved questions
New Member

Re: Cisco 1841: Can ping ip addresses but cannot connect to the

That tracert I uploaded is from a PC in the LAN

Yes I use DHCP in my LAN. DHCP is setup in windows server.

Re: Cisco 1841: Can ping ip addresses but cannot connect to the

Hi David,

If traceroute output is from LAN PC, I would expect that first hop will be 192.168.5.1, not 192.167.18.221 which is ISP gateway.

Can you please upload these output from LAN PC:

ipconfig /all

route print

ping www.google.com

Also as pdriver suggested to try crosscable, I dont think it will be necessary cause it seems that connectivity is up.

Best Regards

Please rate all helpful posts and close solved questions

Best Regards Please rate all helpful posts and close solved questions
New Member

Re: Cisco 1841: Can ping ip addresses but cannot connect to the

Yes you are correct. It was the router tracert..

Re: Cisco 1841: Can ping ip addresses but cannot connect to the

Hello

Yes please remove the static mac

And try a crossover cable from router to modem

Res
Paul

Sent from Cisco Technical Support iPad App

Please don't forget to rate any posts that have been helpful. Thanks.
New Member

Re: Cisco 1841: Can ping ip addresses but cannot connect to the

Don't have a crossover cable here.

Will let you know when I try that

New Member

Cisco 1841: Can ping ip addresses but cannot connect to the Inte

Hi,

Its a DNS issue....try to config 4.4.4.4 as ur DNS in your laptop and even in router. it should work.

Regards,

Satya.M

5779
Views
24
Helpful
27
Replies