Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 1841 Dynamic IP

I have a cisco 1841 router I brought home for the weekend to play with from work. I set it up at work just fine with a static ip from my isp. However at home I don't have a static ip. I got it all configured and set interface fastethernet 0/0 as my wan and set the ip address to dhcp. I have nat turned on as well. I set up fastethernet 0/1 as my lan. I also setup a ACL to permit any and overload on fastethernet 0/0. from the router I can ping www.google.com and 8.8.8.8 and get responses. On my computer however I cannot get responses. I can however ping the router. What am I missing?

 


Current configuration : 911 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
dot11 syslog
ip cef
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
interface FastEthernet0/0
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.10.1.253 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 shutdown
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
!
!
no ip http server
no ip http secure-server
ip nat source list 1 interface FastEthernet0/0 overload
!
access-list 1 permit any
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 login
!
scheduler allocate 20000 1000
end

 

Thank you

5 REPLIES

What is the IP settings of

What is the IP settings of your desktop/laptop? It should point to the router as default-gateway then you could point the DNS to your ISP DNS server.

New Member

i tried setting my desktop

i tried setting my desktop with a static and no luck with the dns server set to the router. I also tried 8.8.8.8 as the dns server with no luck.

hi,try this:no access-list 1

hi,

try this:

no access-list 1 permit any

access-list 1 permit 10.10.1.0 0.0.0.255

I tried to configure this

I tried to configure this over a lab and I was able to get positive results with ACL 1 set to any but you may still want to try johnlloyd_13's suggestion.

 

However, what I tried to do in my lab is to set the customer facing interface of the ISP to no ip proxy-arp since your default route is just pointing out to exit interface. When I turned on proxy-arp on the ISP router then I was able to ping anything on the ISP side. Apparently, you have mentioned that ICMP from the router works fine so we could eliminate proxy-arp issue at the ISP side.

 

What I can suggest is to turn on NAT and ARP debug to see if you are translating your internal network properly.

New Member

I figured out my issue, on

I figured out my issue, on the ip nat source list 1 interface fastethernet 0/0 I didn't type in inside. I also fixed my ACL to be more specific.

 

Thanks for the help!

413
Views
20
Helpful
5
Replies
CreatePlease login to create content